[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

dth_lighting

(Josh) #1839

this thing is awesome! got it flashed, wired up, smart apps and device handlers (both of em) installed, but the virtual switches wont respond. I can program em, create em, but they wont do anything when turned on or off… anyone have any ideas as to what I’m doing wrong?


(cjcharles) #1840

I’ve been thinking some more about this, there are other ways to do the AP broadcast config, but actually the current one has a number of benefits.

If you keep the Wi-Fi details and don’t do anything (like broadcast AP) when there is no Wi-Fi connection, then changing your house Wi-Fi credentials becomes quite a challenge, and even more so if you disable the two reset processes. If you do disable them then you need to do a full wipe and reflash of the ESP which is quite annoying. I think for now I will leave it with current functionality, but can always look again if there are more people wanting a change.

Bear in mind that if somebody does connect to the ESP when it goes back to AP mode, then as soon as they change the code (E.g. To make it malicious) they will lose the Wi-Fi credentials and hence can’t do anything with particular consequence except flash a light… IMHO…


#1841

Once I’ve had a situation when two out of three H801 (that I had at those moment, with eric’s firmware) were reset to defaults on the power surge. I guess, my electric company tried to switch their breaker multiple times within few seconds, which caused H801 to treat this event as a reset sequence for itself. I had to re-configure them from scratch.

Here is my suggestion:

  1. If IP is configured AND it is not 192.168.4.1 AND SSID is stored - never enable its own AP and always/constantly try to connect to WiFi using saved credentials.
  2. Remove this power-based reset option, mentioned above.
  3. Make/keep only two reset options to default:
    3a) Hardware reset via J3 jumper. Exact actions are up to you (like 3 presses within 30 seconds after powering on). Most of the users are technically savvy to complete this sequence, when needed.
    3b) Software reset via UI interface. If you know the current IP and want to reset it to default to reconfigure.

(cjcharles) #1842

Sadly the power based reset method is the only option for quite a few devices since there is no jumper for resetting settings. Also, if it doesnt go back to AP mode then you can never change the WiFi credentials and I think that is a far bigger problem for most people. Given it doesnt have a display of any kind, it needs to fall back to something which is predictable and easy to manage, if you lose the access point (or dont know what it was set to before) then it can be impossible to reset. Maybe I’ll sleep on it for a bit!


(Malek Fahl) #1843

I have this issue right now. I changed routers and now my h801 needs to be reprogrammed but it won’t let me. I tried doing the reset with cycling power 4 times, the red led flashed 5 times and it looks like it’s resetting, however it doesn’t. I can’t get into the config screen in the browser. Also tried the j3 jumper on power up, same thing happens. I either have to reconfigure my network to the way it was, or throw this away and flash another one. Heck, I even tried to reflash it and it won’t go into flash mode. I’m wondering if it was a setting I picked in the config screen keeping me from reflashing? Was there a disable j3 setting? I forget.


(cjcharles) #1844

There is a setting to disable J3, but if youve just changed your WiFi then you shouldnt need to reset it. Just leave it for 5 minutes (or less) and it should start re-broadcasting its access point which you can then use to set new WiFi credentials.


(Malek Fahl) #1845

It does rebroadcast, but it won’t let me into the webpage to change settings. It’s weird. That explains why I can’t use j3, I probably enabled that. It accepts the login when I try to connect, but then it comes up with a page that says rejected request or something similar.


(cjcharles) #1846

Is this related to a password on the config page or something? I dont know why else it wouldnt let you get into that page. Possibly the config password got reset to garbage, however the password enable flag didnt get reset… You could try a string of 26 ASCI_255 chars, or blank password since that should be the default.

It should still go into flash mode when you short J3 during powerup, just make sure you get RX/TX the right way around. If you find that doesnt fix your config settings then make sure you do a wipe before the re-flash, since that will ensure there are no saved settings.


(Anick08) #1847

Might I suggest for those that do not care to buy extra stuff, or reflash their device to simply Use IFTTT?

The MagicHue IFTTT app connects your Magic Home app, and you can make an applet that uses a virtual switch in ST to control the actions of the LED Strip.


(Malek Fahl) #1848

It came down to me using my mobile phone to try and connect to it. Used a PC and I could connect fine, it’s just weird that I could use my mobile before.


(Eric M) #1849

Special thanks to @cjcharles for all of his additions to this project. I have merged all of his changes to the master branch. Thanks!


(cjcharles) #1850

Need a bit of an update to the first post. I’m happy to do it if you want and can message you the changes if you don’t have time, but everything can now use the same firmware as you well know. :grinning:


(Eric M) #1851

If you could, that would be great! Man, I owe you big time. :wink:


(Keith Croshaw) #1852

Anyone here with the FVTLED’s? I’ve been trying a few things without much luck. I’ve got Apple Homekit turning them on and off through Homebridge but I would love better ST integration. Still searching for a solution that doesn’t require an application running in the middle.


(cjcharles) #1853

Just replace the FVTLED RGB controller with an h801 and it will do what you want. Can keep everything else the same in the wiring and power supply.

If you need to make it waterproof you can even buy the waterproof cable connectors that they have used. I bought some for another garden project of my own.


(Keith Croshaw) #1854

That’s an interesting proposal. I’ve never waterproofed anything before. Is it small enough to maybe fit in the existing housing?


(cjcharles) #1855

If I was you I would buy a waterproof box (ip65) and some cable glands then you don’t need to cannibalize one device to make the other. It might not be so pretty or small but it’s easy. You just need to find the right waterproof connectors for the cable.


(JAAS666) #1856

This is great. Flashed and got them running without mayor issues. What I’m having trouble is with the “easy” part.

Finding ways to use the LEDs. It’s been a bit harder to figure out than I anticipated.

For example I want a program to run when a door opens.

I used the smart lighting app to run the police lights program (running 6 times and set to turn off after it runs). It correctly runs when the door is opened but leds remain on after the program runs.


(Ryan Munday) #1857

Webcore will do what you want considering you have an automated off condition.

Ryan


(JAAS666) #1858

Was hoping to get it done without webcore but looks like that’s the only way