[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

dth_lighting

(cjcharles) #1799

Yes, it should work with all ESP based devices, I have one Arilux device (not sure of model number) I will try with that and see what happens to it. I expect the firmware will work fine with the LC02s, but it might need manual re-flashing first in case there were different compilation settings used. Otherwise you can try and use the power cycling reset method (turn it on and off 4/5 times, make sure to turn it off within about 2s of turning on). Does it flash at all or is it dead to the world?
What did you fill in on the forward requests option? Did you forward them in a circle, or all to a single device or something? Do they work when you only turn on one device at a time (rather than all on at once).


#1800

No, they are all dead to the world. The power off on trick does not work. For the forward I forwarded 1>2>3, 3 wasn’t forwarded to anything so no circle. I tried a manual flash and halfway through it gave an error, now it is completely dead to the world. I haven’t tried the other two yet. Unfortunately the H801s will take a while to get here but from what I hear they are more reliable and a better solution.


(Eric M) #1801

Mine were all created with 1M (64K SPIFFS).


(Darren) #1802

thanks @cjcharles for the advice/recommendation.


#1803

@cjcharles @njaslyr I flashed six H801s yesterday, so far so good. I’ve set up custom colors on boot, and they seem to perfectly follow it. :slight_smile:


#1804

Thank you for the info. I believe when I receive the H801s they will work better than the LC02s that I had.


(cjcharles) #1805

I have updated the file on my Github to use a 64k SPIFFS partition (it will increase write wear, but given the SPIFFS usage is so low it shouldnt have a significant impact unless somebody updates their settings every minute!).

@njaslyr that said, I just used the new firmware on an Arilux LC02 and it has also killed mine, hence there is something very funky going on for sure!! At least I can re-produce it and hence look at what is going on! EDIT: Ive even set the chip to flash with all settings relevant to 8285 (should be backwards compatible with 8266), but it still crashes when it reboots, so it seems the 8285 needs very custom firmware… curious!!


(cjcharles) #1806

Ok, have uploaded a version of the firmware which is compiled for the 8285 specifically and even though it has exactly the same settings it does seem to now work on the Arilux LC02.

It is also backwards compatible with my 8266 H801 controller, hence I think going forwards I will just give everybody the 8285 version and stick with a single firmware.


#1807

Thank you! Two of the three I had were just too far gone with the solder pads since they are so small on those models. However, the third was able to flash with the new firmware and save it. Thank you for working so hard to get a firmware that works this well.


(Akash) #1808

Is there anyway of getting different transitions? I’m trying to get my strip to have a run effect. Essentially turning on one led and turning off the one before very quickly?


(Anthony Rossetti) #1809

Does anyone have any ideas why my H801’s keep on getting “stuck” in the off position and won’t turn on?
If i try and control the main device/controller as a whole as in on or off through the ST device handler interface or through alexa or the alexa app it does not respond or turn on
but if i go to one of the R G B sliders in the device handler interface and slide it up it respond.

Then if i leave it idle for a few minutes and try to switch it off i get the same problem it won’t switch off , but if i go and move one of the R G B sliders again and then hit the main controller off button it responds.
could this be a device handler problem or is it with smartthings itself or could it be my router?

The one i have in the bedroom is much more reliable than the 3 i have in kitchen
the bedroom one almost never refuses to turn on or off , the one I 1st flashed was one of the kitchen ones and it was really buggy at first but then after like a week it just started working most of the time almost flawlessly , the 2nd one i added was the bedroom and it was working nearly flawless too
but once i added the 2 other H801s for the kitchen cabinets everything got really unstable.

The 3 kitchen controllers never respond to on commands through the voice assistants or their apps or even through ST or won’t turn on or won’t change with voice assistant commands unless i give the command multiple times
i am not really sure what is going on


(cjcharles) #1810

How come you capitalised h801 but didn’t put in any other punctuation until end of paragraph?


(Anthony Rossetti) #1811

I am really getting sick of you grammar nazis
I’m looking for technical help not writing a novel


(might be my fake name?) #1812

@cjcharles has a point. It makes it hard to understand your posts when your entire post is a run-on sentence with very little punctuation.

I kind of get what you are saying and I want to help, but it’s frustrating trying to decipher your word blobs. Sorry.


(Ryan Munday) #1813

Literally take 2 more minutes to type your question. You’re asking for free help; the least you can do is use accurate grammar and punctuation.


(Rahul Dave) #1814

Hi Vlad -

Which FTDI are you using to flash ? I tried YP-05 but it does not work and error with:

warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

Thanks
Rahul


(cjcharles) #1815

Sounds like either you have RX/TX the wrong way around, or you are not resetting the ESP into flash mode by using DTR and/or gpio0 being grounded. Or both I guess!


#1816

@RahulDave I use FTDI adapter by Adafruit.

Interesting, that I did not have any problems initially re-flashing the original with eric’s version, but indeed had the same problem with the binary file from @cjcharles. Ended up using web UI for each H801 to flash it.


#1817

@cjcharles not a chance I had them swapped, I use even the same wire colors as in post 360. :smile: If the latter (resetting the ESP into flash mode) means to have J3 jumper installed - yes, I had it. Otherwise please, explain.


(Steve ) #1818

Hey @cjcharles have you noticed any odd behaviour with the H801 and your firmware and DH?
My two main ones wouldn’t turn on/off with the main button it only displays turning on/off but would turn on if i hit a colour inside.
And they stopped responding on my wifes app even though they were coming on with my app so i had to delete the devices and re add but stool no on/off function.
Edit.
Oh and i also use a smartapp caked simple device viewer that alerts me when a device isn’t reporting after 24 hours and before i updated i never got aalert for any H801’s but now i get alerts for all of them about not reponded for 24 hours.