[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

dth_lighting

(cjcharles) #1717

Yup! (ST makes me write 10 characters)


#1718

I’m getting some errors compiling the sketch.

class WiFiManager’ has no member named ‘setContinueAfterTimeout
class ESP8266HTTPUpdateServer’ has no member named 'setProjectName

@erocm1231 , Can you share your WiFiManager and ESP8266HTTPUpdateServer libraries? Or your edits to them?

I’m guessing those are the ones you modified.


#1719

Hi,

I’m able to connect the controller to wifi and control the led lights through the browser but I’m not able to to find the controller using app. It keeps searching for it but doesn’t find it. I tried both automatic and manual IP adding.
Please help.

Thanks


(Sylvain) #1720

Did you install the smartapp sonoff connect ?


#1721

I have SmartLife RGBW Light (Connect) installed


(Eric M) #1722

You can comment out the “setContinueAfterTimeout” line out. It is a feature that I haven’t finished yet. Same with setProjectName. It is completely aesthetic so that the web interface had the project name at the top.

@Steveuk23 I tried doing some basic stuff with SmartThings scenes and webcore and I didn’t notice anything out of the ordinary. For webcore I just used “setColor” with some of the predefined colors (orange, purple, blue, etc.). Is there something specific you would like me to test?


(Steve ) #1723

Thanks for the testing @erocm1231
The issue with my scenes is it tends to set the brightness ok just not the colour
This is my test scene --»


I set all my levels to 100%

But it just doesn’t go to the colour in the scene the brightness will change sometimes it will do the colour correctly but then turn the white on…
This is one of the results I had when testing from 100% levels and the colours were correct but the white came on.

But it just seems random what colour is set it seems to vary depending on what colour the device is already on when the scene runs.
Thanks for looking into it.
What I wanted to achieve in WebCore was
If the SHM gets a intrusion then to turn the device red for a few minutes then go back to whatever the settings were beforehand whether that was the device off or on with a colour ,but the restore attributes just do similar to the scenes :frowning:


#1724

Hello @erocm1231, have been using quiet bit of your work in my home automation setup.

I had a question, I am currently only usin w1 and w2 only for my usecase (CW and WW).i was wondering if anyone has a easy way of changing the controls from choosing color brightness to being ab;e to set a color temperature. I assume this needs to be some sort of formula that translates the temperature control to brightness percentages for each of the colors.

Here is a visual example of what I’m referring to, I can currently do this for the sengled bulb and hue white ambiance bulbs.


(cjcharles) #1725

That would be quite difficult, since with Hue bulbs the W1 and W2 are calibrated (or known) in terms of their colour temperature. With the H801, everybody will have different light strips. What might be possible is to have a slider which allows you to set the relative brightness between the two strips, and then the brightness is controlled through existing sliders. I assume that would still give you what you are trying to achieve?


(Sylvain) #1726

Yes smartlife , ok then sometime it will take some time , 5min or more ,and i know yesturday smartthings clouds was having problem , maybe that was your problem. Check here https://status.smartthings.com/ .
Did you fix it ?


(Patrick Mjoen) #1727

Still waiting to see if anyone can suggest the US power adapter for this?


(Michael Hess) #1728

I recommended one in my linked post from post #1, as well as some advice on choosing one. Don’t get the cheapest you can find.


(Michael Tan) #1729

So you have to flash it first? ;( Don’t have the stuff for it


(Eric M) #1730

Hi @Steveuk23, can you make sure that you have the latest device handler installed. Those are some strange results. I’ll do some more testing too.


#1731

Anyone else finding that after last update only W1 is being used?

I have a WC Piston to switch on and select random colour which use to work but now only switches on W1 and nothing for R,G,B?

36


(Rusty Phillips) #1733

Okay…I’m getting to my wits end here. I really hope someone can help me, or has any kind of clues of what I can try.

First of all, let me say that I’m the author of this integration: [RELEASE] New Milight / Easybulb / LimitlessLED integration
…and I know my way around writing arduino code. I don’t typically think of myself as a newbie, but I must be missing something simple, because this thing isn’t doing anything, and I haven’t seen a problem like this in the thread. I think it might be an electrical problem.

THE PROBLEM: No matter what I do, the lights never come on.
PARTS: H801 (tried three of them)
Meanwell 12V 10A power supply
32A RGBW repeater (https://www.amazon.com/gp/product/B00NOHZJZW/ref=oh_aui_search_detailpage?ie=UTF8&psc=1)
LEDMO SMD 2835 Warm White Strip, 9M (someone on Amazon claimed 2.85 amps/5M, and the repeater can handle 8A per channel).

Things that work:

  1. Using the original firmware, I can see the controller on my wifi network for one of the H801s.
  2. Using the new firmware, I can see the controller on my wifi netowrk on a different H801.
  3. Directly connecting the power supply to the lights causes the lights to come on fully.
  4. The red light on the controller and the repeater light up, and both read proper voltage on VCC.

Things that don’t:

  1. Using the original firmware, if I turn every channel to full, I see no voltage out on the multimeter on any of the channels (shouldn’t I)?
  2. Using the new firmware, if I turn every channel to full, I see no voltage on any of the channels.
  3. Using either H801 without the repeater does not cause lights to come on.
  4. Using either H801 with the repeater does not cause lights to come on.

Does anyone have any ideas of what I can do to solve this problem?


(cjcharles) #1734

I’m going to put down a few questions to check and see if that helps narrow your problem down.

  1. Does the h801 work from the webpage, or were you trying to configure it through ST? (Suggest leaving out the ST part for now)
  2. Given you get similar problems with and without the booster I’d leave it out for now while testing.
  3. You only have a single colour LED strip, hence you just have ground and power going to the strip from the h801?
  4. When turning the channels on using the sliders on the webpage you should see 12v coming through the W2 W1 pins on the h801. Do you get it on any colours rather than white? Due to high frequency PWM the voltage will appear lower on most multimeters as they sometimes can’t cope with the voltage fluctuations, but you should get virtually 12v when fully on.
  5. Where did you buy the h801s from? Are they all from a single order? There is a lot of fake Chinese stuff on the internet (as you know), perhaps you picked a dodgy seller.
  6. Might be worth checking cables, sometimes you can get a break in one cable and it will stop everything, but can be hard to detect. Maybe that is confusing things…

(Rusty Phillips) #1735

I don’t have any colors other than white attached, so I don’t get anything other than white.

But…I managed to figure it out. I’d assumed that the controller works by bringing the signal high when it’s on, and so you’d connect the ground and the signal wire to the strip.

After a long time checking with the multimeter, I see that it’s actually reversed.
Positive goes to V+, and negative to the signal pin. With that, it works.

…only took a year to figure that out.


(cjcharles) #1736

Haha funny, I never actually looked at a unit to say that, and it’s less obvious with w1 w2 since they don’t have a 12v source next to it. Having a single colour strip will also be confusing as you will just see positive and negative, rather than colour1, colour2… And 12v.

For your info the reason the colour pins go to ground rather than 12v is because the transistors (used to turn on and off each colour) are typically more efficient at sinking current (hence need to be connected to ground). They are also much easier to control since the gate voltage only needs to be small (0.6v or so), as opposed to 12v or so.


#1737

Is there any way to run a program and have it return to the previous state after the program finishes?

I’m trying to create a visual indicator - for example, flash the lights behind my desk when my washer indicates that it’s stopped running. As it stands, the lightstrip defaults to a very dim blue upon completion seemingly no matter how I configure the program.