[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

dth_lighting

#1676

Gentlemen,

Please advise upon the default behavior upon executing a program and previous color states.

The desired functionality is as stated in the first post:
Upon contact sensor (door) opening, a program is executed, after program is finished or stopped, the controller should return to previous before program colors.

However, the behavior observed for example on the program 1 police lights: program executes and upon stopping program the controller will be either blue or red depending on the timing of stopping the program.

Programs would be ultimately more useful to have a toggle between “pre program color or last program color”

This could be a setting within the programs section or controller global.

@erocm1231 Is this a request a feature that could be implemented

The challenge of returning to previous color is also present within webcore. The virtual device dimmer offers the functionality of manually specifying the colors. Powering off and on retains previous color, however programs result in a unpredictable color after execution.

Has anyone been able to accomplish the aforementioned via webcore or other means?


(Steve ) #1677

I’ve tried but it won’t work either with WebCore or the SmartThings scenes.
It’s apparently to do with SmartThings using a colormap for setting colour but the device handler is set for hex , but it looks like there’s lines to do the maths to change it but I don’t think it’s working.
Wish I knew how to code it but it’s beyond me.


(AaronW) #1678

I experience the same issues. I have used WebCoRE to manage my H801 lights. Having to set each RGBW hex, and level is a pain. The default pre-colors do not work for me or atleast do not display correctly. Part of the many bugs still in the system. BUT I can’t complain that I implemented under/above cabinet custom lighting for under $70.


(Anthony Rossetti) #1679

@ercom1231 hey Eric is there any chance you can try and fix your smart app
it does not work for me at all now , after much headache getting one H801 to work months ago i bought 4 more and now i am having the same issues all over again , only worse
the smart app does not detect the controller , and if i add it manually like i was able to do before it just says that it is not fully configured still.
there is no way to get it working
i log into the controller using my browser and i go to the advanced settings tab and i entered all the fields manually like i did before but it still does not work either with autodetect or by manually adding it through the smart app , it just says "not fully configured’ and i can not control it through ST ,only from my browser

could you please work on the code or provide us with some alternate instructions to get these things to work?
it is really aggravating

EDIT: ok i can get it to control through the device handler
but i can not configure it in the smart app still and in the device handler there are dashes where the device IP should be and where the firmware should be

also when i go into the IDE and my go to my devices and click on the controller i noticed that there is no MAC address listed in there

the other controller i set up has the MAC address listed under where it says “port 80”

can anyone help me to get these added without the smart app? or to get it working with the smart app another way , it just says not fully configured when i click the device in the smartapp even after i do everything manually
and enter the device IP , subnet , gateway ,HA controller IP in the advanced tab through the browser interface

last time i entered everything manually it worked but last time the HA controller IP was in already there this time i had to enter it

and why does it not show a MAC address in the IDE?

also now i just noticed that under automation the smart app is showing up twice , is this supposed to show up twice? maybe this is causing a conflict?

EDIT: note that there was only one copy of the smartapp when i first tried to get the second controller working , i figured out that if i try and go to the smart app through marketplace>smartapps >my smart apps it will add a second copy of the smart app under the automation tab every time i go into the marketplace>smart apps>my smart apps tab
every time i go back there another copy of the smart life app is on the list under automation smart apps ,there were 5 of them in there at one point i called smart things support and they got rid of them for me but it still does not work , the smart app is broken and does not work at all the devices always just say not fully configured


(Michael Hess) #1681

You keep adding the app, don’t do that. You do the marketplace one to install it, then access it through automations from them in.

The app is fine.

Remove everything, the smart app from the st app, the devices related to it from the IDE. Reinstall the SmartApp and wait until it discovers, literally 5 or more minutes. If it still doesn’t find then, it’s very likely a network issue related to SSDP failing.


(Anthony Rossetti) #1682

thanks but nope i did all that a few times and it still does not work and SSDP is fine
everything else works
the smartlife smart app does not work
but i finally did get it working
but this time i not only had to log into the controller and enter the controllers IP address, subnet mask, gateway ,HA controller IP , set static IP to yes
then set the IP to static in the router
but then i had to get the MAC address of the controller from my routers client list and then go into the IDE >my devices> find the controller , go to edit and then enter the MAC address in the device network ID field minus the colons
then go the smart app and add it manually and it finally worked

the last one it already had the MAC address/device ID i did not have to enter that manually before

maybe Eric can update the OP with these manually instructions so anyone else having these issues can find them


(Michael Hess) #1683

What you describe does in fact mean SSDP isn’t working correctly on your router. That’s what discovers the Mac/IP to allow the app to fill the information. It’s a breakdown between the ST hub and router.

Glad you got it working manually though.


(Anthony Rossetti) #1684

i know but it works with all of my other devices though
i turned on that IMGP snooping option too and it made no difference


(Alex) #1685

Is there a way to set the default color to turn every channel on max? RGB & W1 W2

I have searched the thread and cant find anything. I got it working with the previous color setting but I would rather have it directly go to that everytime i turn it on. I tried setting a custom color ffffffff (8 f’s) but that didnt work.


(Donnie Mc Culloch) #1686

I’d also like to know if there’s a way to switch RGB and W1 channels on as default, tried everything I can think of, even reading this entire thread which took some time.

My H801 runs two sets of light, some RGBW strip lights and some RGB only plinth lights and I’d like them all to come on white as default which means all the channels on full in one switch. I’ve messed around with the programs but it seems like you can have one or the other.


(Jason) #1687

I have tried searching here but can’t seem to find a clear answer. Is there any way to use the h801 along with remote control (like an IR remote)? I have one that i flashed, but before I replace the magic home controller with this, I wanted to see if there was any way to keep a remote. TIA!


(ShawnB) #1688

Yes something like you are asking for has already been done. Check out this link for the general idea of how to accomplish it: https://n8henrie.com/2016/02/fauxmo-home-automation-with-the-amazon-echo-raspberry-pi-and-homeassistant/

Basically by using an ESP-01(ESP8266) combined with this arduino library from https://github.com/kitesurfer1404/WS2812FX and maybe Fauxmo for voice control and a little tinkering of the code, you could make a simple and still inexpensive device to do what you are wanting it to do.

It would make it similar to a Pixelblaze with opensource hackable code, but give you dot pixel animations and colors using 2812’s.

This all sound like a great new kickstarter campaign! Who is willing to take it on?


(James) #1689

I have 5 of these strips that have been up and running for at least 6 months without an issue. However, over the last few weeks the strips have been unresponsive or slow to respond. I have tried to rediscover the devices but they are not showing in the app. Is anybody else experiencing this? Any ideas what might be causing this?


(Steve ) #1690

Strips?
Do you mean the controllers if so sounds like a network issue has anything changed on your network.


(Patrick Mjoen) #1691

Anyone willing to sell an H801 that has already been flashed and ready for setup?


(cjcharles) #1692

Ive still got a few left on my shop where I sell hardware for my other integrations. Will ship anywhere, but it’ll be Royal Mail shipping (hence between 1-9 days depending on where you are in the world), if useful. Though it isnt too hard to do yourself!

https://www.freewebstore.org/smartthings-diy-parts


(Patrick Mjoen) #1693

If I dont have to hunt down all the jumper cables and everything came in one kit that would be great.


(cjcharles) #1694

Yup just apply power and it’ll start broadcasting an access point ready to configure for ST.


(Jason) #1695

@erocm1231I too would like to add to this. Is there a way to set this so that all channels or the RGBW are all set to 100%? I use both the W and RGB when lighting a “white” for max brightness but even setting to the previous state doesn’t seem to work. Is there a way?

Thanks!
-Jason


(Jason) #1696

@azwillnj @Donnie_McCulloch I have figured out a work around using 2 piston within Webcore. While not super elegant, it does work. If you’re still interested in doing this let me know and I can share the webcore backup bin code so you can import it.