[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

Hey :slight_smile:

Sorry to hear that, it’s SUPER frustrating. My device is working correctly after that MAJOR headache when swapping to the new app. I tried everything so I really don’t know what action or group of actions solved the issue.

While I am using the H801 for one set of lights, we’re actually using a simple on/off switch for the lights in the kitchen. I was willing to give up the fade on/off to have it be 100% reliable in that room. The other room with the H801 doesn’t matter much, but to be fair, it’s also been fairly stable since my issue back in October 2020.

I hope you’re able to get it working! Wish I could offer more assistance or information!!

If the devices can’t connect to wifi they will broadcast their AP after a timeout and you can connect it to your new router.

1 Like

The device does appear to be connected to the wifi. I have Nest Wifi some I had to make sure it was connected to the correct point.

1 Like

I am seeing the same behavior of the light staying on the last color when I turn the child device handler (police lights) off. I have the setting correct in the options. If I then go to the master (parent) device and switch it off it turns off, obviously.
I have found that if I limit the program to a fixed number of cycles it behaves as the option dictates, but on a program that runs indefinitely, using the child handler to turn it off leaves it in the last state.
Can you tell me which codeset, and approximately where to look in it to try and fix this problem. I would be willing to try my hand at fixing this.
Thanks

cans someone here please tell me what will happen to my 5 H801’s
come june?
i just got the email that my v1 hub is no longer supported and that groovey and IDE will be going away , so what does that mean for all my controllers?
is smartthings a dead platform now? will everyone here be migrating over to hubitat?
or will they still continue to work?
is there a workaround yet?
should i bother investing a new aotec hub or should i just leave and move over to hubitat if i want these and my smartthings anything devices to still work?
i have 5 H801’s and a bunch of smartthing anything devices ,so are they all just trash now, is this platform just trash now?

i’m no expert here but i think if you set the SSID , password and gateway on the new router to what it is on the old then it should just work
the same information they use to log onto your current network
maybe Eric can confirm
i have been procrastinating setting up my new router so i can not say for sure
i bought the new router in hopes that my H801’s would finally respond correctly becaus ei have a problem with them not all responding ,i had to use 3 for my kitchen cabinets because there was just nowhere to run the wires to have all the cabinets connected to one controller , i mostly use Alexa or Google to control them
but most of the time they will not all respond even though i have them grouped in Alexa and GH ,no matter what i do one or 2 do not respond and i have to ask the assistant twice or a few times to get them to respond , i have tried everything to correct this behavior with no luck , so i am upgrading my router to one of those crazy looking asus 5300 ones that look like the face sucker from alien
but now i don’t even know if they will continue to work anymore come June since ST is pulling the plug of IE and groovy and my hub
i hope there will be some way to keep them working and a good explanation of what needs to be done for people who are forced to start all over with a new hub to get the working

Hi @erocm1231.

Thanks for developing and maintaining this! Just found this for a project. I have a ESP8266 Node MCU ESP-12E that I just flashed with the firmware, setup the device, etc. However, I have a strip of regular WS2812B. It has power, ground and data. How would I configure this single data pin for the app?

I think the WS2812B is not compatible. The H801 and other controllers that this firmware supports works with “pwm” LED strips and not “pixel” based strips.

Thank you for your quick reply @erocm1231. I know you are busy so I appreciate the additional information. I can pick up one of those strips to test. Is the advanced section of the configuration that shows pins compatible with the ESP-12e? That is, do those pin #'s correlate with the GPIO pins listed on the EPS unit?

Yes, they should correlate with the bin numbers on the ESP.

1 Like

My H801’s were still working after they shut down support for my gen 1 ST hub,for a few day at least.
but now they no longer work for the R G B and W channels ,however the programs such as fireplace, lightning ,rainbow all still work, but I can not control any of the channels, this is really strange.

I have not got around to setting up my new Aotec hub yet
I would like to get some answers as to what will happen to this project once they shut down the IDE and custom DTH’s

Is there some application process where developers like Eric can submit their project to be included as an official device handler?

I thought they were ending support for the IDE and custom DTH’s on Jun 1 2021 ,the same day as they were pulling support for ST hubs , but I guess they are not pulling support for those until later this year.

I really do not want to go through the bother of setting up the Aotec hub if this project (and other community projects) is no longer going to work , I rather sell the hub as it is new in box
I rather sell the Aotec and move to hubitat If there is not going to be support for these community projects ,
So does anyone have any information yet on what is going to happen to this and other projects that use smart apps and custom DTH’s yet?

EDIT:

Ok guess they are moving to edge which is lua based.

So will it be difficult to port over these groovy based projects to lua to work with edge?
sorry I don’t know about groovy ,java , or lua laungages.
So would there even be a way to build a tool that can automatically port these groovy DTH’s to lua? or would it all need to be done manually?

Could you please help me to get my H801’s working again
I have 5 of the older ones circa 2017 , they have all stopped working with ST since they pulled support for the v1 hub.
I set them up when I had the v1 hub
then they all stopped working with ST but still work from the web interface if I put the IP into the browser.
I just updated to the new Aotec hub today.

It was assigned a different IP address than was entered in the config settings of the controller by my router ,my old v1 hub had a static IP set for it in my router and it was still reserved so I deleted it from the static IP list and then I added the new hub to the static IP list and gave it the same IP address as the old hub so that the static IP of the new hub matches what is entered into the config settings of my h801’s.
Then I tried to reboot everything and tried it again but I am still not able to get them working again after migrating to the Aotec .
The smart app never worked for me for setting them up and I had to do it manually
I figured the problem was the IP for the hub being incorrect in the config settings but now that that has been corrected I am out of ideas here.

Do I need to change anything in the IDE now since the migration?

EDIT:
ok it appears that all my child devices are there in the new app but not the controllers themselves.
I had an issue that was not resolvable on my end where my old hub was still showing up in the IDE but not in the app, I had to have ST support remove it for me because it was giving an error on my end when I tried to remove it and I was not able to add any of my zwave or zigbee devices to the new hub, that is now fixed
after they managed to delete my old v1 hub.
Now the child devices for the H801’s are still showing up but are not controllable and the parent devices, the controllers themselves are gone.
I have tried using the smartlife connect smartapp to try and re add the controllers,
if I hit discover it finds all of the devices but if I click next in the smartlife connect smartapp
nothing happens and then it crashes the whole ST app ,going back doesn’t work I have to close the ST app and open it again and try again
I have also tried to add them using the add manually option but after entering the IP of one of the controllers and hitting next it does the same thing as when I use the discover option , I just get A black screen and the ST app crashes.
I logged into the web interface and everything is set correctly, I set the static IP of the new hub the same as my old one so it matches in the controllers
I am using FW version 2.0.6 on the controllers
is there any way to add them back without using the smartlife connect smartapp?
I figured since they were all configured in the web interface they would just work
but I didn’t realize that only the child devices were still there and not the parent devices.

here is the log from the IDE when I try and run the smartlife smartapp and add the devices

1 Like

have the exact same problem. I tried rebooting router, hub, led controller.

nothing helps.

I even removed smartapp and DHs and tried a previous version from GitHub and nothing.

The auto discovery wont find anything. If I add the device manually I get the message

Device has not been fully configured. Please make sure the device is powered on and has the correct ip address. When confirmed, please com back to this page.

If I go to the device I’m able to save settings and the settings are displayed on the IDE page (transition, transition speed, etc.) So I know the device is there and ST hub can interact with it.

I can also turn the leds on/off but if I try changing color a “loading” icon comes up and eventually times out with the message A network or server error occurred. Try again later.

This has been working flawlessly for a couple years. So I have no idea what could be the problem.

1 Like

Hello,

Hoping someone here could help answer what I believe is a simple question revolving around this integration. I think the answer is yes (due to it being based on the old groovy code).

Will this integration stop working after smartthings moves to full “edge” drivers?

Thank you all ahead of time!

1 Like

I second this, I have just received the email today that says they are making major changes to the platform and that all smartapps and custom device handlers will stop working come October 15th ,( aside from smart lighting and severe weather alerts which will get an equivalent, or be migrated, but I assume all smartlighting automations will need to be set up again).
I am wondering if this project is going to be supported with edge drivers and if there are any plans in the works for a migration path for these devices.
The email was pretty vague and did not mention the shutdown of the IDE and groovy but I assume that is what will be happening come October 15th, despite all the denials I received from Smartthings support agents about that not happening, seems the rumors turned out to be correct despite all the denials and silence even here on the forums.
hopefully it will not be too difficult to migrate this project over.

I’ve flashed my devices (H801 and Sonoff) with Tasmota and they’ve been working well with the Tasmota edge driver. Nice to have them operating locally.

1 Like

Unfortunately I don’t have time to continue developing this project. Using Tasmota as mentioned by @remys is probably the best bet.

Yeah I have heard of Tasmota but I would have no clue where to begin on setting that up
for my H801’s which GPIOs are used for each of the channels tc. and
would it even be able to support the programs feature and would it work with Alexa and Google assistant ?
what about using WLED ,I know it is used for addressable strips but is there an option for RGBW if you don’t want to use an addressable strip?

What are the odds someone else in the community could “port” this project to edge?
I understand this is written in java, not sure what edge drivers would need o be written in, would you even have the technical expertise to port his over to edge or would it involve a steep learning curve and learning another language?
how many people will have the skills to port groovey code to edge drivers?
not really sure on the difficulty level here.

Could you please provide the .bin file for the H801’s are they all the same or were there revisions , I forgot now
and did you need to use the header and a USB to serial adapter to do the flash or did you just upload the .bin through the web interface for the controllers?

I used the FTDI adapter connected to the board header, then the web flashing tool. Very quick and easy.

Instructions

tasmota web flashing tool
https://tasmota.github.io/install/