[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

There are new options for programs that allow you to have the program return to the previous color before the program, stop at the last color of the program, or return to off after the program. You might need to update your SmartApp to specify which option. The last option sounds like some quirk with the new app that might require you to force close it, clear cache and data, or switch the device handler to something else and then back (or a combination of the above). Honestly there is some mystery on how to fix this and many people have problems with it.

@jasonc Is there anything unique about your network? Business grade router or wifi, wifi repeaters, etc? Usually when the SmartApp can’t find the devices it is because something on the network is interfering with ssdp. You also might want to reboot your router.

I’m running on an orbi mesh network. I haven’t had problems detecting other devices, but I can try a reboot.

Just migrated to the new SmartThings app and, you guessed it, I’m having issues with the SmartApp. :cry:

But first… THANK YOU so much to EVERYONE who has contributed to this project. :heart: :heart: :heart:

Here’s what I tried / steps I took:

  1. Removed all H801 devices from within the mobile app
  2. Removed all erocm123 SmartApps from within the mobile app
  3. Removed all erocm123 SmartApps from within the SmartThings IDE
  4. Re-added the most recent erocm123 SmartApp from within the SmartThings IDE using the Github repository integration method (erocm123 / SmartThingsPublic / master). I added the “erocm123 : SmartLife RGBW Light (Connect)” SmartApp and then published “For Me”.
  5. Enabled OAuth for the SmartApp (tried it with and without)
  6. Removed and re-installed the mobile SmartThings app (iPhone)

Then, from within the mobile app:

  1. SmartApps > New SmartApp > “SmartLife RGBW Light (Connect)”

  2. Discover Devices

  3. image001_small

  4. Discovery started!

  5. image002_small

  6. One device found > Next

  7. image003_small

  8. Device selected > Done

  9. image004_small

  10. (Goes back to previous screen) > Next

  11. image005_small

  12. And THIS is the screen it’s stuck at

  13. image006_small

So from here no matter how long I wait or how many times I hit ‘next’ it just sits here. Any ideas? I did try as much troubleshooting as I could before bugging you folks, sorry for such a long post. :frowning:

Thank you in advance for your help / comments / feedback. :slight_smile:

Have you tried doing “Manually Add Device”. That’s what worked for me. You will need to know your device’s IP address to do this.

This usually means there is a problem with the controller device handler (not installed, not published, wrong namespace, etc.) You can watch the logs while this blank screen appears to see what it says.

Thanks! I gave that a try, unfortunately same error. Good idea though!! :slight_smile:

Thanks! I think this might be part of it, I looked in my IDE and the “smartlife-rgbw-controller” isn’t installed. Is this the right one? When I tried to install it from within the IDE, I get the following error:

Me and this new app just aren’t getting along. :frowning:

Edit: So I think part of this is USER ERROR :joy: :joy: that error from above is because I’m mixing up device handler and SmartApp. The device handler was installed, but it was the old version. I’m attempting to remove the old version + link to the github repository and then install the latest version.

Edit 2: Progress! Both the SmartApp and device handler are installed, but now the SmartApp won’t show up as an option to install from within the mobile app. Going to reboot the hub because, hey, that never hurt right? :wink:

Edit 3: The hub reboot resolve the SmartApp piece! Within the ST IDE, it was showing “published” prior to the reboot but showed up as “unpublished” after the reboot (even though I had published it already). I re-published it (again) and now the app is available to install from within the mobile app.

Edit 4: Hey @Derakkon guess what? I needed your suggestion after all! :star_struck: After all of the fixes above, I DID have to manually add the H801 via IP after all. For some reason the automatic discovery doesn’t work now, which is fine, these devices have a DHCP reservation from the router anyway.

Edit 5: Well we’ve made progress! Thank you everyone!! :heart: I was able to add the controller from within the mobile app, but it doesn’t respond to any commands. It gives the error “A network or server error occurred”, image below. I rebooted the hub just to be sure, and force-closed the mobile app but still no dice. I don’t think it’s the H801 LED controller because I can manually turn the LED lights on/off from the web interface with no issues. It also responds to ping from both wired and wireless so I don’t think it’s actually a network issue. I also tried it with and without the “Switch Child Device” device handler, not sure if that should be installed in the ST IDE or not.

Error message:

Live logging entries:
image

I’m not sure why you are still having issues, but I’m pretty sure it’s not the Switch Child Device DTH. Installing that allows you to create child devices for the individual programs so you can more easily control them in the new app.

1 Like

What device IDs have you got for the manually created devices? Perhaps it hasn’t got the IP address correct?

1 Like

Ugh me either, ST hates me this week haha. :frowning: I wanted to use the switch child device but the July 14th, 2020 commit on github (history here) has a
comment that mentions “Changing how child devices are created to work with new app”. So I wasn’t sure if I should exclude the switch child device DTH or not.

.
.

Good question!! :slight_smile: From within the ST IDE > My Devices > the manually created device, this is the device network ID (below):
image

Which looked odd, so I removed and re-created the device and attempted the auto discovery this time. It worked (no idea why it’s working sometimes and not others). Now the device has the actual MAC address for the device network ID. Also further down under ‘Data’ it now shows the mac address along with the IP and port, but it wasn’t showing the mac address there previously.

Now it’s not giving me the network error, but the controller won’t actually turn the LEDs on from within ST. It works normally from the controller web interface. Here is the log data:
image

I’m no developer, but it looks like the controller is responding with a ‘null’ value. Maybe it’s the PIN assignments or something? I didn’t change those for the H801 device. Do these look correct?

(Combining with my other reply from below and deleting to clean up my communication)

Edit 2: OK so this is even more strange. If I manually turn “ON” the LEDs from within the H801 controller’s web interface, this change shows up within the ST mobile app, which is great. So it appears to be communicating correctly. And THEN I can turn the LED lights “OFF” from within the ST mobile app and it works. BUT! HAHA! I then can’t turn them back “ON” from the ST mobile app. Strange right?! :persevere: :persevere: :persevere:

Edit 3: Well folks I have NO IDEA what was/is going on, but after cycling between rebooting the hub, rebooting the controller, removing/re-adding the SmartApp and DTH, etc this silly thing is FINALLY working. To everyone who has helped out and provided time/effort to this project in general, I just want to say:

If it happens again you should check the preferences for the individual device in ST, the settings menu, where you will need to choose the transition type.

Now that ive had to migrate to the new smarthings app. is there way to make it so all of the smartlife devices are not showing up with the name “smartlife rgbw controller”.

Can you show a screenshot? You should be able to rename the devices.

with the new ST app this device makes the app crash. is there a fix / update ?