[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

Question for the pros…

So the H801s that have been working perfectly for years (much thanks @erocm1231) have gone wonky on me. Kids were changing its colors back and forth and it stopped working. No worries & I thought it will be a great time to flash them to the latest firmware. But after doing that I am not able to connect to the units!! It broadcasts the SSID and lets me connect w/ “configme” but then I cant load 192.169.4.1 Of the 5 units, only 2 of them have the solid green and red LEDs after the flash.

Am I missing something? Could these units have burnt out? If so, I don’t mind getting new ones.

Is the H801 still the most reliable unit or should I switch over to one of the newer supported models?

Appreciate the help fellas!

Hi Charles,
I’d be happy to try that firmware on my older cores. Shoot me a link if/when you have a moment. I looked, but didn’t see it on your GH.

Thanks,
Jonathan

Hello! Just wanted to thank you again for developing this, have some beautiful main lighting in my house running of this. I’m having a bit of trouble though - one of the controllers I just tried to set up is non responsive to commands. I’ve tried manually sending commands at the IP address, updating and repeating the firmware. The lights it’s connected to are always on. Any idea what could cause this?

Also, whats interesting is if I set it manually at the h801s ip address, say I click W1, the next page still shows W1 as 00 not FF

Hmmm, not sure. Have you made sure the pin numbers are set correctly in the “Advanced” tab?

Yes, I did set to the h801 pinout

I think I know what you mean by your question. That is normal, clicking on the W1 endpoint in the dashboard does not set it to a particular brightness unless you also include a parameter for the desired brightness. The dashboard is best tested on the control tab since there you can control things without just opening the endpoint that allows control.

Hoping someone might be able to help.

I’ve got this controller running (modules flashed, smartapp and both device handlers installed). I’ve programmed the modeules, and made some “programs” for light control. Everything works perfectly in the smartapp and module control (device handler).

Problem is with the virtual switches. I had to uncomment out the lines of code in the smartapp (don’t know why they were commented out) before I could see the “make virtual switches” in the connect settings. Switches are created. However, they do not control the light. I see in the smarthings ide that the command is sent, but nothing happens.

Where have I gone wrong?

The virtual device code was commented out because I switched over to using child devices. There are toggle options in the device preferences to enable the different child devices you want. Then you can use those devices to activate the different functions. You have to have the switch child device installed.

Eric,

Thank you so much. Because I couldn’t see the virtual switches in the device list, I thought something was not working correctly. I can see them when I associate the smartthings items to google home.

Perhaps one additional question: can I rename the virtual switches somehow? I’d like them to not be “led light - program 1” but be able to say something like “led light - police scene”

Thanks again for your help.

My strips aren’t reliable any longer. Honestly I can’t get them to turn on 80% of the time. I have two strips with separate controllers. The just say ‘trying to turn on’ in SmartThings but never do. Occasionally they will. Not sure what to start with.

I think you can rename them in the IDE by going into the parent device and then clicking on the child device link at the bottom and then “Edit”.

Thanks so much…never really noticed the child device list before. Something newly learned.

Hey @whtzom6

Did you ever find a solution to this scenario? I’ve hit the same behaviour and the device presents the SSID, I can connect to the device via the IP. BUT nothing is controllable.

However the LED situation is exactly as you have described. Green light flashes every 10 seconds and no Red light appears at all.

Sorry to raise this thread from the dead, but couldn’t find any solution to your problem.

Thanks

Hi Group,
I see @cjcharles made some edits to the firmware .ino code out on @erocm1231 's github.

This may sound really newbie like, but how do I go from .ino to a hex bin file I can compile and update the firmware on my units with?

Thanks,
Jonathan

You have to download Arduino and all the required libraries and then compile it into a bin file.

That change was to fix a problem when using an external switch and some ipv6 fixes. So it is possible that you don’t really need the changes.

1 Like

@Dunlapjc - If those are the fixes you are looking to test out then you can test the firmware below. Though beware I may have used different compilation settings to Eric, hence if using the web upload tool then you may need to re-flash through the RX/TX ports on the controller

Thank you sir!

I tried recompiling and downloading the libraries on Friday, but clearly messed something up and bricked it until I reflashed the old version onto it via the RX/TX ports.

I’ll give this a go!

I installed a momentary button a little over a year ago and had little success with this. I saw the changes in code and fingers crossed this is what fixes it.

Thanks again,

Jonathan

1 Like

Let me know!

Hi all,

Anyone having issues with the new Smartthings app crashing when trying to select their smartlife devices?

I have a few h801’srunning for years now when I try select the device in the new app smartthings crashes. I also have issues with webcore trying to control the devices.

I haven’t fully migrated to the new app as I still have st classic on my phone and the smartlife devices work fine using that.

Not fully sure what’s going wrong.

I can’t seem to find a clear answer here, but the comment at the top from 2017 says its still being worked on so i wasn’t sure if it had been:

Does anyone know if I ordered one now if i could flash it to work with ST?