[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

Anyone try to use the waterpoof strips outside?

I have a steep driveway with a retaining wall on one side. It’s a little hard to see when backing up at night. I was thinking about running an LED strip, if I could hide it.

I’ve got low voltage wiring in place. I could build some kind of enclosure for the h801 and power it from the low voltage line when it is live at night. . . .

Would there be a specific reason why the color picker isn’t working? I can manually slide each channel, R,G,B, and W1 just fine. The programs work too, but the for picker doesn’t change the color when I choose a color. Doesn’t work in the app or in actiontiles. Maybe I’m just not using it right.

Thanks for the info, I was just using my phone with google assistant but I am leaning towards buying a google home, I have an echo dot but I am liking google assistant better.

Am I doing something wrong here? Every time I lose power at the plug (not the house, internet stays up), meaning it gets “switched off” as it’s on a switched outlet and my kid just plays with switches, it loses wifi credentials.
My sonoff does the same thing, although that’s just because I have a crappy cord connected to it that I have to replace.
It’s driving me up a wall. Every time I can’t communicate with it in ST, I pop open wifi on my phone and there’s the ESP or Sonoff. This is getting stupid. I’ve even flashed the latest firmware onto them. Obviously 2 different devices, 2 different firmwares.
@erocm1231 do you have any ideas?

I had one of these on my deck under the handrail for a while. Although I used it with the dumb controller and put everything in a waterproof electrical box. Never had any issues.
It was similar to this junction box. I siliconed around the strip to keep it water tight.
IP65 Waterproof Outdoor 2 Way PG9 Gland Electrical Junction Box Black https://www.amazon.com/dp/B016PO1CWE/ref=cm_sw_r_cp_apa_j2.WybVWRBSZ0

1 Like

Yeah, I was trying to push a workaround for ActionTiles and it looks like it is causing problems. Try the latest version.

@dalec I have mapped Daylight to W2. I am traveling and can’t test it right now so if you want to be the guinea pig . . .

@michaelahess It looks like ActionTiles is sending rgb values labeled as hex (which is what is throwing things off). I’m sure @tgauchat is aware and hopefully it will be fixed soon.

oink oink :ok_hand: I am on it! Just for clarification; Do I only need to update the firmware .bin file or is there an update to the device handler as well?

FYI: I just got my ActionTiles access today as well.

Just the device handler.

1 Like

SmartThings’s Docs for Capability “Color Control” explicitly included hex in the specifications…

Well, they used to!!! :confounded:

According to GitHub, the specs changed on Nov 30, 2016; but I don’t think we (or other developers…) were broadly notified… Were we? @Jim @unixbeast?


I believe that ActionTiles currently, purposefully, sends redundant values with the setColor Command, in order to maximize compatibility with various DTH implementations…

hue=60
saturation=58
hex=106166255 (ummm… I’m not entirely certain that we convert this to “#RRGGBB”, which would be a bug on our side to investigate)

1 Like

FYI… since Smartthings app update my H801 kept becoming unresponsive… I had enabled device health… once disabled the connection has returned to solid

I just tried flashing my new H801 using the “3.3V 5.5V FT232RL FTDI Usb to TTL Serial Adapter Module for Arduino Mini Port” device hooked up to my pc laptop via USB for power. It looks like it’s writing the SmartLifeRGBWController.ino.generic.bin flash image to the controller just fine but then I get some weird warning messages at the end.
Can this be safely ignored? Are there some test commands that I can execute to validate that the image flashed properly? This is my first attempt at working on this type of mini-project so any help is very much appreciated!!

setting serial port timeouts to 10000 ms
setting serial port timeouts to 1000 ms
espcomm_send_command: receiving 2 bytes of data
writing flash
… read 0, requested 1
warning: espcomm_send_command: didn’t receive command response
warning: espcomm_send_command(FLASH_DOWNLOAD_DATA) failed
warning: espcomm_send_command: wrong direction/command: 0x01 0x03, expected 0x01 0x04
closing bootloader
flush start
setting serial port timeouts to 1 ms
setting serial port timeouts to 1000 ms
flush complete

UPDATE: I tried this 2 more times and on the last try I held all four wires/pins against the H801 board while the flash process executed and it completed successfully! Woo hoo!!

But Ummmmm, now I connected power the VCC and GND on the right side terminals on the H801 and fired it up and…absolutely no broadcasting of the espRGBW.[mac address]. :confounded:

I have This power supply:
https://www.amazon.com/gp/product/B017R17YQC/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

I’m looking at the H801 circuit board while under power and I see there are two led lights in the corner labeled D1 and D2. The D1 led is off, doesn’t light up at all and the D2 blinks green about once every 10 seconds.

I know it flashed correctly, but this dang thing won’t broadcast that SSID!!!

could I possibly have a defective unit?

I’m so incredibly frustrated with this.

@erocm1231:

@625alex and I will chat, but it does look like we may be sending "hex": "#106166255" as the hex parameter value. If so, then concatenated decimals is a bug, even if "hex": is still supported. So that’s something we need to investigate further on our end.

In the meantime… does it help for you to know that we send all of Hue, Sat, and Hex? Can you just ignore the `“hex” argument?

Just checking you did disconnect the switch wires after your flashing completed?

Strange not to see anything at all being broadcast by the device, I would expect it to broadcast something if it was booting correctly (that might be the original WiFi from unflashed device for example). Just checking your phone is searching for 2.4GHz devices and not just 5GHz.

The LED flashes are correct if I remember correctly, that said, can you try powering through the FTDI and boot that way instead? I found one of my devices did something strange on the first few boots but then started working normally, so assumed it was stuck setting something.

I agree with @cjcharles you should be seeing something on the 2.4Ghz band if it is flashed correctly or you left the jumper on pin J3 so it is back in flash mode.

If still no luck you could try resetting it OR reflashing again in case it was a bad load.

[quote] The new firmware has two methods of accomplishing this. Since the device doesn’t have any buttons by default, I wanted to create a way for everyone to be able to do a factory reset.

(1) This method might be easier to do with a surge strip with a button attached. Unplug controller and plug back in. Within 2 - 5 seconds after plugging in, unplug and plug back in. Repeat this process 4 times. You can know you are doing it correctly because on the second plug in the LED Strip will light up GREEN, the third it will light up BLUE, and the fourth it will light up RED. After it turns RED, you can just leave it alone. The little red led will blink 5 times slowly and then the RED LED strip will start to flash as the storage is being wiped. After that is finished the LEDs will turn off.

OR

(2) After the device is turned on, jump J3 for a) between 10-20 seconds will reset the wifi b) between 20-60 seconds will reset everything. If you reset the wifi correctly the little RED LED will blink 3 times quickly. If you reset all the device settings correctly the little RED LED will blink 5 times slowly.[/quote]

1 Like

My Xfinity internet has been flaky today so haven’t been able to test till now.

Getting some erratic behavior.
I have only been testing this on one H801 thus far on my testbench but the device handler isn’t updating status on the device screen. For example everything is Off and when I manually turn on the Red channel it turns on the light but the mobile app isn’t updating to show its ON. Neither the red channel nor the main global indicator.

UPDATE: I should have known better; Everything is fine today without me doing a thing. All the crazy behavior coincides with SmartThings issue being announced. Note to Self: Not a good week for testing SmartThings code

Yes, even used a magnifying glass to ensure that there was no bleed over on the lead wires i soldered into the J3 holes for my wires.

Yep it is. To verify i re-enabled the broadcasting of my 2.4Ghz SSID band on my home wi-fi (i normally don’t broadcast for security reasons and all my devices use 5Ghz) and verified that my Android S7 Edge could “see” it .

Tried that as well and no luck. Held the wires in place for 5-6 minutes, watched the D2 led blink and kept refreshing the wi-fi networks on my phone hoping to see the SSID appear but no luck.

The advice and assistance is very much appreciated.

Thank you @dalec. I ended up re-flashing successfully three times today but still not seeing an SSID. I will try resetting it as per your methods above and let you know how it goes.

Don’t suppose you know if it was working with the original firmware do you? Do you see any high power wi-fi networks near your phone (I.e. perhaps it is just the ssid not as expected)

Would also suggest flashing one more time to be sure it finished and confirm nothing got corrupted somehow. That said should make no difference if you have already done it a couple of times. Maybe have a look at the antenna on the PCB and take a photo of you can to check for shorts or breaks.

Really running out of ideas now as these should cover it… If you do press the button again when booting do the led flashes change (they should)? If you connect all power and strips properly, do you get any LEDs on at all?

I “second” this idea as well