SmartThings Community

[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

dth_lighting

(Kavvy) #305

Have any recommendations on a specific one? I use one similar to this for my under cabinet lighting, but thats only about 15ft.


(Michael Hess) #306

https://www.digikey.com/product-search/en/power-supplies-external-internal-off-board/ac-dc-desktop-wall-adapters/589898?k=12v+power+supply&k=&pkeyword=12v+power+supply&pv127=131&pv127=1312&FV=fff40009%2Cfff8004a%2Cc00002%2C1180003d&mnonly=0&newproducts=0&ColumnSort=0&page=1&quantity=0&ptm=0&fid=0&pageSize=25


(Michael Hess) #307

I use ones from old PC’s, other higher quality electronics. Those are usually better than your “UL Certified” not really certified ones on Amazon/eBay.

But when I know I need a real good quality one, the DigiKey options have never let me down. These controllers are cheap so going with something that might blow one up that costs 20+ bucks may not be needed, but I also don’t like my house catching on fire…


(Kavvy) #308

Good point.

Ill swing by Office Depot today to see if they have any (local) before I order one.

I cut my order back to just 1 of these devices, to see how it would work. Once I can get it operational, I may just order a few more for future projects.


(Dan) #309

It would be SUPER helpful if someone could make a quick video just showing how to setup a new device from flashing, jumping, and app installs.


(Michael Hess) #310

The link to the instructions I posted a few up is far easier, less pause/play/pause/play, and it’s pretty much step by step. App and device type installs are already in the forums somewhere if you’ve never done that before. Search IDE smartapp install or something. On my phone so not easy to check.

Edit, here it is:


(Dan) #311

What about a video just showing how to flash the device. The connections are confusing without being able to see somone do it.


(Michael Hess) #312

Here’s a close up I just took. Getting these tiny labels on video would be a futile effort.

White is RX, Red is TX, VCC (power) is the right most black on the H801 and second from left (3rd pin from left) on the FTDI adapter and GND (ground) is the last black that’s not in a header on the adapter and second from right on the H801.

Also notice the little jumper/header pin on J3, short when applying power then remove. This particular board doesn’t have the pins soldered, I just have them inserted into the cable header and the jumper itself, gravity holds them in enough to make contact if you are careful not to bump it.


(Kavvy) #313

I missed the part in the initial post that said I needed the FTDI adapter. Just ordered it. Was wanting to play with this tonight but I guess thats a nogo.


(Michael Hess) #314

You can still play with it with the crappy app, if you can find it…and get it working. I did, it sucks, but it’s VERY fast at changing colors.


(Dan) #315

Where is the J3? I don’t see it.
After all this, then you get a USB and plug into computer?

Thanks for the pictures too!


(Michael Hess) #316

Yeah when you get it looking like that, plug the FTDI adapter into the computer, and follow the flashing instructions.

J3 is labeled as such in the picture right next to the cable plugged into the board.


(Dan) #317

Should this link work?


(Michael Hess) #318

Alternate link a quick google search found:


(Dan) #319

@michaelahess @erocm1231

I downloaded everything and setup the cables as instructed.
Plugged the FTDI into the computer and when I click the esptool.exe in the zip file. It opens a black window for .2 seconds and closes. I am not able to get anything else to happen.

Or what is the comport?


(Michael Hess) #320

You have to manually run the exe with the command I’ve posted from a command prompt, you have to verify what com port to use after you plug the adapter inot eh computer. It’s in your device manager assuming you are on a windows machine.


(Dan) #321

@michaelahess
I ran the esptool.exe and it flashes a black window and disappears. So I can’t type anything.
This is my device manager:

But that is still there even after disconnecting the FTDI.
I am on Windows 7.
I also have the SmartLife.bin in the same directory.
I can also run the flash.cmd but I think I need the COMPORT first?

EDIT Okay, now I have this:

Am I suppose to disconnect the J3 jumper after it is powered on?

I tried to do the command in a separate cmd:


(Michael Hess) #322

Don’t need to remove J3 after it powers up, just do so after you get it working.

Check if the COM5 device is actually using the FTDI driver, I can’t easily get into troubleshooting that but there are plenty of resources online for that. You may need to download and manually install a driver. Check the Amazon reviews, I think there were some links to how to’s there.

You are almost there. Did you verify the filename in the command window is the same as what you downloaded? You said it was in the same directory f:\desktop\new folder right?


(Dan) #323

Well when I unplug it, the COM5 goes away.
I can also do this:

Man - I have no idea what I’m doing.
Yes the directory is F:\desktop\new folder


(Michael Hess) #324

THAT’S IT!!!

All those dots are the PC sending the firmware to the H801.

Once it’s done, you remove the J3 jumper so as to not accidentally put it back into flash mode, then wire the power up to the 12v vcc and gnd on the right side of the device, and then you can connect to it with your phone!