[RELEASE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

Looking for advice on a high WAF (wife acceptance factor) LED under cabinet installation. I really need the system to be operable by a wall switch, while also being operable by Smartthings automation. Options I have come up with so far:

  1. H801 with external momentary switch connected to J3. Unclear what happens when J3 is cycled.

  2. H801 with power supply connected to Zwave on/off switch. Unclear what happens when you power cycle the H801.

  3. Fibaro with single external switch connected to all 4 inputs. I’m really not clear on what happens when the 4 inputs are off and then back on.

  4. Fibaro with power supply connected to Zwave on/off switch. Unclear what happens why you power cycle the Fibaro.

In all 4 cases, if any of these do not return to their original color state and brightness after being cycled with the switch, they are a no-go. Let me know your thoughts based on experiences with these, and let me know if I missed any other better solutions. Thanks!

Hi I know this thread covers an LED strip, is there anyway to control a smart life (tuya smart) light bulb with smartthings and if so how, does the bulb firmware need updating or can a device handler just be added to control the LED Smart life light bulb.

Thanks in advance for any help.
Sim

There are a few people who have flashed the firmware onto a bomb, but it was quite involved from what I remember. Suggest searching writhing this thread and if you have no luck I can take a look too.

Thanks for the reply, I’ve been searching a few days for that sort of info. :frowning:

Hmm, youre right that it wasnt in this thread… I found this linked from the thread https://www.cnx-software.com/2017/03/03/ai-light-esp8266-based-wifi-rgb-light-bulb-supports-mqtt-via-espurna-open-source-firmware/ which will give you some things to go on. The exact process will depend on what bulb you have. Though the H801 firmware linked in the first post will work, it just might have some tweaks needed. The tweaks would be changing which pin controls what colour, since they have probably used different pin ordering, though once you have the firmware loaded you can easily update through a webpage rather than faffing with an FTDI/serial flasher.

Check this out. :slight_smile:

It uses a wall mounted Z-Wave dimmer, a constant voltage line level dimmer that outputs 12v, and direct wired LED strips. Standard wall switch operable by anyone, whether or not they are aware you have a smart home and fully controllable by SmartThings. Ours turn on whenever we walk into the kitchen.

Hi Eric. Here are some pictures of the Arilux that i have. The board is totaly different from the other’s that i have. I have flashed it by soldering direct to the wifi chip. Like i said it works fine apart from the colours are out of sequence to the software. It has a different chip on board, it has and esp 8285. I now have some H801 to replace it and they are working fine.
Thanks

Cool, so thats the one I re-programmed too. I assume you can just swap around which cables connect to which pins to get around the pin order problem? I think I found the pins were a bit wrong on my version too, but you could try some of the other firmware options as they have different pin assignments (and should be otherwise identical I think).

It is the same one you re-programmed, i used your instructions to do it. It was fairly straight forward. I can’t change the pins around as the software is using w1 to control one of the lines instead of green i think. I think i tried some of the other firmware options but i will give them another try sometime this week, hopefully i can find one that works.

So long as when you change R, G, B, W1 sliders individually in the app/SmartThings you get a different LED coming on then you can map them, i.e. Red on the slider actually changes Green, Blue on the slider actually changes W1… Once you have that you can just connect the LEDs with a different order. If you have a slider that does nothing that is when you will need a new/different firmware since then it wouldnt be possible to re-wire the LED strip.

The one i have is rgb only,no white, and the green slider does nothing. The red works as red, the green does nothing, the blue is green and the w1 controls the blue. So i will need a different firmware. It’s not really a problem anymore as i have replaced it with a H801 which works perfectly.

Yes Im afraid you will as swapping the W1 is not easy without new firmware. Glad you got the H801 working though!

Sorry to necro-reply this post, but I happened to notice this post elsewhere in the forums from someone stating the hex parameter still exists even though it was removed from the ST documentation. The post is part of a short thread by someone with the same complaint of setColor not working in webCoRE.

It’s all above my current knowledge level, but I hope that helps, if you haven’t already figured out how to get setColor working the way you expect it to.

I also have the new lc01 with the ESP8285 and have been able to flash it but the colors are jumbled. How would I change that in the firmware?

The transfer went fine. I found to device on my wifi list as an access point. it wont take the configb password. it wants one more charactor. Has anyone else had this issue

It should be configme

Thx that worked

I can’t get Google Home to set colors. It can turn it on and off as well as dim the lights, but if I tell it to set the strip to a color, it will do it but the color won’t change.

This is what the log looks like when I tell Google to set it to Red:

87d27f51-e1de-4061-9f9a-1451706a821e 1:46:21 PM: debug Outgoing: [requestId:34878633949653190, payload:[commands:[[ids:[c5ca176d-80fe-4423-9a53-a57981b73c60], status:PENDING]]]]

87d27f51-e1de-4061-9f9a-1451706a821e 1:46:21 PM: debug Set TV Light Strip to 16711680

87d27f51-e1de-4061-9f9a-1451706a821e 1:46:21 PM: debug handleExecute()

c5ca176d-80fe-4423-9a53-a57981b73c60 1:46:21 PM: error java.lang.NullPointerException: Cannot invoke method toInteger() on null object

c5ca176d-80fe-4423-9a53-a57981b73c60 1:46:21 PM: debug hue: 0, saturation: 100

c5ca176d-80fe-4423-9a53-a57981b73c60 1:46:21 PM: debug setColor being called with [hue:0, saturation:100]

c5ca176d-80fe-4423-9a53-a57981b73c60 1:46:21 PM: debug [hue:0, saturation:100]

The only issue I can find is this error that occurs: error java.lang.NullPointerException: Cannot invoke method toInteger() on null object

Hi everybody! Newby here.
I have just started reading this thread, which is super long by the way and it is almost impossible to read it all.
I have managed to buy the controller and all the rest of the hardware, flashed successfully the controller(H801).
It is on my network and it seems like is doing OK.
My problem is, that I don’t know what is the next step from here.
Somebody could describe for me, what are the steps, to install the apps needed, where do I find them. I could not find anything like these, in Smartthings app. I have never heard of GrubHub, by the way. I’m not a Linux guy either.
Thank you in advance.
Tibor

Right at the bottom of post 1 there’s 3 links to github you need to open them and choose raw so all you see is just the text.
Then go your IDE account and then device handler and create a new device handler and select from code and copy and paste the code into it and save and then press publish >for me

Do that again for the other device handler and the bottom one is a smartapp just do the same as before but in the smartapp menu.