[RELEASE] Smart Weather Station Tile Updater and Severe Weather Notifications - Fix Broken Modes and Repeat Notifications

If your device is working properly you’ll see something like this in the IDE when you click Done or refresh.

798ae49a-5e33-476b-b714-b807d020574f 3:12:05 PM: debug WUSTATION: event: [name:wind, value:0, unit:MPH]
798ae49a-5e33-476b-b714-b807d020574f 3:12:05 PM: debug WUSTATION: event: [name:weather, value:Scattered Clouds]
798ae49a-5e33-476b-b714-b807d020574f 3:12:05 PM: debug WUSTATION: event: [name:weatherIcon, value:partlycloudy, displayed:false]
798ae49a-5e33-476b-b714-b807d020574f 3:12:05 PM: debug WUSTATION: event: [name:humidity, value:61, unit:%]
798ae49a-5e33-476b-b714-b807d020574f 3:12:05 PM: debug WUSTATION: event: [name:feelsLike, value:87, unit:F]
798ae49a-5e33-476b-b714-b807d020574f 3:12:05 PM: debug WUSTATION: event: [name:temperature, value:83, unit:F]

Also you zipcode shows KEDU?

Otherwise delete your weather device and start over.

KEDU is a local airport and perfectly valid “zipcode”. The weather tile successfully displays data for it. I’ll try deleting and re-adding when I get a chance.

1 Like

can i input my WU key?
what device handler does this work with?

@RBoy is this broken? If so, what is the new alternative? It’s still listed on your site.

Thanks.

No, it’s working fine. This is a SmartApp which refreshes the weather tile and adds other logic around it. This is a replacement for the stock app which used to ship with ST to update the weather tile and has the mode bug in it.

Are you confusing it with the latest weather DTH which was updated by ST to use a different weather data source? It still works with that new DTH.

This smartapp is not updating my PWS weather anymore. I think its because of this post that I found:

Weather API Changes

Announcements

Dec 2018

1 / 93

Dec 2018

3h ago

SmartThingsStaff Member

25d

The WeatherUnderground (WU) APIs SmartThings has been using to access local weather data are being shut down at the end of this year. This means any Automations or Devices that use the getWeatherFeature() method will stop running or begin returning errors on January 1, 2019.

We are taking steps to ensure that the SmartThings SmartApps and the SmartWeather Station Tile device handler will continue to work by porting them to new APIs from The Weather Company (TWC). These will be released into Production this week and there will be no gap in performance. To maintain your SmartApps and device handlers, we have exposed the following methods for SmartApps and Device Handlers to replace getWeatherFeature().

Thanks for the app. It installs and executes, and the SmartWeather Station Tile events log shows it received a refresh command, followed by a ‘last update’ command. Under the value column it shows the latest date and time. However no weather data has changed over the span of hours, and on the device page the last updated time still shows as many hours ago, contradicting the event list.

An additional error in the IDE live logging shows this for the Weather Station tile:

error groovyx.net.http.HttpResponseException: Not Found @line 219 (poll)

I’m still learning my way around Smartthings, apologies if anything doesn’t make sense, and thanks in advance for any assistance.

That looks like an error with the underlying weather station controller. Just make sure you’re using using the SmartWeather Station Tile device handler (type) in the IDE.

I’ve also found a bug in the new weather station controller which was causing an error while refreshing it and submitted a patch to ST. Once they review/incorporate it it’s possible your error may go away.

I also get error groovyx.net.http.HttpResponseException: Not Found @line 219 (poll) when I try to use a nearby weather station “pws:KPABUTLE21”. It works when I use my zip code, but the info it pulls isn’t really near my house.

@RBoy
I’m also getting this error:

Is that the result of the bug you mentioned as being patched?

The weather tile info looks good BTW.

Yes, the patch was submitted and accepted by ST. When it goes it into production this error should go away.

@alixjg I believe that the new weather tile only accepts zip codes

1 Like

and no Lux, I believe ?

Smarthweather stopped updating last night.
Ide log shows following error:

Tried to update zip or local WS id but error remains.

ST tile looks like below after manual update.

Any ideas?

I think there is an issue with the ST scheduler. I have this and a few other devices that use runIn() to refresh on an interval and they have all crapp3d out.

Looks like you didn’t enter a zip code in the preferences page. There’s a bug which I causing this exception if there is no zip code. I’ll submit a patch to ST but in the meanwhile I think manually entering a zip code in the preferences page of your weather tile should fix your issue.

Patch has been submitted:

EDIT: Looks like ST has accepted the patch so it should be in production in about 2 weeks or less.

1 Like

Thanks for the quick reply.
I must have introduced the blanc ZIP error myself after the smartapp stopped updating several parameters.
Tried with and without zip and pws id.
This is what I get in the IDE. You will notice that some data is not being pulled. Did not change anything on my setup (as far as I can remember) and updates stopped last night.

Thanks that worked!
Just use no pws or specific zip code

But if you leave the zip code blank it doesn’t update. Also do you know if you can enter a Canadian postal code instead of a zip code?

If I use a pws from Wunderground it works as well but unfortunately without lux and some other values. Don’t know for Canada, I am in Switzerland.

With ZIP I get following error.