SmartThings Community

[Release] SHM Delay Version 2.0

Please see prior post. I suspect that the same motion sensor is defined in multiple delay profiles.

The simulated sensor is used by SHM Delay to create an intrusion alert. The notification messages should have a message with the actual sensor causing the intrusion.

@arnb thanks for your suggestion. This option has been enabled for sometime in my settings. I also have the time delay added as well.

Alright so I did more testing to see what the issue might be and it is the living room motion sensor. “I Have the same motion sensor defined in multiple delay profiles…” is on. How would I add a motion sensor time delay to each profile?

Page 2 of each delay profile
“When arming in away mode optional motion sensor entry delay time…”

Also insure any motion sensors used in delay profiles are removed from Smart Home Monitor Security settings

@arnb sorry if it was asked before I am a long time shm delay version 1.07 user and I have experienced quite a lot of disarm issues using iris keypad once a few months, as a result I have been starting to upgrad my old smartapps one by one to isolate issues, the first component I suspected is the deprecated user lock manager and I upgraded to lock manager 2.x, I don’t want to touch shm delay 1.07 for now but would like to clarify if I need to disable my lock manager if I just want to upgrade to latest version of v1 in GitHub rather than v2, I recall some time ago the newer version of shm delay has integrated the lock manager code so just want to confirm if it is ok for me to keep using lock manager to use the latest version of v1, I just would like to keep my changes to minimal, I have been using the aeotec siren and sometimes I cannot disable the siren using the keypad I don’t think it is related to shm delay so I don’t want to change that for now, thanks a lot for your smartapp it is just great

I already have “When arming in away mode optional motion sensor entry delay time…” set to 5. Should I change that to 10? Also don’t have any motion sensors in SHM.

Can’t hurt, especially when the ST Cloud is running slow.

No. However, you are on your own with that setup. SHM Delay V1 is not supported.

That’s good enough I will try to fix my issues for the siren first thanks

I’m having an issue where when I disarm from SHM, my keypad lights don’t update, even though in the SH app, it shows the keypad is disarmed. If I switch from stay to away (or visa versa), it will sometimes update the lights, and sometimes I can get it to update to disarm after several cycles back and forth, but its very sporadic.

I also noticed if I arm with the keypad, then disarm, it will disarm in SHM, but the lights on the keypad won’t change. If I disarm with the keypad again, they will change.

I’m using a Centralite 3400 with the suggested DTH and the classic app. I have mode fix on and have tried multiple different settings and nothing seems to fix the issue.

Any ideas?

Thanks.

This may be an issue with the Zigbee mesh (signal) in the keypad’s location. It can also be caused by slow ST cloud response.

Searching the forum should find many articles about fixing the ZigBee mesh. Not much that can be done while remaining on ST to fix the slow cloud response.

I’ve search “repair zigbee mesh” and “reset zigbee mesh” and all I’ve found is people telling others with problems to power cycle devices. Could you point me in the direction of what you are talking about?

It doesn’t make sense to me that its a connection problem when the device functions properly (arming/ disarming), but that the indicator lights do not. I would think that if there was a connection problem, nothing would work. I’ve also moved the keypad to several parts of the house with the same result. Can you explain more why you think it’s a mesh problem?

Thanks.

I’m so frustrated! I have everything working as desired but I can not get any kind of audible alarm notification. When I trip an alarm I’m hoping to hear my two Iris V2 keypads make a siren sound of some kind and have my Alexa devices speak that there is an alarm. I’d also expect to hear a countdown beep from the keypads during the entry delay. The only kind of audible alert I can get is my Alexa devices saying to “please enter your pin” as soon as I opened a door. Then no beep as the time counts down and absolutely no notification of an alarm state other than a normal notification beep on my phone once the alarm has been triggered.

What an I missing here? The keypads were used with an Iris system (which I REALLY miss) and worked fine there. As I’ve been trying to figure out how to recreate the functionality of Iris I’ve even had the keypads work through some combination of settings between Lock User Management, SHM, SHM Delay, and who knows what other magic combination of settings between all of the different third-party solutions to simulate an actual alarm system.

Currently, when an alarm should be sounding and I go to the alert section of SHM it says that the siren and audio devices are active followed by a line that says the audio and siren are muted. I’m at my wits end with this. Any help would be greatly appreciated!

I understand, on Iris everything just worked, on ST it’s a challenge.

I need some information to assist with your issues:

  • which DTH is being used with the keypad: RBoy or other – include name
  • if using Rboy DTH is global setting “I am using the RBoy Apps Keypad DTH” set to ON/True?

I am unable to help with Alexa issues, suggest posting those questions on the appropriate forum.

Thanks for the help. I’m using RBoy dth and the global setting is on.

Try using the Mitch Pond DTH suggested in Section 14 of the documentation. It does not support the siren (thought that was a Iris keypad V3 only feature), but everything else works. Turn off the Rboy flag.

Verify SHM Delay is correctly setup

  • Delay profiles for doors to be monitored and basic tests noted in Section 15 are working
  • User Pin profiles for users
  • A User Pin of 0000 to utilize Iris On/Partial without entering a pin code
  • Modefix Profile is created
  • After that is working you may want to setup the Talker module if not already set

I’ll try the other DTH and see if that helps. The siren has worked with this setup but it seems that it’s some magical combination of different modules that I can’t seem to recreate. Everything else is working. I just have nothing but the single spoken command to enter a pin that comes from the Alexa device. No countdown beep, no siren, and even the beep with key presses is inconsistent. This is true of both keypads so I don’t believe it’s a hardware problem.

hey @arnb
Can i ask a couple of basic questions? i’m a bit new to this and got a bit lost in the documentation :frowning:

  1. If the delay is triggered and the alarm goes off - can you get the alarm rearmed after a short period of time? for example, my old style alarm will detect motion and the alarm goes off as expected. If it doesnt detect any further motion, the alarm will rearm itself and the siren will stop screaming. The strobe will remain flashing to indicate that an event has occurred.

Keep up the great work mate!

I may have missed this in the 1078 previous comments… but is there a way you can make shm delay work with Google assistant to say “set the alarm” as your walking out, and have it set the mode to away after a defined delay time? No key pad, just voice commands to turn it on and off?

After an ST alarm you must go into the phone app, and clear the alarm in order to get notified of any additional alarms. It’s the way ST works. You should be able to dismiss the siren when clearing the alarm.