SmartThings Community

[Release] SHM Delay Version 2.0

smartapp_security

#698

Darn. I’m going to try and see if I can physically muffle the sound somehow. It really is disturbingly loud. I’ve got neighbours :expressionless:


(Arn B) #699

Perhaps tape on the “vents” on top and bottom edges? I agree, in a multiple dwelling structure the V2 will disturb the neighbors.


#700

I’ll try some different tapes and paddings and report back :slight_smile:


(Keaton Hoskins) #701

@arnb I LOVE your app! Just wanted to say that before my pending question :wink:

I am having trouble implementing or “trying” to implement the “Talker Profile”. When I click on create, it seems to hang and do nothing. I am running v2.2.4 currently, so I think I am up to do per my github check.

If you need anymore infor let me know. I am trying to integrate the #echospeaks with my SHM delay build for doors open/close and left open when trying to arm.

Thanks!


(Arn B) #702

2.2.4 is the current veresion of SHM Delay, 1.0.3 is the current version of SHM Delay Talker Child. Assuming both modules are installed, please start IDE Logging prior to your next attempt, then post any error messages.

You are in uncharted territory AFAIK.


#703

I’d like to share my experience regarding linking the Iris V2 keypad to Smartthings and SHM Delay.

The first step, as documented, is to add the keypad as a Thing, and everything worked as documented for me. Removing the batteries, holding the tamper switch while putting one battery back in, releasing the tamper switch two seconds later, then adding the Thing in ST worked like a charm.
However, the second step of adding the keypad (press the tamper switch and wait two or three minutes until the keypad beeps) did not work for me. I had turned up the volume using long presses on the ‘2’ button but no beeps and the network light would keep blinking for thirty minutes or more.
The solution for me was as follows: after adding the Thing and pressing the tamper switch I typed in a four-digit code follow by ‘On’. The keypad beeped angrily and the network light changed its rhythm slightly. After that, I added the keypad to SHM Delay and it worked as ordered.
So, I don’t quite know why this worked for me, but if you’re having trouble with the second step it’s worth a try.

On the loud beeping during exit and entrance delays: I’m going to buy some sturdy tape to cover the holes on the side to prevent waking up the neighbours three doors down with my exit delay beeps and report back. The tape I had in my house didn’t do the trick yet :slight_smile:


(Keaton Hoskins) #704

I am looking for a way to integrate my #actiontiles with using a simulated keypad. The only way to do this currently would be to link out to your site, but I don’t think there is a way to retain the ID in that link. Any ideas?


(Keaton Hoskins) #705

Looks like it was a simple case of not having the child app installed eek… somehow I missed that part from the github integration. The profile is working as I tested from browser, now I am working on getting it working with my wall mounted tablets running #actiontiles


(Arn B) #706

I suppose you could create a tile with a link to the simulated keypad browser version, or perhaps a link to the Android version, but there is no integration with the ActionTiles pin number entry.


(Espozuno) #707

<<Set the global to show the triggering sensor on in SHm Delay, the phone apps notifications will display the <<sensor creating the intrusions. SHM always shows the simulated sensor when triggered from SHM Delay.
<< Was Enabled
<<I would add the motion sensor to the delay profile “Ignore these motion sensor during exit delay…” All Added
<<Should the same motion sensor be used in multiple profiles turn on Global “I have same motion sensor <<defined in multiple profiles…” Was Enabled
All these settings are configured properly, but when I trigger a motion sensor during Armed (Away) I’m still getting in my notifications that all my Simulated Contact Sensors were activated and my SHM Security Tab Alert messages also identifies that the specific Simulated Contact Sensor was activated but not the Motion Sensor.


(Arn B) #708

When a motion sensor triggers prior to opening the monitored contact sensor, this is what should occur, an alert. However, you should be seeing a notification message from SHM Delay with the name of the real sensor, contact or motion, creating the alert. In the delay profile page 3, make sure “log to notifications” and or “Send Push Message” are on/true


(Espozuno) #709

Yes they were both Enabled also


(Arn B) #710

Try saving the delay profile and Global settings, then retry.


(Todd M) #711

I am trying to add a “Simulated Contact Sensor” through the IDE but it keeps telling me…

Access Denied

We’re sorry, but you are not authorized to perform the requested operation.


(Todd M) #712

Nevermind…
Had to create the device in a Private Window in Firefox.


(Woodrow Collins) #713

Hello! I’m curious, is there a way to completely not use a motion device? My system is working great with the exception of one area I would like to completely ignore the motion components built into the device using SMH when the system is armed.

Thanks


(Arn B) #714

In the SHM “devices to be monitored when unoccupied” turn off “use every open/close and motion sensor”, then under Motion Sensors don’t select the device. (Also don’t specify the device in SHM Delay motion sensors.)


#715

I was able to get Sonos working with SHM Delay Speaker Devices.

In the SHM Delay talker child, around line 115, change the capability to “capability.musicPlayer”

input “theSpeakers”, “capability.musicPlayer”, required: false, multiple: true, submitOnChange: true,

Save, don’t publish.


(Arn B) #716

Interesting. So you were unable to select the Sonos speaker devices?

I don’t have real speakers and have no idea why I used capability.audioNotification instead of capability.musicPlayer.


#717

That is correct. The capability you had under speaker is not in the Sonos device handler. The sonos device handlers only lists the following capability:

capability “Actuator”
capability “Switch”
capability “Refresh”
capability “Sensor”
capability “Music Player”

Another thing to try would be to add the capability you had to the sonos device handler. Anyone want to help experiment with this a bit?

I haven’t done much reliability testing. Made the change and I had to disarm/arm a few times before I heard the exit message. Haven’t heard the entry message yet. Also it needs to have the attempt resume music logic added so it will play the music it left off.

I am using a Sonos:connect AMP device but they should all be the same.

What happens if you try to use both Lannouncer and Speaker? Any issues?