SmartThings Community

[Release] SHM Delay Version 2.0

smartapp_security

#678

Okay that makes more sense. Couple more questions and I should be good.

  1. How do you create a Delay profile?
  2. How do you make the simulated sensor know which real sensor it is working with?

Thank you for the quick replies!


(Arn B) #679

Those questions are answered in the extensive documentation at the beginning of this thread.


#680

My bad. I just went through the instructions again and figured it out. Thanks again :+1:


(Alessandro) #681

Hi All.

First of all CONGRATS on writing such an amazing app. Should replace the default SHM!

I haven’t installed anything yet, but I have gone through the whole thread and I have a few noob questions to ensure that this works with my use case.

  • I don’t have a keypad, and not planning to use any virtual keypad (action tiles or others).

  • I currently activate SHM with presence, or lock keypad entry through webcore pistons.

Would I be able to use the delay functionality of this awesome app without using the centralite keypad or virtual keypad and just relying on Webcore Pistons?

Thanks so much for your time!


(Arn B) #682

I don’t use presence for anything (unreliable for me), so I am unable to comment on that, however the delays do work without keypads.

For example I will get an Exit delay when setting the SHM alarm state to Armed Away from either ActionTiles or the ST Classic app dashboard. The Entry delay is set using a “Delay Profile” that is tied to a door’s contact sensor being openned.


(Alessandro) #683

Hey @arnb thank you kindly for the response! I know what I am doing as soon as I have a spare moment!
Thanks.


#684

Alright so I got everything and facing one problem with my Centralite keypad 3400. I just records temperature and battery. I looked through other forums where you can change it by pressing the tamper button but that didn’t do anything. Any other solutions?


(Arn B) #685

Change it, to what? Do you mean reset the device to pair with another hub?

SHM Delay and SHM do not monitor the keypad’s tamper event. If someone takes off the wall you can do something with WebCore.


#686

I was reading through this post: [RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

So before the keypad was online reading battery % and temperature. I tried resetting it and now it gets motion as well as the 3 buttons on the top light up. When I enter the number I set it under user profile the keypad waits a couple of seconds then beeps.


(JS) #687

Hi there ! BTW thank for the answer, I’ve struggling a lot with this without any success until now.
I just purchase a new contact sensor for my garage door, and this one is working with your smartapp ! So my problem is that my DSC alarm sensor (I get them with a Devices Handler to smartthings) can’t be selected in your SmartApp

I have notice the “optional To use the IDE device type to force accept device thing” for the Simulated contact, do you think that if this option was available for Real contact sensor, i’ll be able to select them ?

thank you again,


(Arn B) #688

It’s on page 1 of the delay profile field “(Optional!) Contact Name: When Real Contact Sensor is rejected as simulated, enter 4 to 8…”

Should that not work for you delete the following lines 255 to 283 in SHM Delay Child V2.1.2

if (thecontact)
{
/* log.debug “editing contact name ${thecontact.typeName}”
def txt = “xfinity 3400 Keypad xyz” //test code for failing match group test
def m
if ((m = txt =~ /(.)(?i)(keypad)(.)/)) {
log.debug “m $m”
def match = m.group(1) //fails with error message here
log.debug “MATCH=match"} */ if (thecontact.typeName.matches("(.*)(?i)(keypad)(.*)")) { error_data+="Device: {thecontact.displayName} is not a valid real contact sensor! Please select a differant device or tap ‘Remove’\n\n”
}
else
if ((thecontact.typeName.matches("(.)(?i)simulated(.)") ||
thecontact.getManufacturerName() == null && thecontact.getModelName()==null &&
thecontact?.currentState(“battery”) == null && thecontact?.currentState(“batteryStatus”) == null) &&
!thecontact.typeName.matches(ok_names))
{
error_data+=“The ‘Real Contact Sensor’ appears to be simulated. Please select a differant real contact sensor, or enter data into Contact Name field, or tap ‘Remove’\n\n”
/* error_data="’${thecontact.displayName}’ is simulated. Please select a differant real contact sensor or tap ‘Remove’"
for some reason the prior line is not seen as a string
*/ }
else
if (!iscontactUnique())
{
error_data+=“The ‘Real Contact Sensor’ is already in use. Please select a differant real contact sensor or tap ‘Remove’\n\n”
}
}


(Espozuno) #689

There was a ST update Last Night and my whole ST Security System with my Konnected Alarm Panel went to Hell!!!
After many hours of updating, deleting, updating again and configuring I finally got my Konnected Panel to see the sensors and work properly. Now the problem is with SHM Delay… I had everything working perfectly until this ST Update.
So, I recreated New Simulated Contact Sensors and I am configuring them with SHM Delay to Delay opening when setting Away mode but the Simulated Contact Sensors are not responding to the system or SHM is not working. Can anyone help? Again, I’ve tried simple solutions to removing and reinstalling SHM Delay and I can’t get it to work.


(Espozuno) #690

To be more specific from my earlier post. I have my wired Physical Konnected Alarm Sensors and they are working fine. I have the following setup: Contact Sensors- ( Zone 1, Front Door ), ( Zone 2, Garage Door ), ( Zone 3, Slider ), ( SmartSense Multi Sensor, Back Door ), ( Motion Sensors - ( Zone 5, Family Room Motion ), ( Zone 6, Living Room Motion ).
Then I set up the following Simulated Contact Sensors: ( SIM01 - SIM Front Door ), ( SIM02 - SIM Garage Door ), ( SIM03 - SIM Back Door ).
I then added the Simulated Contact Sensors to SHM - Security for Away Mode, added Physical Sensors for Armed ( Stay ) mode and both information to SHM Delay to Delay the Family Room Motion and Living Room Motion.
Testing using the Garage Door Sensor which is directly in front of the Family Room Motion Sensor Arming in Away Mode, I get no delay of the Motion Sensor and no trigger of the SIM Garage Door. Then after the Garage Door is closed for about 30 sec, I get a quick SIM Garage Door Open event. If I walk in front of the Family Room Motion Sensor after activating Away Mode within the 30 sec, I then get a Activated Alarm event. Any help will be appreciated? Thanks.


(Arn B) #691

I can offer general suggestions.

  1. Read the instructions at the top of this thread
  2. Set global settings and modefix information - save
  3. Create a delay profile only for doors used for active access and egress. Start with a single profile and get that working before moving on to addtional profiles that may introduce cross profile interference that must be mitigated by a setting in globals
  4. Remove any real sensors used in delay profiles from SHM monitoring
  5. add any simulated contact sensors used in delay profiles to SHM monitoring (seems like you did that)
  6. any motion sensors that trigger during entry delay may be mitigated by adding them into the delay profile and removed from SHM
  7. if using a keypad add user(pin) profiles

(Espozuno) #692

<<I can offer general suggestions.
<<
<<1. Read the instructions at the top of this thread. followed all the instructions as I have done before when I originally set DHM Delay up and updated to 2.0.
<<2. Set global settings and modefix information - save. Global settings and modefix were configured properly
<<3. Create a delay profile only for doors used for active access and egress. Start with a single profile and <<get that working before moving on to addtional profiles that may introduce cross profile interference that <<must be mitigated by a setting in globals. I did this today and it did not make a difference and got the same results. No Simulated Contact Sensor activity and no delay of the motions sensors.
<<4. Remove any real sensors used in delay profiles from SHM monitoring. The only real sensor that I used under SHM monitoring for Armed (Away) was the Zone 3, “Slider” contact sensor. I removed that for SHM monitoring and I still got the same results.
<<5. add any simulated contact sensors used in delay profiles to SHM monitoring (seems like you did that). Yes
<<6. any motion sensors that trigger during entry delay may be mitigated by adding them into the delay profile <<and removed from SHM. I did not do this because I do want the motion sensors to detect motion under SHM monitoring Armed (Away) if someone comes through a window. Does the motions sensors still work if they are not in the SHM monitoring for Armed (Away)?
<<7. if using a keypad add user(pin) profiles. I’m using ActionTiles with the pin pad to Arm and Disarm the System. So I did not set up any user profiles.

The other thing I’m going to note is what I installed in IDE and their version numbers:
SHM Delay V2.2.4 published
SHM Delay Child V2.1.2 not published
SHM Delay Modefix V0.1.5 not published
SHM Delay Talker Child V1.0.3 not published

Thanks for your help


(Arn B) #693

If the sensor causing the SHM alert is the “simulated contact” sensor the alert occurred from SHM Delay, otherwise it is from Smart Home Monitor.

Please take a look at your notification messages and go from there. Also in globals settings, insure you have “This app issues an intrusion message with name of triggering real sensor?” set to On/True

If this does not help you resolve this issue, please save the Smart Home Monitor settings again, then retry.

Regarding motion sensors. Sensors defined in delay profiles are monitored by SHM Delay, not SHM and are active during Away modue.

Are there any Webcore pistons or other smartapps operating on these sensors?


(Espozuno) #694

<<Regarding motion sensors. Sensors defined in delay profiles are monitored by SHM Delay, not SHM and are <<active during Away modue.
So this was the problem!! I deleted the Motion Sensors from SHM Security and the system works now with just the SIM Garage Door only. I am going to try and add the other Simulated Contact Sensors for the other Doors and see if it still works.

The only thing that kind of bothered me is when I tested the system, set SHM Armed (Away) to activated and I closed the Garage Door and waited 30 sec to trigger the Family Room Motion sensor, the Alarm went off as expected but the Activation status came from the Sim Garage Door and not from the Family Room Motion sensor. If I was away and I got an alert, I would like to accurately know if it was by motion or Door sensor

<<Are there any Webcore pistons or other smartapps operating on these sensors? No Webcore only BigTalker2

Thank you so much, You’ve been such great help!!!


#695

Is it possible to lower the volume for entry and exit delay beeps on the Iris V2 keypad? I can change the volume for keypresses using the 2 and 5 keys, but that doesn’t seem to affect the 30 seconds of angry beeping during exit and entry. I know it’s supposed to be loud enough to hear, but I’ve got two keypads and I’d like the beeping to be quite a bit softer :).


(Arn B) #696

Same issue here, unable to adjust AFAIK. Exit and entry beeps are LOUD.

@RBoy Do you have any information for lowering the Iris V2 volume for the exit/entry beeps?


(Arn B) #697

Set the global to show the triggering sensor on in SHm Delay, the phone apps notifications will display the sensor creating the intrusions. SHM always shows the simulated sensor when triggered from SHM Delay.

I would add the motion sensor to the delay profile “Ignore these motion sensor during exit delay…”
Should the same motion sensor be used in multiple profiles turn on Global “I have same motion sensor defined in multiple profiles…”