SmartThings Community

[Release] SHM Delay Version 2.0

smartapp_security

(Arn B) #637

.[quote=“mikpeet, post:630, topic:121800”]
Seems that the delay is only running when in Armed/Away mode
[/quote]

I beleive this may be due to some of the latest ModeFix profile option changes allowing user’s to set how each mode operates. The code generating the user event needs to be modified, currently it allows only for away.

Please let me know how you are arming your system


(Arn B) #638

Relased SHM Delay V2.2.2 {deprecated by V2.2.3}

Corrects missing nonkeypad exit delay notification in SHM Delay Buzzer/Switch when there are no SHm Delay Talker profiles

Installation
Update module SHM Delay from github arnbme / SHMDelay / Version2
Save, then publish for me


(Todd M) #639

I am using either my phone using SHM or my Fire HD using ActionTiles to arm from Disarmed to Armed (Away).


(Arn B) #640

Relased SHM Delay V2.2.3

Now uses the ModeFix settings when available to issue the non keypad user event for Stay and Away SHM status.

Installation
Update module SHM Delay from github arnbme / SHMDelay / Version2
Save, then publish for me

Please report any issues


(Arn B) #641

Just released SHM Delay V2.2.3, Let me know if this works for you. I tested mainly from ActionTiles.


(Mike) #642

I normally arm away mode using presence (L360) and stay mode off of time and when things quite down.

I have tested arming disarming using the keypad with same results.


(Arn B) #643

What is same results?


(Mike) #644

Same thing. Still works great when armed away but when armed/stay it registers that the door opens but no beeping and no simulated contact after the 30 seconds.

Not sure if this helps…I enabled “True night flag” in global settings and when a door is opened in armed/stay it does trigger instantly. When I disable “true night flag” is see the notification when a door is opened in armed/stay but like before the keypad does not beep and does not trigger the simulated contact.

The modes on the keypad seem to be tracking very well now whether I arm from keypad or app.

I did update to the your latest version 2.2.3 tonight.


(Todd M) #645

Still testing.
Can I arm away without a buzzer (only when others are asleep) ?


(Arn B) #646

Be sure module SHM Delay Modefix is running version 0.1.5. Then go to SHM Delay

  1. Global Settings “Mode Fix when system armed…” and verify it is on
  2. Turn off true Night flag, save
  3. Below Global Settings, tap on Mode Fix Settings.
  4. Verify the various modes
  5. Set the exit and entry delay settings for the various states and modes
  6. Save the Modefix profile
  7. try it again

The documentation has fallen behind the capabilites of the system.


(Arn B) #647

Currently no date / time parameters. It’s possible but would have to be associated with each State/mode combination showing in Mode Fix.


(Jeff) #648

There is an option in the Konnected buzzer’s device settings in ST to set alarm duration and time between beeps and maybe you can reduce that time to zero? I personally just use it as a momentary device and sound it repeatedly by turning it on via Webcore.

I successfully set up an entry delay in Webcore but I haven’t tested it much yet. I have it beep once per second for the same duration as the SHM Delay and it stops when the alarm is disarmed. If you need the Webcore for this, let me know, it works great so far. I don’t have a real need for an exit delay beep because 99% of the time I use presence sensors and the exit delay of 60 seconds is more than enough time for me to get out of the door anyway.


(Arn B) #649

Attempting to have ST blink a bulb, or quickly turn a device on and off that does not have this function built into the hardware, is generally not suggested due to delays with the internet and cloud processing. It may work now, or most of the time, but the odds are high it will fail at some point in the future. So for example if it’s possible to set your buzzer to beep 15 times for one second with a 1 second delay then issue a single command to create this effect, great.


(Todd M) #650

Yes, I experienced this problem. I was using webcore to turn the buzzer on/off with delays and that just did not work. I had cloud delays as you describe.


(Arn B) #651

There is also an ongoing issue with commands with delay timers. For example in an SHM Delay delay profile there’s an option to beep a siren or alarm 2 seconds after the contact sensor opens. When I first set this up about 16 months ago, it worked fairly well, now the siren almost always chirps between 8 to 12 seconds late.


(Jeff) #652

I know what you mean, I’ve had the same issue with lights especially, and I am seeing it with the buzzer. It doesn’t matter for me as long as it does manage to beep multiple times within the 20 second delay to remind me to disarm the alarm, although It would be nice to have a slicker solution. If it doesn’t respond once in 20 seconds, then I have bigger issues because the rest of the system is doing to be of little use.

The Konnected buzzer settings only allow it to have one “version” of the beep, I think, so you can set the duration to fire each time, but I think it would be the same for every call to the buzzer.


(Mike) #653

All is working great now. Completely my fault. I failed to read a few of the settings in the Modefix function. It was spelled out very clearly but I was being dumb. I needed to enable the entry delay for that function. May be worth defaulting the function to “on” since this is the purpose of the app. Thanks for the support and great work with what you have done. Sending a donation over shortly.


#654

@arnb I picked up an Iris v3 keypad for cheap and can’t for the life of me get it to arm the system. Its currently setup exactly the same as my Iris v2 (which is working perfectly), but whenever I use “on” or “partial” the light changes, but it doesn’t change smartthings in anyway. I’m not sure if its an issue with SHM Delay or @RBoy DTH I’m using. Both are completely updated. Any insight?


(Arn B) #655

I assume you’re using the on and partial key without a PIN. That would require in the V2 at least a pin user profile code of 0000. In shm delay the 0000 code is programmed not to function for OFF.

Should this not cure the problem kindly contact rboy apps support @maddie @rboy


(www.rboyapps.com - Make your home your butler!) #656

Arn, the v3 Keypad does not allow the user to enter a pin when arming, only for disarming as I had indicated earlier. So the DTH doesn’t have anything to report (ie blank). Do you want the DTH to report 0000 for this scenario? This may be misleading since the user can press any 4 numbers before arming and the keypad will just ignore the numbers. Maybe a special case in SHM Delay to allow arming without a pin may be needed.