SmartThings Community

[Release] SHM Delay Version 2.0

I need help with one step of the installation process. When I get to step 10. Delay Profiles I do not have the same settings available to me that is listed in the instructions. For Item 4. (Optional) When a motion sensor triggers an intrusion during an entry or exit delay: select a motion sensor device
When multiple motion sensors must be defined: set global Allow Multiple Motion Sensors to On/True
Defined motion sensors are monitored during Alarm Status: Away
Mine is worded a little different. I have (Optional) Ignore these Motion sensors during exit delay, and when the real contact sensor opens during entry delay. These sensors are monitored in Alarm State: Away (Remove from Smarthome Security Armed (Away) Monitoring). I added my two motion sensors to this and removed the motions sensors from Armed away monitoring. The motion sensors do trigger the alarm when activated, but they show up as a simulated door sensor in SHM. Is this normal or do I have the settings wrong? I would like to distinguish between door and motion sensor alarms.

When SHM Delay encounters an intrusion condition, it opens the simulated contact sensor. So if things are properly setup most all SHM issued messages would show the simulated sensor. However, to ease the process of determining the actual cause of the SHM Delay intrusion, when global associated witth “This app issues an intrusion message with name of triggering real sensor?” is on SHM Delay issue a message with the name of the sensor creating the issue. Look at the Notifications log to find the problem.

The documentation may not be 100% in agreement with the latest versions of the live modules.

When a motion sensor is defined in multiple profiles, the “I have the same motion sensor defined in multiple delay profiles…” must be set on to stop false intrusion alerts.

I have successfully set up SHM delay and am using an amazon fire tablet, action tiles etc to arm and disarm.

I have being looking at the simulated keypad but disputes following the instructions and multiple attempts I have not been able to get it to work.

The keypad device appears to be setup Which has enabled me to establish a ikpd and user profile.

My understanding, please correct me if wrong, is that once I select SmartHome monitor and then Arm in action tiles the simulated keyboard should appear.

Not sure what I have missed.

Suggest re-reading documentation Section23. The Simulated Keypad does not interact with ActionTiles.

The documentation describes the process to get this working in a browser, or with the side loaded android app. To use the keypad go to the keypad website UrI or open the phone app, enter the ID generated when setting up the sim keypad and it should work.

Hi all. Not sure what the crack is, but I’ve used this on and off for a while now, but never quite been satisfied with the overall ease of use of using my smartthings system as a daily alarm.

However, finally got around to hooking up a cheap rfid keypad through a fibaro ubs, so now it’s a doddle to arm / disarm without needing a tablet etc.

Onto the main point - my audio notifications have never quite been right. Using kiosk browser along with this app and big talker I have found that basically, the voice Announcements are patchy or delayed, often making me wonder whether alarm has actually done anything etc. The time delay is sometimes just too great. Or for whatever reason disarming shm gives me a double-announcement. Can’t see why. I also use the buzzerswitch module, to achieve the below…

However, again, consistently, using big talker directly works spot on, but this is needing a combination of virtual switches with some clunky smartlighting rules to attempt to have these switches logically figure out when the alarm is

(a) initially set
(b) at the point of exit delay
© fully set.
(d) entry delay

Is there a chance that you may be able to tweak your app to include a few options to enable a users choice if switches (on or off) during these stages above? Not sure if that’s a big ask, or if nobody else seems to have these problems anyway. It would mean that my setup would become far less ‘messy’ plus it would allow me to say, hook up lights/buzzers to give an intuitive idea of what’s going on.

Feedback much appreciated! =)

In my opinion, the problem is running what should be locally based processing over the internet, in the cloud. Most of my system now runs on the Hubitat platform, and no longer encounters the issues you describe.

SHM Delay is stabilized, however feel free to modify the logic and code. A modified BuzzerSwitch module, with some virtual switch devices should easily handle this. Additionally, the SHM Delay Talker module already handles the voice messaging for the conditions defined above.

Regarding the “spotty” TTS messages: Should you be using an Amazon tablet with Fully and LanNouncer, the Amazon OS does not play well with LanNouncer and I suggest using the Fully Kiosk Browser DTH for TTS. Also on my Amazon tablets, TTS improved after totally disabling Alexa.

agreed on the local processing aspects. oddly enough, the ‘talker module’ is where i notice the delays, which is why i went the switch/bigtalker route, which works virtually instantly every time without fail. Odd.

i’m aware of the cloud aspects, which is why i try to keep as much as possible local. As I understand it, the virtual switches and smartlighting all operate locally. I’m already using kioskbrowser and your DTH too =)

As for modifying the code, I appreciate the offer but I’m afraid the programming is beyond me. I’m just going to have to attempt to figure out some ‘tidier’ logic to create some switches which define what status the alarm is at the time.

Thanks for the feedback, I totally get that I’m trying to squeeze a bit of functionality out of something that wasn’t quite designed to do this, but I’m confident it’s possible = )

As long as the locally suppoted virtual devices are used with a local app. That may only be SmartLighting at this point, most everything else including all user developed apps, execute in the cloud.

Perhaps it is due to the talker module waiting to be posted for the SHM Delay app’s generated location events that are being delayed in the cloud.

Probably. That’s why I’m trying to use a cheap system and keep it as local as poss, through the use of virtual switches and smartlighting, only reverting to 3rd party bits when necessary. =)

As you can see from the above pic, I’ve managed to tidy up the rats nest of “if that then this” and I’ve made 4 switches, only one of which is active at a time.

The idea was to then associate events with each stage of alarm, easily.

So using big talker, shm Delay, kiosk browser and your dth, all of this works perfectly without relying on your voice module parts of shmdelay. So I get voice announcements:

Exiting: “setting alarm… You have xx to exit”
Exited: “alarm set”
Entering: “please disarm the system”
Entered: “system disabled”

Now I’m just going to have another quick play to verify, but I believe it’s the “alarm set” which also seems to repeat itself whenever I’ve actually disarmed the system, and I have no idea why. Driving me crazy =)

I am however, still struggling with one single announcement, which for whatever reason, STILL doubles up or manages to announce at the wrong time.

I’ve accepted that for whatever reason, the voice notification (“alarm set”) is played (a) when it should be, but also (b) when the system is disabled. No idea why, I can’t see any logical reason.

Instead, I’ve chose to cut it out of the equation and have a smart socket switch on instead, connected to a bulb. This works flawlessly. Very odd.

Update - must be a timing issue. When linking the voice announcement to a virtual switch (which is ON when alarm is fully set, no delays active etc), voice announcements don’t behave as they should (see post above).

If however, I link them to a physical smart socket instead - perfect.

Mental!

-=edit=-

Another update! Perhaps I’ve discovered the limits of the platform…?

In a nutshell, I use shm delay along with the buzzer module, virtual switches and some smartlighting rules to determine what’s going on with the alarm.

i.e.

  • alarm completely disabled
  • alarm set, still on the way out the house, an exit delay
  • exit delay completed, alarm now fully set.
  • re-entering the house, entry delay active, waiting for alarm to be disarmed.
  • back to the first stage again (alarm completely disabled).

Depending on which stage it’s at, the hope was to hook up an indicator panel with red, amber green, and a buzzer to clearly indicate what’s going on. I also have things such as a flashing external alarm box to show the alarm’s active, and various sirens which are triggered if there’s an alert.

The aim of all of this was to to create a kick-ass smart system whilst maintaining absolute wife-friendliness. The cherry on the cake was the addition of a rfid panel hooked up to a fibaro ubs allowing seamless and mother-in-law-compatibility, with a few voice alerts using big talker.

Clearly I was hoping to keep the majority of this running as locally as possible, with minimal reliance on cloud. It’s worth noting that had I envisioned I’d be doing as much as I am with the smart platform, I wouldn’t have chosen smartthings due to the issues with cloud reliance, but as with all things, the project started with a bit of mild curiosity and the purchase of a starter kit to control some christmas lights!

As you can imagine, the setup I have now involves a fair amount of “if this, then that, change mode, flick this switch on, flick this switch off…” etc.

Apparently herein lies the problem. Sometimes in the instance where a trigger of some sort might need to turn off 3 switches, turn on, and change the mode and alarm status… you may find that not all switches are actually flicked. An maybe the mode will change, but the shm status won’t. The troubleshooting has been a bit of a pain purely because there hasn’t actually been any errors in my logic, it’s just been partial intermittent ‘misses’.

I’m still keen to figure a way around this, but it seems the problems may be insurmountable. It’s completely doing my head in to know that, for example, shm is supposed to disarm, change the mode to home, and turn a switch off. Using one switch to trigger this works just fine, using another will do all but change shm status, breaking the logic, so to speak.

Sorry to hijack your thread - was never the intention ! Your software (along with kiosk browser) has been an integral part of this all for me, and I truly appreciate it. Maybe hubitat is going to be the next step, eh ? = )

-=/edit=-

Hey, I use the SHM Delay 2.0 for my security system and am looking for a new keypad that will be compatible with it. I have a Iris V2 keypad which gives me a lot of issues. I also have a friend looking to build his system from scratch very soon. What keypad should we get?

I’m not sure if this was brought up in any of the previous posts, but Centralite filed for chapter 7 bankruptcy in March 2019. ( https://staceyoniot.com/centralite-has-filed-for-chapter-7-bankruptcy/ ). I don’t feel like I want a keypad from a company that can no longer support it, if needed.

Are the TCH / UEI / Xfinity keypads the only ones left? or did Centralite somehow make them too? Does it even matter?

Thanks for the help!

If the keypad works it really does not matter. About all that is available today are used UEI versions. Don’t get an Iris version 1, it will not work. When buying used make sure it has the mounting plate.

The first Xfinity keypad was a Centralite clone, Iris V2 was also made by Centralite.

I am using an Iris v2 keypad with the SHM Delay 2.0 and I am curious if there is a way i can make it so putting in a certain code will cause an action to be done. I dont know if that is possible or not but is something I am curious about.

OK… I have searched high and low, so now I beg your assistance.

I cannot figure out how to enable “exit delay beeps”. I am intending to use the pin-protected SHM tile in ActionTiles to enable and disable SHM. However, we need exit beeps to tell everyone “its armed, get out!” Even if using the ST Dashboard to enable, I would want exit beeps. However, the only context I can find for exit beeps is in relation to a real keypad (iris).

I see the settings for entry delay beeps in delay profile, but I cannot find exit delay beeps. What am I missing?

Exit and Entry beeps are hardware commands issued to keypad devices.

Since you are using ActionTiles, consider using the SHM Delay Talker module, the Fully Browser, and the Fully Browser DTH, to generate TTS messages about the state of the system.

Thanks arnb,

Im confused by this though, as it doesnt appear to be completely true.

There are entry delay beeps in the app without Talker/TTS, but no exit delay. I don’t understand why it would have one, and not the other.

I don’t actually want it to talk. I have a chime, and I just want the chime to beep. We dont really use ActionTiles, as we mostly arm SHM from ST Dashboard, and we would want the chime to beep regardless of ActionTiles.

The keypad uses a single hardware command to generate beeps for a specified time duration. Doing this with a “chime” device requires multiple commands issued perhaps every second, this is not recommended using the SmartThings cloud based code running over the internet, but would be feasible with a locally based hub, such as Hubitat.

So i updated to the latest version and now my Iris 3405-L Keypad no longer chimes… What did i do wrong?

I don’t know.

Verify the Delay Profile (page 2) “Beep Chime these devices” has the keypad(s) defined. Save the profile (even if already set)