SmartThings Community

[RELEASE] Russound Multi-Zone Controller Integration

smartapp_av
russound
dth_av

(Jim) #507

@redloro I was able to get the driver working with my Mac, so I got brave and bought a raspberry PI3, running raspbian. I unfortunately am not having the same success. I am getting the following error and I’m pretty much out of ideas. Any help you could provide would be greatly appreciated. Thanks

npm run install:rnet

smartthings-nodeproxy@1.0.0 install:rnet /home/pi/smartthings-nodeproxy
npm install && npm install serialport@5.0.0

up to date in 2.462s

serialport@5.0.0 install /home/pi/smartthings-nodeproxy/node_modules/serialport
node-pre-gyp install --fallback-to-build

node-pre-gyp ERR! Tried to download(404): https://github.com/EmergingTechnologyAdvisors/node-serialport/releases/download/5.0.0/serialport-v5.0.0-node-v59-linux-arm.tar.gz
node-pre-gyp ERR! Pre-built binaries not found for serialport@5.0.0 and node@9.8.0 (node-v59 ABI) (falling back to source compile with node-gyp)
make: Entering directory '/home/pi/smartthings-nodeproxy/node_modules/serialport/build’
CXX(target) Release/obj.target/serialport/src/serialport.o
…/src/serialport.cpp: In function ‘void EIO_AfterOpen(uv_work_t*)’:
…/src/serialport.cpp:96:30: warning: ‘v8::Localv8::Value Nan::Callback::Call(int, v8::Localv8::Value) const’ is deprecated [-Wdeprecated-declarations]
data->callback.Call(2, argv);
^
In file included from …/src/./serialport.h:6:0,
from …/src/serialport.cpp:1:
…/…/nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Localv8::Value argv[]) const {
^~~~
…/src/serialport.cpp: In function ‘void EIO_AfterUpdate(uv_work_t
)’:
…/src/serialport.cpp:152:30: warning: ‘v8::Localv8::Value Nan::Callback::Call(int, v8::Localv8::Value) const’ is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from …/src/./serialport.h:6:0,
from …/src/serialport.cpp:1:
…/…/nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Localv8::Value argv[]) const {
^~~~
…/src/serialport.cpp: In function ‘void EIO_AfterClose(uv_work_t
)’:
…/src/serialport.cpp:191:30: warning: ‘v8::Localv8::Value Nan::Callback::Call(int, v8::Localv8::Value) const’ is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from …/src/./serialport.h:6:0,
from …/src/serialport.cpp:1:
…/…/nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Localv8::Value argv[]) const {
^~~~
…/src/serialport.cpp: In function ‘void EIO_AfterFlush(uv_work_t
)’:
…/src/serialport.cpp:235:30: warning: ‘v8::Localv8::Value Nan::Callback::Call(int, v8::Localv8::Value) const’ is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from …/src/./serialport.h:6:0,
from …/src/serialport.cpp:1:
…/…/nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Localv8::Value argv[]) const {
^~~~
…/src/serialport.cpp: In function ‘void EIO_AfterSet(uv_work_t
)’:
…/src/serialport.cpp:290:30: warning: ‘v8::Localv8::Value Nan::Callback::Call(int, v8::Localv8::Value) const’ is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from …/src/./serialport.h:6:0,
from …/src/serialport.cpp:1:
…/…/nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Localv8::Value argv[]) const {
^~~~
…/src/serialport.cpp: In function ‘void EIO_AfterGet(uv_work_t
)’:
…/src/serialport.cpp:342:30: warning: ‘v8::Localv8::Value Nan::Callback::Call(int, v8::Localv8::Value) const’ is deprecated [-Wdeprecated-declarations]
data->callback.Call(2, argv);
^
In file included from …/src/./serialport.h:6:0,
from …/src/serialport.cpp:1:
…/…/nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Localv8::Value argv[]) const {
^~~~
…/src/serialport.cpp: In function ‘void EIO_AfterDrain(uv_work_t
)’:
…/src/serialport.cpp:384:30: warning: ‘v8::Localv8::Value Nan::Callback::Call(int, v8::Localv8::Value) const’ is deprecated [-Wdeprecated-declarations]
data->callback.Call(1, argv);
^
In file included from …/src/./serialport.h:6:0,
from …/src/serialport.cpp:1:
…/…/nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Localv8::Value argv[]) const {
^~~~
CXX(target) Release/obj.target/serialport/src/serialport_unix.o
CXX(target) Release/obj.target/serialport/src/poller.o
…/src/poller.cpp: In static member function ‘static void Poller::onData(uv_poll_t
, int, int)’:
…/src/poller.cpp:69:29: warning: ‘v8::Localv8::Value Nan::Callback::Call(int, v8::Localv8::Value*) const’ is deprecated [-Wdeprecated-declarations]
obj->callback.Call(2, argv);
^
In file included from …/src/poller.cpp:1:0:
…/…/nan/nan.h:1618:3: note: declared here
Call(int argc, v8::Localv8::Value argv[]) const {
^~~~
SOLINK_MODULE(target) Release/obj.target/serialport.node
COPY Release/serialport.node
make: Leaving directory ‘/home/pi/smartthings-nodeproxy/node_modules/serialport/build’

  • serialport@5.0.0
    added 116 packages in 37.112s

#508

Anyone having problems with their Russound Smartapp not refreshing/updating as needed? I’ve noticed that the last few times I’ve used this, for example, within the Smartapp I’ll click on a different ‘Source’ and it physically changes the source but doesn’t recognize the change within the Smartapp. Same goes with turning it on/off, and other buttons as well.


(Peter) #509

I have the same issue. This has been going on for the last few months. I had asked redloro for help and he wanted to see the log file which I sent. I have yet to hear from him.


(Ken) #510

I’m having the same issue.


(Jim) #511

I have seen this issue as well. What I have had to do is remove the devices on the IDE website and then go to the smartapp and do the save again. Once I did that it fixed the issue. It’s usually after I lose power that I have had these issues.


(Jim) #513

I had some weird stuff that happened with smartthings IDE, found out there were different shards. Some of my smart apps and device handlers showed up on one shard but my devices didn’t. I wonder if something like that is happening with yours. Probably not but it frustrated me for a while.


(Jim) #514

Are u using a Raspberry PI? I’m having issues with even getting mine working. I have it working on my Mac but I don’t want to waste that resource just to run the STNP.


(Jim) #518

By shear determination I was finally able to get everything working on my Mac, but unfortunately I can’t get the RNET driver to install without the errors on the RPI3. I’m willing to donate money to anyone who can get me up and running at this point. It’s beyond my abilities at this point. If I see an error I recognize from my previous evolution using the Mac I will let you know.


#519

Have you tried installing as root…putting ‘sudo’ before the command?


(Ken) #520

I removed the devices and added them back and I’m still having the same issue.


(Adam Laakso) #521

Hi everybody. I just purchased an MCA-88X and I have the node server running on a Windows server. I can see the Smartapp discovering the Zones on the node server. But no things are being created in Smartthings. I do have both Smartapp and Device Handler installed as well. Any thoughts on why it’s not being added? I do have the c-series = true as well. All zones and source match my 88x

Thank you for your help in advance!


(Ken) #522

Did you configure the Smartapp on your phone/tablet? Make sure the discover toogle is on.


(Adam Laakso) #523

I sure did. And when I hit save I can see it “discover” on the node server cmd line. But never adds to Things


(Jim) #524

Try changing the controller number to 0 if it’s set to 1


(Adam Laakso) #525

{
“port”: 8080,
“authCode”: “05311”,
“rnet”: {
“c-series”: true,
“serialPort”: “COM4”,
“sources”: [
“Bluetooth”,
“Streamer”,
“Source 3”,
“Source 4”,
“Master TV”,
“Source 6”,
“Source 7”,
“Source 8”
],
“controllerConfig”: {
“type”: “discover”,
“zones”: [
{
“zone”: 0,
“name”: “Master”
},
{
“zone”: 1,
“name”: “Patio Lower”
},
{
“zone”: 2,
“name”: “Great Room”
},
{
“zone”: 3,
“name”: “Patio Upper”
},
{
“zone”: 4,
“name”: “Dining Room”
},
{
“zone”: 5,
“name”: “Kitchen”
},
{
“zone”: 6,
“name”: “Office”
},
{
“zone”: 7,
“name”: “Basement TV”
}
]
}
},
“notify”: {
“address”: “172.16.0.104”,
“port”: “39500”
}
}

This is my config


(Ken) #526

Make sure your controller is set to Master.


(Adam Laakso) #528

Looks like on the back it’s set to #1


(Ken) #529

I have the Monoprice amp and looking at the Russound that sounds correct.


(Toby D) #530

@redloro

Finally had a chance to take another crack at this. It’s been New Years since I last touched this and with Summer comingup, I want to be done with this. ANYONE who has insight, please chime in! I have gone through and completed a fresh install of Raspian on my RPi3. Removed node and reinstalled the lastest node (v8.1.1). Downloaded and unpacked the Smartthings-nodeproxy. Built the Json file for my setup (Monoprice 6 Zone). When I go to start the node server.js I keep getting errors:

Please let me know what I have missed or am doing incorrectly

Thanks in advance!!


(Adam Laakso) #531

Well I got it working…

You guys were right in where I needed to specify “controller”. I was missing this line in my config:

“controllers”: [
{
“controller”: 0,