SmartThings Community

[RELEASE] Russound Multi-Zone Controller Integration

smartapp_av
russound
dth_av

#427

I haven’t done much with the Russound. I actually thought I would go through Alexa as that integration will be coming out shortly! However my C5 series will not have integration with Alexa, so I maybe doing more in the future. It currently will turn on each zone and change volume. I haven’t tried changing the source input, but I think it could do that. I want to be able to set favourites so I could switch between Sirius and Spotify.
For what I have working today. I have installed google home and redloro Russound app. I renamed the zones in google home from RNET:living Room to just living Room. Then it worked. Ensure all of the components work before you try. Good luck.


(Ivan Reynoso) #428

Thanks. So much


(Todd M) #429

I was not able to get Alexa to change audio sources on my C5 without using the Ask Alexa app and webcore macros. Now it is easy. “Alexa, turn on the radio in the kitchen” or “Alexa, turn on the music server in the kitchen.” Those commands set the speaker volume to 40% (or whatever you set as default), select the audio source and turn on those speakers. I use Kodi running on an old desktop to manage my music collection. “Alexa, tell kodi to play the artist Def Leppard” or “Alexa, tell Kodi to play my 80’s Playlist” gets me rockin’ to my favorite tunes! I love it!!


#430

Hey Pantheon:

Here’s where I’m at.

I have a basement cable room that has my monoprice multi room controller. I have an echo dot connected to it via 3.5mm line out/3.55mm input into controller. This monoprice controller feeds speakers into 4 locations in my house. I named this echo dot “Speakers”.

I put an echo dot on my main floor to act as the microphone there.

Without ask alexa or anything other than this @redloro and @tcjennings developed node proxy and smart app, and the smart things skills added to alexa, I can do the following talking to my main floor alexa:

“Alexa, turn on [basement/office/living room/deck] speaker”.

            - this first command is to turn on whichever speakers i need on in the house 

"Alexa, play Spotify [or “play [artist/song] on Spotify] on Speakers”.

            - this gets the music playing through the basement echo dot which feeds into the controller and 
              outputs to the speakers i turned on.

I don’t have the ability to change sources (and admittedly that’s ok, as i primarily use spotify and having the echo dot connected to feed that source in is great), or to adjust volume (although i can adjust the actual echo dot output volume, which sort of works).

I’ve mucked about under the alexa settings “Smart Home” and tried to create groups from a speaker on off switch together with the basement echo dot, thinking that it might be smart enough if i named that group “Office Audio” as an example (which has the office audio toggle and the echo dot connected to the controller as the group members) it would turn on office audio and play music through basement echo dot. No such luck - if I say “Alexa, play spotify on Office Audio” it doesnt do anything.

So, my goal is ultimately what I think you’ve accomplished. I want to be anywhere in my house in range of an echo dot and to basically be able to say “Alexa, turn on [speaker in x room] and play [artist/song] on spotify.”

Is this basically what you have working?


(Todd M) #431

If you have “devices” in the Smartthings app (basement/office/living room/deck), then you should be able to control the volume of those “devices” through the redloro app. If I want to just change the volume of a particular speaker(s), I would say “Alexa, set the volume in the basement to 50 percent.” That is how my volume adjustments work with just the work from redloro.

I have not worked with the groups options on my Alexa yet. But if I follow your process correctly, then you are trying to execute a compound command by turning on Office Audio and playing Spotify through those speakers with your command “Alexa, play spotify on Office Audio.” Does that command actually turn on your Office Audio speakers? If so, what command do you use to turn Office Audio off?

This would be a compound command, ie. trying to turn on the chosen speakers AND start playing spotify through those speakers. If your echo dot (“Speakers”) is always your audio source, then this should be fairly easy with two separate commands. It appears that you have this working already.

But if you have different audio sources, as I do, then I think you will have to install the Ask Alexa app and run macros. That I what I have to do. I have several macro names such as “Turn on the radio in the bathroom” or “Turn on the music server in the kitchen.”

So when I say “Alexa tell smarthings to turn on the radio in the bathroom” then the “Turn on the radio in the bathroom” macro runs. It turns on the bathroom speakers, sets the volume to 40 percent and turns on the radio audio source. I execute several commands with a single macro. But I had to use Ask Alexa and webcore macros to accomplish this.

If I want to play music from my collection of mp3 files on my Kodi music server, then I have to use the Kodi-Alexa app to start playing those files (or playlists, or artists, etc.) off my Kodi server. I don’t use Spotify. But I will be integrating my Amazon Music Prime as an audio source soon.

So here is my setup. I walk into the bathroom. I have a dot there. I say “Alexa, tell smarthings to turn on my music server in the bathroom.” Then I say “Alexa, tell Kodi to play my 80’s playlist.” Then my 80’s playlist starts playing on the bathroom speakers at 40 percent volume. I can then adjust the volume with simple commands like “Alexa, set the volume in the bathroom to 30 percent.” I can next/previous/pause/stop music playback with simple commands like “Alexa, tell Kodi next.” I used to have to do all of these things on my phone with multiple apps and I had to keep my phone in the shower with me to make any adjustments. Now, I do it all with voice commands to Alexa.


(Kumar Mudedla) #432

Hi Everyone, Following thread from sometime and waiting to buy a 6 zone controller/amplifier and I need a suggestion from you on which device is the best in between Russound and Monoprice. I leaning towards Monoprice as its cheaper ($449 now). Is any one have any issues with Monoprice?


#433

No issues with the Monoprice app and the price difference is huge.


(Ken) #434

You may want to ask the question here: http://www.avsforum.com/forum/36-home-v-distribution/1506842-any-experience-monoprice-6-zone-home-audio-multizone-controller.html. I have owned the Monoprice Amp for almost a year with no issues.


#435

Pull request submitted, @redloro.


#436

@Pantheon would be interested also in your WebCoRE code. I am at the point where everything is working and have started the WebCoRE piece. I have a good idea of how to do it, just wondering how you did it as it may be more efficient than my method.

Thanks to you and@redloro as well for the great work you guys have done!

PS: have you got a way to change the tuner channels? That is the one part I would like to do as well. I can see it being done with favourites, but that feature doesn’t exist. Is there another way?


(Todd M) #437

Torgysk,
The WebCoRE pistons are really very simple. I have not attempted to do any tuner channel changing. We only listen to one radio station and currently it never changes. But I do plan on trying to add the ability to choose different radio stations. Here is my Bathroom Music Server piston. “Music Player 1” is the device name from redloro’s work (ie, my bathroom speakers). “Source1” is where my music server is connected to my Russound so “source1();” turns on that source. You can set the volume to any percentage you like. Then turn the device on. So when I say “Alexa, tell Smartthings to turn on my music server in the bathroom” the macro “Music server in the bathroom” is executed.


(Todd M) #438

I love my Russound MCA-C5. I do not have any experience with the Monoprice. There are pros and cons for both. BUT, I would not purchase the Russound MCA-C5 again. The high cost and the lack of ethernet, wireless and voice control are shortcomings. Yes, you can use the Russound XTS In-Wall Touchscreen (at $400 a piece). But I have invested lots of time and effort to attain voice control throughout my entire house with Alexa. I don’t think that is possible with either of them without the setup discussed here. I am not sure if the newer Russound/Monoprice controllers offer that capability out of the box.


#439

If I were purchasing again, I would buy Russound again, but I would go with the 66 or 88 series as Russound has announced native support for Alexa, which the MCA 5 will not have.


(Toby D) #440

Happy New Year’s Eve everyone!

I am absolutely new to Smartthings and RasPi, and the last time I did any kind of ‘code’ work was in 6th or 7th grade… many many moons ago. So here is my NOOBS dilemma, I know I’m probably over complicating this. I have gotten everything on to the RasPi3, updated to the newest Node (v9.2.1), set up the Smartthings Smartapp and Device Handler on Smartthings Website… I have confirmed that Node is there and installed… Ive gone as far as attempting to ‘pi@raspberrypi:~ $ cd smartthings-nodeproxy’ then ‘pi@raspberrypi:~/smartthings-nodeproxy $ npm run start’

then i get this:

smartthings-nodeproxy@1.0.0 start /home/pi/smartthings-nodeproxy
node server.js

[2017-12-31T14:07:47.547Z] [stnp] SmartThings Node Proxy listening at http://:::8080
[2017-12-31T14:07:47.555Z] [stnp] Error: ENOENT: no such file or directory, scandir './plugins’
https://github.com/EmergingTechnologyAdvisors/node-serialport/releases/download/5.0.0/serialport-v5.0.0-node-v59-linux-arm.tar.gz
^C[…] - : info lifecycle smartthings-nodeproxy@1.0.0~start: sma

I used one of my PCs to connect via RS232 and used a nifty little windows app from a guy called Mike I found on YouTube. http://youtu.be/fHB_gjc1w8Q but I want to run it via the RasPi3 instead of leaving it connected to a PC. I must be missing a step somewhere or I’m just a complete NOOB (or both). I’ve gone down thru this entire post and read each comment to see if I have missed anything. Now I am in information overload. Any help is much appreciated


(Todd M) #441

Torgysk,
I just read the product info on the MCA-88 series and did not see any mention of Alexa support. Is that something Russound is “planning” to add?


#442

They have announced it. I am a russound installer and took a quick webinar on how to set it up. A firmware upgrade is coming any day now that will enable this. it was announced on their website.
There is an Alexa link and it notes what systems are supported.

If you cannot find let me know and I will send you a link.


(Todd M) #443

I found it. Excellent! A bit too late for me though…


(Todd M) #444

Can I get Alexa control with my MCA-C5 with this update? The Russound web site says “Please contact your Russound Certified Installer to add voice control with Amazon Alexa to your Russound system.” Do I have to do that or can I install this functionality myself?


#445

The MCA-5 cannot be firmware updated to enable Alexa. The Russound website does have a list of equipment that is update able to enable this feature

I am in the same boat as I have an MCA-5 as well.


#446

Hi @redloro - thanks so much for this project, it’s exactly what I was looking for. However, I think I’m having an issue with the rnet plugin - when I try to run STNP I get a bunch of errors - but I also see a potential problem when I try to install the rnet plugin:

pi@raspberrypi:~/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy $ npm run start

smartthings-nodeproxy@1.0.0 start /home/pi/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy
node server.js

[2018-01-01T15:45:18.521Z] [stnp] SmartThings Node Proxy listening at http://:::8080
/home/pi/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy/plugins/rnet.js:1
(function (exports, require, module, __filename, __dirname) {
^

SyntaxError: Unexpected token <
at createScript (vm.js:80:10)
at Object.runInThisContext (vm.js:139:10)
at Module._compile (module.js:599:28)
at Object.Module._extensions…js (module.js:646:10)
at Module.load (module.js:554:32)
at tryModuleLoad (module.js:497:12)
at Function.Module._load (module.js:489:3)
at Module.require (module.js:579:17)
at require (internal/module.js:11:18)
at /home/pi/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy/server.js:88:35
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! smartthings-nodeproxy@1.0.0 start: node server.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the smartthings-nodeproxy@1.0.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/pi/.npm/_logs/2018-01-01T15_45_18_570Z-debug.log

So you can see there that the plugin isn’t loading. This is what I get when I try to install the plugin (downloaded the one that you posted back in August):

pi@raspberrypi:~/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy $ npm run install:rnet

smartthings-nodeproxy@1.0.0 install:rnet /home/pi/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy
npm install && npm install serialport@5.0.0

up to date in 5.491s

serialport@5.0.0 install /home/pi/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy/node_modules/serialport
node-pre-gyp install --fallback-to-build

node-pre-gyp ERR! Tried to download(404): https://github.com/EmergingTechnologyAdvisors/node-serialport/releases/download/5.0.0/serialport-v5.0.0-node-v57-linux-arm.tar.gz
node-pre-gyp ERR! Pre-built binaries not found for serialport@5.0.0 and node@8.9.3 (node-v57 ABI) (falling back to source compile with node-gyp)
make: Entering directory '/home/pi/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy/node_modules/serialport/build’
CXX(target) Release/obj.target/serialport/src/serialport.o
CXX(target) Release/obj.target/serialport/src/serialport_unix.o
CXX(target) Release/obj.target/serialport/src/poller.o
SOLINK_MODULE(target) Release/obj.target/serialport.node
COPY Release/serialport.node
make: Leaving directory ‘/home/pi/Smartthings/NodeProxy/smartthings-master/smartthings-nodeproxy/node_modules/serialport/build’

  • serialport@5.0.0
    updated 1 package in 31.321s

It looks like it’s not attaching to the usb serial port - I’ve tried it with the config set to “usbser” and also specifically defined “dev/ttyUSB0” which is where the connection is. Not sure where to go from here since I don’t think the physically connection is the issue. Any thoughts?

Thanks in advance!