SmartThings Community

[RELEASE] Russound Multi-Zone Controller Integration

smartapp_av
russound
dth_av

#407

Awesome (enjoy your vacation!)


(Ivan Reynoso) #408

Enjoy the VAC…


#409

Yes - when it’s setup correctly all manual changes to the system should get reported back to ST.


#410

Yes please… can you submit a PR in GitHub so that I can merge the changes?


#411

Traveling for business this week, redloro, but I’ll try to submit the PR this weekend. It’ll be my first PR in GitHub and I’ve been meaning to learn how to contribute back changes, so this is good.


(Peter) #412

Redloro… I am pretty sure my setup is correct. What exactly should I check? Thanks for your help.


(Todd M) #413

redloro,
Your work with the Russound has been awesome and as I initially said to you has started a fire in my brain. I cannot say thank you enough. I have now incorporated the Kodi app into this system and can voice-control nearly everything that is audio related in my home. “Alexa, tell smart things to turn on the music server in the bathroom” or “Alexa, tell smart things to turn on the radio in the kitchen” will set the audio source to my music server (or whatever I say), sets the volume to 40 percent and turns on the speakers in the bathroom (or wherever I choose). I have webcore macros for every music source and every speaker location in my home. AWESOME!! Then, “Alexa, tell Kodi to play the playlist Todd’s 80’s” starts my playlist or “Alexa, tell Kodi to play the artist Foreigner” starts playing my Foreigner collection. From your work I can then easily ask Alexa to adjust the volume, mute, loudness, etc. I can use Alexa and Kodi to easily navigate through my music server with all of the typical playback controls. I am now trying to program compound commands for Alexa to select an audio source, turn on the speakers and start playing music in one command. Your Russound Zone Device Handler made things in webcore extremely easy. Long story short, your hard work with Smartthings and Russound has made this entirely possible and I could not have accomplished this without you. Thank you so much.


#414

Run the following test with the STNP logs up:

  • Turn Zone 1 ON with the ST app and record the logs
  • Turn Zone 2 ON manually and record the logs

Zone 1 and Zone 2 should show ON in the ST app…if they don’t send me the logs…


(Peter) #415

Redloro… how do you see and activate the SNTP logs? Which directory? Sorry for the noob questions. Thanks.


(Peter) #416

Hi redloro… I am getting the following when type node server.js

pi@raspberrypi:~/smartthings-nodeproxy $ node server.js
events.js:141
throw er; // Unhandled ‘error’ event
^

Error: listen EADDRINUSE :::8080
at Object.exports._errnoException (util.js:874:11)
at exports._exceptionWithHostPort (util.js:897:20)
at Server._listen2 (net.js:1234:14)
at listen (net.js:1270:10)
at Server.listen (net.js:1366:5)
at EventEmitter.listen (/home/pi/smartthings-nodeproxy/node_modules/express/lib/application.js:618:24)
at Object. (/home/pi/smartthings-nodeproxy/server.js:74:18)
at Module._compile (module.js:435:26)
at Object.Module._extensions…js (module.js:442:10)
at Module.load (module.js:356:32)

What I am doing wrong? Please help. Thank you.


#417

You’ve got some other service listening on port 8080… restart your pi and/or change the port in config.json


(Peter) #418

Which port number do I select? I am using the same pi also for my alarm server using port 8111.


(Ivan Reynoso) #419

This sounds fabulous, do care to share your set up with Kodi and Alexa…love to try it


(Peter) #420

H redloro…here is the log. I turn on zone 1 with the ST app (no issue) and I turn off (no issue). Go to turn on zone 2 manually as you instructed and there is NO log recorded. There is no communication when I manually turn on.

Please help.

Thanks.

pi@raspberrypi:~/smartthings-nodeproxy $ node server.js
[2017-12-15T00:53:21.699Z] [stnp] SmartThings Node Proxy listening at http://:::8080
[2017-12-15T00:53:22.816Z] [stnp] Loaded plugin: rnet
[2017-12-15T00:53:24.232Z] [rnet] Detected serial ports: ["/dev/ttyAMA0","/dev/ttyUSB0"]
[2017-12-15T00:53:24.263Z] [rnet] Connected to RNET: /dev/ttyUSB0
[2017-12-15T00:53:33.929Z] [stnp] ::ffff:10.0.1.4 GET /plugins/rnet/controllers/0/zones/0/state/1
[2017-12-15T00:53:34.223Z] [rnet] {“type”:“zone”,“controller”:0,“zone”:0,“state”:1}
[2017-12-15T00:55:11.345Z] [stnp] ::ffff:10.0.1.4 GET /plugins/rnet/controllers/0/zones/0/state/0
[2017-12-15T00:55:11.406Z] [rnet] {“type”:“zone”,“controller”:0,“zone”:0,“state”:0}


(Peter) #421

I solved the port issue. I sent you the log display.


(Todd M) #422

Absolutely, I’ll share everything that I have. I’ll help in any way that I can. I was determined to get this working and certainly there were some frustrations along the way. But it is AWESOME now. Basically, you must set up the Smartthings Node Proxy and the Russound Device Handler as redloro has detailed. You have to have all of that working properly FIRST. Then you can use the Smartthings app on your phone to access and control the Russound “devices” (RNET : Kitchen, RNET : Bedroom, etc.) that are populated into your Smartthings phone app by redloro’s Smartthings/Russound work. Then, install ASK ALEXA from MichealS and get it working. Once Ask Alexa is up and working I will be happy to give you my webcore code. The code itself is very simple and will be specific to your setup. At this point you will be able to tell Alexa to turn on any of your speakers (“Devices”), select any source and adjust the volume. Next, the Kodi-Alexa app. The Kodi-Alexa app is amazing and was the easiest of all to get up and running. Then, you can tell Alexa to tell Kodi to play your favorite playlist or artist or song, etc. All of this sounds complicated. And it was at first. But now that I have it working it was not that difficult at all. I just had to learn some basic json and webcore. Huge shout out to redloro, MichaelS and m0ngr31 for all of their hard work to make this possible.


#423

Ok - great… looks like we need to bump up debugging to get to the bottom of this. I think someone very early on had reported something similar but I thought we had got that worked out… maybe not. In any case, we should be able to get to the bottom of this… I’ll shoot you a PM.


(Ivan Reynoso) #424

Perfect I have the MPR and is working perfect, I just need to set up the Alexa part, I have not yet pulled the trigger to the assistant but now I’m ready. Will let you know once I’m up and running.

Thanks


#425

Just wondering if there is a plan to add favourites to this program? I have integration with google home and it works ok. I would like to have favourites added so I can have google control the inputs!

Thanks!

Jeff


(Ivan Reynoso) #426

Torgyst, what did you do to get the Google home to work and what commands do you have working?