SmartThings Community

[RELEASE] Russound Multi-Zone Controller Integration

smartapp_av
russound
dth_av

(Steve Davies) #367

LOL I double checked nothing else was attached. Also rebooted the PC and Russound for good measure. Even attempted other COMs… No change.


#368

Ok - let’s try something else… it may be that SerialPort 6.0 (which was released 16 days ago) breaks this…

  1. From the command line where STNP is installed…
  2. Run npm uninstall serialport
  3. Then run npm install serialport@5.0.0
  4. Then run node server.js

And report back…


(Steve Davies) #369

You sir are amazing!
IT WORKS!!! I can’t thank you enough! Honestly, I can’t think of anyone I’ve interacted with online who has been this supportive. Hats off to you sir!


#370

Awesome! I’ll update the repo so that this doesn’t happen to the next guy… :slight_smile:


(Todd M) #371

Having similar problems here too. I was able to get my Smartthings app on my phone to populate with the Russound switches but now that does not work. I uninstalled the serialport and installed serialport@5.0.0 Here is what I am getting after “npm run start”

smartthings-nodeproxy@1.0.0 start D:\smartthings-nodeproxy
node server.js
[2017-10-29T20:27:33.771Z] [stnp] SmartThings Node Proxy listening at http://:::8080
[2017-10-29T20:27:36.438Z] [stnp] Loaded plugin: rnet
[2017-10-29T20:27:36.922Z] [rnet] Connected to RNET: COM3
[2017-10-29T20:27:37.031Z] [rnet] Detected serial ports: [“COM3”]
[2017-10-29T20:33:18.860Z] [stnp] ::ffff:192.168.0.17 GET /subscribe/192.168.0.17:39500
[2017-10-29T20:33:20.467Z] [stnp] ::ffff:192.168.0.17 GET /plugins/rnet/discover
[2017-10-29T20:33:20.779Z] [rnet] {“type”:“discover”,“zones”:[{“zone”:0,“name”:“Craft Room”},{“zone”:1,“name”:“Great Room”},{“zone”:2,“name”:“Kitchen”},{“zone”:3,“name”:“Master Bath”},{“zone”:4,“name”:“Master Shower”},{“zone”:5,“name”:“Patio”},{“zone”:6,“name”:“Workshop”}]}
[2017-10-29T20:33:20.779Z] [rnet] Completed controller discovery


(Todd M) #372

Not sure what I need to do to get voice volume control through Alexa. Can you explain a little more how you were able to get that working?


#373

What’s not working? Looks like the service is running and you did a device “discovery” from the SmartApp.


(Todd M) #374

Ok, got the SmartThings app to populate. It would help if I would just watch your video again when I have problems. Did not “npm install” for the dependencies. Is that in the FAQ? You mention it in the video but I do not see it in the FAQ. Anyway, now I am not getting any sound to my speakers. I can choose speakers, source and volume but no sound. If I load the Russound app (on my phone) that sound works.


#375

Which Russound controller do you have? Can you confirm if you turn ON/OFF a zone that the zone is actually ON/OFF?


(Todd M) #376

MCA-C5. It appears that when I turn on the zone using ST (not using Alexa) that the zone is not actually turned on. I had this working once. But I have since re-installed windows on a dedicated ST proxy laptop.


#377

Oh yeah… did you set

"c-series": true

in your config.json? What you are seeing would happen if this is not set.


(Todd M) #378

yep, got it…

{
“port”: 8080,
“authCode”: “secret-key”,
“rnet”: {
“c-series”: true,
“serialPort”: “COM3”,
“sources”: [
“Tuner”,
“Music Server”,
“Great Box”,
“Master Box”,
“Porch Box”,
“Bluetooth”
],
“controllerConfig”: {
“type”: “discover”,
“controllers”: [
{
“controller”: 0,
“zones”: [
{
“zone”: 0,
“name”: “Craft Room”
},
{
“zone”: 1,
“name”: “Great Room”
},
{
“zone”: 2,
“name”: “Kitchen”
},
{
“zone”: 3,
“name”: “Master Bath”
},
{
“zone”: 4,
“name”: “Master Shower”
},
{
“zone”: 5,
“name”: “Workshop”
}
]
}
]
}
},
“notify”: {
“address”: “192.168.0.17”,
“port”: “39500”
}
}


(Todd M) #379

All works GREAT now!!! Redloro, many, many thanks…
Faulty USB cable…


#380

So, I haven’t revisited this topic since I got this working earlier in 2016. Haven’t changed anything aside from regular app updates in ios to the smart things app.

The smart things app no longer accurately shows the states of each zone. They default to off, and even if you turn them on (which turns on the zone and the wall panel lights up) the app on refresh will show it as off. If you turn it back on, and then off again, it will turn the zone off.

Any idea what might have changed to cause the ios app to no longer reflect the right zone state?


#381

There have been a bunch of updates and improvements to the SmartApp and STNP plugin… suggest you update all as well as your config.json - that should resolve your issues with zone state. Note that you should probably remove all your zones before the update and allow the new SmartApp to recreate them for you.


(Todd M) #382

Will do. Thanks.


(Desirae A) #383

What do I say to Alexa to control the volume? Can I control the sources as well through Alexa?


(Ken) #384

@redloro Same question, I re-installed the Smart App and Device Handler tonight, but cannot control the volume to the zone via Alexa.


#385

You can control via the SmartThings app right?? Have you looked at Alexa Helper?


(Ken) #386

Yes, the app works correctly. I just looked at the helper, I can’t find anything.