[RELEASE] Ring Alarm Keypad (2nd Gen) Device Handler

A little tip here, the default timeout for a pin entry is 2 seconds. Sometimes due to mesh issues or platform latency it may take more than 2 seconds to for the communication to complete and hence it times out. A typical symptom is what you’ve seen here, arming/disarming manually works but the keypad doesn’t seem to respond (that’s because the pin code is a series of events and everything must be completed within the default 2 seconds timeout).
The solution is simple, open the device settings page and increase the Pin entry timeout to 10 seconds. That should take care of mesh delays/platform latency for most situations.

1 Like

Does anyone know if the Ring KeyPad Gen 1 can work with RBoy’s LUM and with arming/disarming STHM?

Wondering if anyone could offer advice? I would like to use @RBoy (@maddie) Intruder Alert SmartApp as my home security system. I purchased the Ring Keypad and successfully paired it. I have some questions, though, and I’m hoping someone with a lot more experience/expertise can help . . .

  1. Is it a good idea to use IA as the main app (as opposed to SHM)? Are there obvious drawbacks (like working well with Ring Keypad)?

  2. Does the Ring keypad work well with IA? I am still trying to figure out how to arm/disarm from the keypad. Will the system stay in sync when I turn it on/off from a virtual switch I have created?

  3. I see people talking about Lock User Management @RBoy app. Is that something I should be using with the keypad? I also see a lot of people discuss needing Webcore if they have the Ring keypad. What function does Webcore play in the setup? I use @joshua_lyon . Can I do the same thing with it?

I am grateful for any basic info related to these questions.

Ring Keypad (Gen2) - Version 02.01.01

  • (New) Custom controls and UI for the new ST app
  • (New) Select keypad arm mode (Armed Away or Armed Stay) when “locked” from the settings page (default Armed Away)
  • (Enhancement) Increase default pin code entry timeout to accommodate for mesh/platform latency
  • (Fix) Sync lock state with arming mode when sending direct commands to the keypad by SmartApps


IMG_0056 IMG_0055

NOTE: You may need to exclude your keypad, delete the DTH and reinstall it for the changes to take effect. When pairing please follow the instructions in the first post to use S2 pairing for improve reliability and responsiveness.

1 Like

Woohoo! Excited to update my DTH.

1 Like

just paired another ring keypad and no red network light yet…

Are you holding the 1 key to get it into general pairing mode?

yep, pairing in the new app, 1 key for a few seconds until the green network light blinks fast.

Which hub are you using?

v2 hub 200

@RBoy

I updated but in webcore if you set to armed stay it announces armed away and then armed stay. Previously it didn’t do this.

That’s probably because your webcore rule is sending both commands, first Lock (ArmedAway) and then ArmedStay. As a guideline use Lock only for SmartApps (e.g. Automations) where the custom capabilities (ArmedAway/ArmedStay) aren’t available.

We’ve released an update (v02.01.00) today with an additional feature, now the user has the option in the settings page to select the keypad arm mode (armedAway or armedStay) when “locked” (the default is armedAway).

If I do this without the lock command

The problem is you will end up with it set to armed stay but unlocked.

My automations rely on being able to check this lock state, so I need it to show as locked when armed stay is active.

It didn’t do this before the update. Maybe it was a latency issue but it would only speak home and armed with that piston.

Yes it’s probably the latency but that’s a good point, it should report as locked when armed and vice versa. This feature has been added in v02.01.01.

I updated and can verify that the issue is fixed and it works great now.

@RBoy

i have noticed that when a ring alarm keypad is paired using the classic app security will be s0_downgrade and the wireless red light will show when there is keypad activity.

when a keypad is paired using the new app and automated then security will be s2_failed, but no wireless red light.

so, does this mean that if a keypad is paired using the new add and manually using the sdk code that it should pair with security as s2_authenticated and no red wireless light?

Classic app doesn’t support S2. Are you choosing the z-wave brand in the new app when pairing it?

Ring Keypad (Gen2) - Version 02.02.00

  • (Enhancement) Improve handling of mesh/platform delays and out of ordered packets to improve keypad code entry reliability

If you’re facing issues with key codes not registering consistently (which is caused by mesh or signal problems), this update will help address some of those issues.

1 Like

it was rather obvious that the classic app didn’t support s2.

yes, when i paired in the new app i chose z-wave brand.

when i pair the next i will pick z-wave and have to figure out how to manually put in the sdk.

@RBoy

I can’t seem to input my key code since this update. It says my user code is invalid.

I tried going into LUM and sending the code again, it doesn’t seem to work.