[RELEASE] Ring Alarm Keypad (2nd Gen) Device Handler

I see you need a “webcore piston”
I have never used Webcore before though. Not very familiar with it.

Yeh the webcore piston is to set armed stay. Idk why but thru the automations in Smartthings it won’t arm anything but away…

You don’t need webcore if you use Lock User Management (LUM) from RBoys with the Ring keypad.

1 Like

Hmm can you screenshot how you configured LUM (I have LUM)

You need webcore if you want it to sync both directions.

1 Like

I have not had to use Webcore to use the keypad to set Armed/Stay/Home. Not sure what you refer to with “sync both directions”.

Anyway I am using the new App and I have a separate LUM smartApp for the new ring keypad. I know it says Arm Classic SHM it is working for me and I only use the newer version STHM. The button actions are just setting mode to either Away or Night. This will then trigger Automations some what like in a prior post that does all the real work.

So there is no way to use webcore directly using the subscribe to armMode numbers? Or am is missing something here?

I posted a snippet of a routine i created in webcore above… once you add ActionTiles to the mix I think it’s easier to use webcore to keep it all In sync…

1 Like

My Ring keypad arrived and I just found out that I’ll have to purchase the license from RBoy to get the device handler. It would be nice if you could mention that in your first post so that people don’t feel misled.
$40 for a license is a lot to make my $50 device work.

1 Like

Buy two keypads… offsets the $40 :slight_smile:

1 Like

The red wifi light is on a lot with my keypad and I can’t arm/unarm or turn off the siren when it is on. Any suggestions?

  1. Is it paired securely?
  2. If you move it closer to your hub - does the signal light go off and it responds quicker?

You can bypass the keypad all together and use Alexa to arm/disarm SHM using secret words. I created a 20 second delay on specific entry doors, Alexa welcomes us home and reminds us to disarm the alarm. If you don’t tell her the secret word, the alarm will sound and lots of notifications get sent to various phones. I even created a distress feature in which the system will disarm and notify 6 people to call 911 if a specific word is used. Alexa will even provide a spoken audible alert on my and the wifes phone should someone use this word.

You can ask Alexa if the alarm is on or off and I incorporated 2 LED bulbs strategically placed in the house that change colors to green, yellow and red depending if SHM is set to disarm, stay or away. This provides for a visual indicator as to the alarm status.

It was actually a very simple setup using 1 piston with maybe 20 lines. Several virtual switches and some Alexa routines.

The red wifi light is on less now, but the keypad is taking 10-60 seconds to register that I’ve put in the code, armed it or disarmed it.
Just now, I tried to arm the system with the keypad. Nothing happened. The red wifi light isn’t on. The device shows connected in Smartthings.
Overall, this seems to have been a waste of $90.

Sounds better… what did you change? Where is the bottleneck. Mine responds within a second

Thanks for your response. I’m not sure what helped with the red wifi light. It is in the same location.
I don’t know how to find out where the bottleneck would be. I have 65 devices but not experiences any delays with my other devices.

Update: The keypad is not responding at all when I type in the code and try to disarm, or arm. It arms and disarms when I use STHM in the app. I don’t know what has gone wrong. It was working a few days ago and I didn’t change any settings.

i am having one heck of a time trying to include/pair a ring keypad again.

after resetting it with the pinhole in the back, there is no response on the front. during pinhole pressing the green wireless light on the front flashes fast for several seconds and then flashes red for a couple of seconds.

so during reset when the white light under the keys blinks off then i pressed and held the 1 key while still pressing the pinhole in the back and the green wireless light started blinking slowly. then i put the hub in include/join mode and it appeared to join. though there is no response from the keypad or the app to the keypad. also, in the app the battery icon has a dash below it.

in the logs i see a warning “Unrecognized device. Contact developer with MSR null”

Okay, I was able to fix this by pressing the pinhole one time in the back and the white keypad light came on in the front. i looked at the log and it was syncing and updating. in the app i pressed the refresh circle and it updated the battery status and the keypad said disarmed.

i have 2 ring keypads (so far) and they are showing the red networking light. one keypad is about 10 feet direct path to the hub and then other is about 30 feet direct path to the hub. the red light appeared the second day after pairing. though, they still respond and work.

I have downlaoded several RBoy apps and don’t get some of the screens that are shown above as screen captures. Why? For example, on the Ring 2nd Gen, I don’t have the screenshot on the far rights (with graphical display of disarmed, unlocked, autolock, etc).

Hey there. The screenshots in the first post are a mix of the Classic app and the new app. We’ll be updating the DTH soon to bring some of those advanced custom UI controls into the new app. Please subscribe to this page or our facebook page for the upcoming release information.