[RELEASE] Ring Alarm Keypad (2nd Gen) Device Handler

@RBoy @leonardo I just bought one and have the same problem not be able to use chime feature. I tried also via Webcore to trigger it but no luck.

One more thing is that I can’t see any of buttons in my device, Fire, medical…they should have be mapped in device handler.

Info about keypad:
zw:Fs2ac type:400B mfr:0346 prod:0101 model:0401 ver:1.16 zwv:7.12 lib:03

Thanks

@Dr_Crimper The last question,

It’s working here:

If the chime isn’t ringing then it’s losing packets in the mesh (or may need a factory reset). Since it’s a sleepy device it’s very sensitive to mesh delays and packet loss, adding a good buffering device close to the keypad and moving it closer to the hub will resolve most issues with no responses, partial responses or slow responses.

I saw that video. I really don’t think that’s the issue as I’ve seen many others with the same problem. I’ve got 3 of these, all in different locations. I’ve reset them all and added again. I have no issues with any other features. All keypads arm and disarm and I can change all the settings without issue. Anything I could send from the logs that might help??

1 Like

Thanks snijjar, let me try that.

Btw. how come your first screenshot looks like that? You have the “firebutton” and “medical button” specified, when I added the ring keypad via the Rboy device handler it looks like this:

Did i do something wrong?

In snijjar post [RELEASE] Ring Alarm Keypad (2nd Gen) Device Handler - #202 by snijjar

There are buttons for fire, medical… im not sure how he mannaged this?

You need to just scroll down to see these buttons and assign them if you plan to use them.

If you don’t see anything please check in ide if you are actually using Rboy’s handler and not another handler.

Also make sure you’re in the latest version of the handler.

@Dr_Crimper
I have a feeling that EU version is not supporting those buttons for some reason or there is actually a newer version of keypad that this DH not fully supports.
If that’s true then some things in first post are not correct and should be clarified or removed.
The same thing is with some of us not being able to use chimes for some reason.
We can’t just post link’s to posts from 2 years ago and saying that it’s working when it clearly is not.

Ok interesting, hope rBoy is reading this? Must be a way for them to do some beta testing on EU device to figure this out

Finally got the ring keypad to work with STHM back and forth, perfect. Thank you mvevitsis :grin:

BUT one thing is still not quit right. When armering from the Ring keypad the “Armed Stay” and “Armed Away” is switched around. So when I press “Armed stay” on the keypad the voice says “Home and Armed” BUT the exit delay (set for “Arm Away”) starts AND the STHM switches to “Armed Away”.

I checked everything and it looks like its setup like its shown in this forum so if anybody has an suggestion would be great. Thanks.

Did you set the webcore piston?

Yes, think its correct?
image

You need to make sure that keypad lock triggers the virtual switch sthm stay, not sthm away.

Ring Keypad (Gen2) - Version 02.06.00

  • Added support for EU version of the Ring Gen 2 keypad

You may need to exclude and re-pair EU keypad for the changes to take effect. Also recommended to add a buffering repeater close to the keypad for optimal operation

:+1:
Super fast support

Superb work @RBoy :grin::+1: now I can see all buttons.

Only thing that is not working is still chimes and I can hear them if I put keypad against my ear like in distance, like that volume is turned down to almost zero or something. It could be that my unit is defective but as there are others so I assume that something in device handler needs to be tunned upp regarding sound volume maybe.

Thanks again for your hard work :+1:

It’s already there in the preferences page, Annoucement volume

That one is only affecting announcements and not chimes, looks like that anyway. Announcements are working as they should.
Strange thing this with chimes, signal is coming to keypad and it’s executing command but it’s barely hearable. Maybe there is something about volume they changed, I’m just speculating now :grin:, or they don’t want us in EU to use chimes 🤦:rofl:

@maddie , my V2 keypads are confused about being plugged into AC. Does that affect battery life or any other functionality?