[RELEASE] Ring Alarm Keypad (2nd Gen) Device Handler

That one is only affecting announcements and not chimes, looks like that anyway. Announcements are working as they should.
Strange thing this with chimes, signal is coming to keypad and it’s executing command but it’s barely hearable. Maybe there is something about volume they changed, I’m just speculating now :grin:, or they don’t want us in EU to use chimes 🤦:rofl:

@maddie , my V2 keypads are confused about being plugged into AC. Does that affect battery life or any other functionality?

@RBoy User from US here i am using V2 Keypad. The chimes dont seem to work i see “2:05:27 PM: info Triggering Chimes: [Security Keypad]” If i put the keypad speaker holes very close to my ears i can hear the chimes. I just brought brand new unit from bestbuy? I see @Adnan_Sarajlic reporting the same

1 Like

@sub263 Exactly the same behavior :+1:

1 Like

UPDATE: A new update for the DTH has been released which addresses the soft/no sound beeps / chimes for the keypad with newer firmware. (v02.07.00)

Apparently the soft chime for some users is a known issue with these keypads, some users seem to have this issue while others don’t. Possibly a hardware issue: Keypad (Gen 2) how to increase volume of alarm speech + tones - Ring Alarm - Ring Community

Ring support recommends doing a complete factory reset of the keypad (see first post) or asking Ring for a replacement: Sound on my Keypad was going and is now gone - #10 by Sschwegler - Ring Alarm - Ring Community

I’m having the same trouble getting reverse Arm(Stay) state pushed to the device. I saw a bit of script and am guessing that’s a webcore screenshot, but I’ve not seen detailed directions telling you exactly what to configure, where. I don’t have webcore installed, and when I went to add it, there was a setup asking about actuators, sensors (keypad is not an option) so it’s all a bit confusing. Any help would be appreciated.

UPDATE: I installed WebCore and poked around until I found you have to add the virtual switches and keypad in, then create a web piston (didn’t know what that was) to fire off the logic shown above. After doing so I am able to setup Arm (home) from action tiles or via virtual switch and have it propagate down to the keypad and STHM.

Now I’m trying to figure out how to get the Ring Keypad to do the countdown arm sound when you begin Arm (away).
UPDATE 2: Looks like this has to be done with Intruder Alerts with Actions > create new monitor > Intruder actions > set entry delay and turn on alarms (keypad), then in Arm/Disarm under Any of these switches are on I set to the Arm(Away) virtual switch.

This is probably a very dumb question, but I’ve been trying to figure it out for a good hour now. I’ve set up a user using ULM, gave it a 4-number pin. I set up the virtual switches to arm/disarm. But when I enter the pin, followed by any of the 3 buttons, I always get an Invalid Code Detected Event.

I have tried to set up additional users with different codes, I extended the timeout duration, all this to no avail. I’m using the latest DTH (although it displays as Enhanced Z-Wave Lock, I validate its the code from the Ring keypad integration).

A bit at a loss here. Anyone have pointers on how to resolve this? Thank you!

Had some time to spare. Rereading the initial instructions, I realized I had paired using the QR code directly, so I excluded the keypad and paired it using S2 Mode. But when I did that, it never asked me to scan the QR code or enter anything - it paired as a generic Z wave device, and that’s it.

After changing its device type, it synchronized user pins. But when I enter one, it just doesn’t do anything - no event for code invalid, no event at all.

Will re-exclude tonight and start from scratch again. Any tips on the pairing part? Why did it not ask for anything once I started pairing?

Tried to exclude, wasn’t detected by Smartthings anymore. Re-added it and it works as expected now. Ghosts? Full moon? We’ll never know but thanks for reading!

Ring Keypad (Gen2) - Version 02.07.00

  • (Fix) Ring Gen2 keypads with firmware 1.09 and above would not beep/chime
  • (New) Added the ability to adjust the Chime/Beep volume

Recommended to add a buffering repeater close to the keypad for optimal operation

Hi,

I am new with the ring keypad v2 and the DH so I have a couple of questions.

  • How do I define the pincode?
  • Define Arm delay?
  • Select alarm sound?

Best regards
Christian

This fails for a simple scenario, unless I’m missing something:
lets start with everything disarmed and both STHM buttons off
lets set security mode to “away” in STHM:
Because of the first screenshot the alarm will lock, that is good
But because of screenshot 6 [Auto Disarm(Away)] it will change the security mode back to disarm.
Am I missing something?

It doesn’t, because ‘all conditions must be met’ is enabled, and the switches will only change state again based on user input.

Hi. I’ve been trying to set up a “Stay” mode that synchronizes between two keypads. I’ve used Webcore to set the unused keypad to “Locked” and its mode to “ArmStay”, but this conflicts with the setting at the keypad level, which forces the selection of a mode when locked (Away by default). This means when I lock the second keypad, it triggers my “Arm Away” routines.

Has anyone been able to figure this one out?

Sorry but no. Right from the start when you arm the system by tapping "Arm (Away)"in SHM on your phone, all conditions are met for 2 rules:
“Alert Away” which will arm the keypad which is fine
and
“Auto Disarm (Away)” which will disarm SHM and left both devices out of sync

It doesn’t, because LUM is set to trigger based on the keypad status, setting the virtual switch to on. You may need to add a delay if auto disarm is triggering before LUM.

@RBoy i bought the handler and it works quite well.
I’d like to create this scenario:
1)alarm on dealing the code to the keypad and in 30 seconds it turns on
2)when i come back home, i open the door (where i have a contact sensor) and the keypad start chaining for 30 secs…
3)if in 30 secs i disable the alarm everything fine, if not the siren start louding.

4)is it normal that if the siren is louding, if i press a key it stops? it’s not very good, it should stop only when i insert the code to disable the alarm.

See this app: [RELEASE] Security System: Intruder Alert with Actions

That’s how the keypad is designed to operate, it’s not configurable

thanks.

That’s how the keypad is designed to operate, it’s not configurable

it’s a little stupid, if i’m a thief and the keypad starts ringing it’s not right that it stop lauding… could you improve the software to avoid it? I don’t think that if i use it with original amazon configuration it works like that

Hi @RBoy is there a plan to have this keypad running in Edge?

1 Like