[RELEASE] Resilient - My Ecobee Device & ecosystem v5 - The smartest thermostat under ST with new "comfort tips" features and Unique Integration with Echo/Ask Alexa

askalexa
ecobee
thermostat
climatecontrol
dth_hvac

#780

I did that before making my original post. Now I am trying to relogin with Ecobee as my thermostat is back online.

Edit: I was able to log back in and all seems to be working now.


(Yves Racine) #781

Yeah, I just checked at multiple user locations for those who have paid for my support packages, and the code has been able to recover from this ecobee outage…

No issues whatsoever.

Regards.


(Andres Castano) #782

Guys I’m getting this error message when I try to open the ecobeeSetZoneWithSchedule SmartApp. Please let me know if you are facing the same issue.

Thanks


(Yves Racine) #783

Hi, this could be a temporary ST issue under your ST account/shard.

Please try again later.

P.S. I supervise many user locations for contributors who paid for my support packages, and I’ve not seen any specific issues related to ecobeeSetZoneWithSchedule.


(Yves Racine) #784

Hi,

Just want to inform my contributors that a new version (v5.9.9s) can be downloaded at my e-commerce solution provider (sellfy) using the original download link or your sellfy account provided that you’ve followed the update procedure indicated at my store (under the terms of service).

If you’re are an active contributor to one of my support packages (and I have access to your ST account), the upgrade has already been done for you. You don’t need to do anything, everything has been taken care of.

Following the ecobee outage yesterday, I added new features to be able to recover any relevant
commands by “piling them up” so that they can be replayed over when the outage is fixed over a period of an hour.

This feature, combined the actual resilience of My Ecobee device (to avoid any ecobee disconnects), will ensure even more robustness for my contributors and their HA scenarios.

Regards.


(Andres Castano) #785

Hey buddy,

After no luck for more than 24 hours I had no other option to uninstall and
the reinstall the SmartApp from IDE it worked for a couple of hours but I
had to build my setup from scratch, it worked for a couple the hours but
the issue is back again.
Tell me what can I do now


(Yves Racine) #786

Hi Andreas,

I’m sorry, but there seems to be some specific issues under your ST account.

If you want me to intervene in your ST account, please contribute to one of my support packages at my store and I will look into it.

Regards

EDIT: Be sure to use My Ecobee device with the smartapp as my DTH is the only one compatible with the smartapp. Also, please refer to the ST community wiki for prerequisites & configuration.

http://thingsthataresmart.wiki/index.php?title=EcobeeSetZoneWithSchedule#Prerequisites
http://thingsthataresmart.wiki/index.php?title=EcobeeSetZoneWithSchedule#Configuration


(Jared) #787

Curious question: People have to pay for your device in order to use it…
Commonly, when people buy software, support is part of that. It’s usually either open source (free) software and you pay for support, or pay for software with support included.

But it looks like you want them to pay you even more just to get support on it? Isn’t that double-dipping? Double charging?

Forgive me for asking this, but it just feels wrong to me.


(Yves Racine) #788

Hi, fyi, I’ve documented everything at the ST community wiki. There are some troubleshooting
and configuration sections for all my smartapps and devices.

If there is a specific issue that I cannot reproduce and no logs are provided, then I need to look into it under the user account.

This takes time, and for a specific intervention under a ST account and for any major upgrades, my support packages are needed.

Regards.


(Yves Racine) #789

Hi,

Just want to inform my contributors that a new version (v5.9.9t) can be downloaded at my e-commerce solution provider (sellfy) using the original download link or your sellfy account provided that you’ve followed the update procedure indicated at my store (under the terms of service).

If you’re are a contributor to one of my support packages (and I have access to your ST account), the upgrade has already been done for you. You don’t need to do anything, everything has been taken care of.

In order to achieve even more reliability, I changed the ‘replay’ logic used in case of ecobee or ST outage to queue up to 10 entries for each setter command (setHold, setThermostatSettings, resumeProgram, createVacation, deleteVacation, setClimate), so that the commands will be ‘replayed’ over the next hour following a temporary outage.

This new queue logic, combined the actual resilience of My Ecobee device (to avoid any ecobee disconnects), will ensure even more robustness for my contributors and their HA scenarios.

Regards.


(Andres Castano) #790

Hi Yves,

I found what is causing the issue, if I set the holdType parameter to
’nextTransition in MyEcobee device I won’t be able to open the Smart
Appeven I delete the parameter. The only option to get access to the
SmartApp is by deleting the device from IDE.

Looking forward for your comments or solution

Regards,

Andres


(Yves Racine) #791

Hi, which version are you using?

I’m running ecobeeSetZoneWithSchedule and My ecobee device with the holdType set to nextTransition and I don’t have any issues.

If you have any logs, send them to me at services@maisonsecomatiq.com
Regards


(Andres Castano) #792

Hi,

My apologies for my late response, I was out of town.
My ecobee device, version 5.9.9s
EcobeeSetZoneWithSchedule, version 8.1.3

I will upgrade My ecobee device to the latest version and I will let you know.

Thanks


(Yves Racine) #793

Hi,
You should not have any issues with those versions. I suspect that you are using a device (sensor or vent) that is not responsive (too much latency or not online)…

Please make sure to install the right DTH for the vents (if any) as indicated in my prerequisites for ecobeeSetZoneWithSchedule.

Check your sensors and make sure that they work properly. My code is working at many user locations, so I don’t expect any issues with my code.

And, there is nothing I can do on my side without logs.
Regards.


(Andres Castano) #794

To avoid this particular issue I had enabled “Only use Program/Comfort Setpoint baselines for temp/vent adjustments?” option from the SmartApp. It’s working fine after and I got the same result.

Thanks Ives,


(George) #795

Hope I’m asking this question in the right place. I’ve purchased this software and have most of what I want working. One thing left: I have ST door sensors, how can I set ecobee to away mode when a door has been left open 5 minutes, then resume when it is closed? Thank you, George


(Yves Racine) #796

Hi George,

I don’t have any specific smartapp for your use case at my github, but you can use a smart rule engine (Core/webCore, SmartRules) for this specific requirement.

For the list of smartapps and related use cases available refer to the 1st post of this thread.

P.S. I have the WindowAndDoorOpen smartapp which actually turns off the thermostat when the contact is open and turn it back on when the contact is closed. It’s slightly different from your original use case.
Regards.


(George) #797

Thx, so any chance you could modify your app to add the option for a 5 min timeout? I don’t want the AC to turn off anytime we go out the door.


(John) #798

Try WebCore.


(Yves Racine) #799

Hi,

There is already a timeout built-in that you can use, see the following parameter:

section(“And, when contact is left open for more than this delay in minutes [default=5 min.]”) {
input “maxOpenTime”, “number”, title: “Minutes?”, required:false
}

You can even specify a notification frequency after the above threshold has been reached:

	input "frequency", "number", title: "Delay between notifications in minutes", description: "", required: false

P.S. I won’t modify the smartapp as there are many contributors who use it already. Any change will impact them.

Regards.