[RELEASE] Resilient - My Ecobee Device & ecosystem v5 - The smartest thermostat under ST with new "comfort tips" features and Unique Integration with Echo/Ask Alexa

askalexa
ecobee
thermostat
climatecontrol
dth_hvac

(Yves Racine) #758

Hi,

I sent an email to all my active contributors today about the new update procedure effective immediately.

After some investigation with my e-commerce solution provider, I’ve found the following solution:

  • Instead of “pushing” updates by emails, you’ll now be able to download the new versions when you feel it’s most appropriate for you.

  • Currently, with the original “Sellfy” download link, you can download up to 5 times (or 5 versions spread over time) of the product(s) you’ve contributed to.

  • With the new update procedure I sent to all my active contributors, they will be able to download unlimited “minor updates” when they feel it’s the most appropriate for them.

Please take note that I will no longer “push” updates by emails.

Regards.


#759

I think this case is slightly different. The name of the Namespace / name of the app under My SmartApps is yracine : MyEcobeeInit for both instances. When I go to the thermostats in the My Devices section it only shows one entry under MyEcobeeInit so I can’t tell which one. What’s also odd is I have two thermostats (Upstairs and Downstairs) but only only one of them (Upstairs) shows MyEcobeeInit on the In Use By section even though they are both using the DTH. It seems things are still working fine as is so I should just leave it alone but the duplicate entry rouses my ocd.

It feels to me like SmartThings shouldn’t allow a second entry in SmartApps with the same name so maybe I just need to contact support.


(Yves Racine) #760

If you want to remove one, you can rename the entry you want to keep and press remove on the one you want to delete.
Regards


#761

This just keeps getting stranger. I renamed one of them in the IDE (in definition I updated to name: “removethis”). In the ST app under SmartApps it still only shows one entry which is the original name but carrying the old version number so I know it’s the right one. If I go into add a new app in the ST app I can see the one I renamed, but I haven’t added that yet. If I remove the MyEcobeeInit will that remove the thermostat devices also? If not I was thinking I could just remove both then add one back, but if it removes the devices, I don’t want to go that route as I have a lot of automation tied to them. For now I have just updated both versions in the IDE to be the up to date code.


(Yves Racine) #762

Ad indicates at the ST community wiki, if you remove the parent app (MyEcobeeInit), this will remove the child devices only if the devices are not used elsewhere in other smartapps of routines.


(Sean Naber) #763

Very impressed with this so far. Purchased and installed over the weekend.

Could use some help with one thing though: when im ready to go to sleep, I want the thermostat to stop following me and resume my normal sleep schedule that i have setup within the official ecobee app. Is that possible?


(Yves Racine) #764

Hi, please refer to the 1st post of this thread for all use cases supported.

Based on your requirements, I believe ecobeeResumeProg should be the smartapp to be used.

There is also a lot of configuration tips under the ST community wiki:

http://thingsthataresmart.wiki/index.php?title=My_Ecobee_Device#Configuration

Regards,


#765

Ok, finally figured out what I think I did wrong. I think I opened the sensor init code and updated it by accident. Was going to leave well enough alone but realized my sensors hadn’t been registering since I made the update. In the IDE I updated the using the sensor init code you recently sent and seems like it has started working again. I tried to run the sensor init app again and got an error but think that was because the devices were already there. Either way it started registering in the recent events so will see how it goes. Thanks.


(Sean Naber) #766

Is there anywhere I can see which sensors are currently being used to calculate the average temperature? Some of my sensors, such as the remote sensor that came with my ecobee4, shows no activity within smartthings since I installed the My Ecobee Device smartapp. Thanks!


(Yves Racine) #767

Are you using the MonitorAndSetEcobeeTemp smartapp at my github to connect any ST connected sensors?

I don’t understand your question. If you’re using the above smartapp, then I’d recommend to use
ecobeeSetZoneWithSchedule instead as you can decide which remote sensors will participate in the avg temp calculations through the concept of zones. The paid smartapp at my store will also show a dashboard and the running Schedule config with the all details related to the current zoned rooms.

If you need me to check your configuration settings, please contribute to one of my support packages at my store and I will look into your ST account configuration.

EDIT: if you’ve installed the EcobeeConnect before, I recommend that you uninstall it as it can be confusing to have both devices. Also, Please follow all installation steps for My ecobee Device and EcobeeRemoteSensorInit.
Regards,


(Sean Naber) #768

Yves, I may go ahead and try ecobeeSetZoneWithSchedule. But, before I do that, my issue is that the lil-bee remote temperature sensor that came with my ecobee has stopped reporting to smartthings. The last report was for Sunday morning, which is when I installed My Ecobee Device. I’m just trying to confirm if the lil’bee is reporting to your smartapp or if it’s completely stopped working. Is there a way to check? The reason it’s so important is because the lil’bee is in my bedroom and I need it to report to your smartapp so that we can sleep comfortably.

Thanks much for your attention so far! I really appreciate how quickly you respond.


(Yves Racine) #769

Hi, you said that your ecobee remote sensor stopped reporting to ST when you installed My ecobee Device, is this remote sensor tied to EcobeeConnect? If so, you should remove it and replace it with the use of EcobeeRemoteSensorInit.

The list of events should tell you if your remote sensor is working.

I’m sorry, but without access to your ST account or logs, I cannot help you effectively. If you have installation or configuration issues, please either consult the configuration & troubleshooting sections at the ST community wiki or contribute to one of my support packages at my store and I will look into them under your ST account.

http://thingsthataresmart.wiki/index.php?title=My_Ecobee_Device

http://thingsthataresmart.wiki/index.php?title=Ecobee3RemoteSensorInit

EDIT: I know now what’s going on, you contributed to the standalone DTH only, not for the ecobee remote sensor app. You’d need to contribute to ecobeeRemoteSensorInit at my store to get your lil’bee reporting again to ST.
Regards


(Sean Naber) #770

Ah, ok. That makes sense. Thanks!


(Yves Racine) #772

There are ways to do this. Just contact me at services@maisonsecomatiq.com and I will let you know the different options.

Regards


#774

So as of yesterday at some point, I noticed the MyEcobeeInit stopped functioning. I am no longer able to use the device handler because of this. I go into the smart app and try to make sure I am logged in but a bunch of errors get thrown and it cannot find my Ecobee TStat at all.

It says “You are connected”, but then when I click on that to try and log in again I get:

{
“error”: “invalid_request”,
“error_description”: “The request is malformed. Check parameters.”,
“error_uri”: “https://tools.ietf.org/html/rfc6749#section-5.2
}

When I try to select my Thermostat I get “You Can’t currently add this”

I tried reinstalling the App and I got to the Ecobee login screen but I got errors as soon as I logged back in

I use this for at least 3 pistons and it is annoying to not work. Any ideas?


(Yves Racine) #775

Hi @Bigsam411,

I don’t know which versions you’re running, but I haven’t seen any issues with My Ecobee device for quite a while at the multiple user locations that I supervise as part of my support packages.

So, it must be a problem specific to your ST account and/or your shard… Try reinstall the code, and re-login at ecobee.

That’s my best suggestion without seing any of your logs.

P.S. Please don’t post any log errors here in the ST community forum as there could be sensitive info about your thermostat.

Regards.


#776

I am having all sorts of problems too, but I don’t think it has to do with ST or the handler. I started receiving a very long error that begins with MyEcobeeInit>too many exceptions and then references Connect TimeoutException. I then tried to control the thermostat with ST and Alexa and neither would respond. I then tried direct in the Ecobee app and the Ecobee site and the app just hangs when I try to go to one the detail page. Web site won’t even go to the login page.


(Yves Racine) #777

Yes, for some user locations, I see the the ecobee connections are down (ecobee server issues or other ST backend issues), my code should be able to recover if the ecobee outage is not too long (less than 1 hour).

doRequest>exception org.apache.http.conn.ConnectTimeoutException: Connect to api.ecobee.com:443 [api.ecobee.com/216.220.61.235] failed: connect timed out

EDIT: I just tried to log at the ecobee website, and there is definitively an outage:

The ecobee website is temporarily unavailable and our technical support team is correcting the problem.
We expect to have the situation resolved in the near future and we apologize for any inconvenience that this may have caused.

If you need to contact us please email info@ecobee.com or phone 1-877-9-ecobee

Thank you,

The ecobee team.

Regards.


#778

Yea it seems like their servers are down. I am unable to connect from the thermostat now too. Seems like I jumped the gun on blaming your app. I will see what is going on and if the Thermostat connects to their servers I will double check your app. Until then I guess I can manually control it.


(Yves Racine) #779

In your case, I would make sure to update the code with the latest version, and re-login at ecobee.

Regards.