SmartThings Community

[RELEASE] Remotec ZXT-120 AC IR Controller (2015)

thermostat
dth_hvac

(Ron) #21

BTW: Code has been moved to the following location because of the IDE github integration.

Device

Apps



(Chun Liew [SmartHomeDB Evangelist]) #22

@Ron: Thank you, the above did the trick!
Changed the 67…84 to 19…28 for both heat mode as cool mode.

I have not yet plugged in your temperature scale script, but will let you know if that works properly when I test it.


(Ron) #23

Not sure what you mean by plugging in my script. The temperature scale code was from my device code. I think it should work fine. The only issue should be the slider can’t be limited in range dynamically so that part of the code needs to be hacked. The rest should be temperature scale setting safe code. I just pointed you to the section since I have not tested the Celsius logic so look there if you have any issues.


(Oliver) #24

Hi -

sorry this may be a naive question, but is there a way to just use it in the way the manual suggests to send codes to the AC? The configure tile doesn’t seem to do anything.

If that’s not the way, any way for a non-programmer to upload any of these scripts?

Thanks!


(Ron) #25

Once you have the device installed you need to set the preferences for the device, including the code from the manual for your AC unit. Then clicking on configure sends these settings to the zxt-120.


#26

I would add that the code list often has several codes for each manufacturer. So start with the first code, click Configure and wait for it to upload to the IR sender (IIRC, the IR Sender blinks at this point). Then try turning your aircon on/off. If it doesn’t work, go back and try the next code, press configure, wait for IR to respond, and try turning on/off again.
If you’re lucky you will hit paydirt trying the first few codes. Once you have one that turns your aircon on/off, try the other functions.


#27

Out of interest, anyone got these working on V2 hub? Mine just arrived…


(Ron) #28

In my version of the device code I display the “configured” code which is returned from the device. So you know your configure worked when this code is displayed.

I have 5 of these and had no issues moving them to my V2 hub.


#29

Hi Ron,
Previously I had 2 ZXT-120s on my V1 hub.

Now I am trying to install three new ones on a V2 hub. I am using 1.6h src.
I am finding the device and able to set preferences.

However the configure button doesn’t do any thing for me on Android, and it gives me an “Unexpected Error Occurred” on Windows Phone. I can refresh and see the temp, and Config of #72 which I assume is the shipped default. (Mine is 229!)

Any ideas on why the config isn’t working for me this time around?
TIA.


(Ron) #30

@Twisticles Do you see a “Learn” button tile with a toilet paper roll icon (the icon was temporary to reflect the current state of this new feature :slight_smile: )? This is a feature I was working on but having issues because the ide is busted for debugging. This version is bad so make sure you are using this version. I was working on a new “Learning” mode feature but the ide infrastructure is hosed preventing me from getting it done. I had introduced a bug while trying to do that breaking the config option.
I have reverted these changes until the ide is fixed and I can debug correctly.

So download the lastest version from here…

Also make sure you set the flirs mode to “Always listening” or config doesn’t work correctly. You can only change the flirs mode when the device is not paired so you may have to remove and re-add.

If these two suggestions don’t work then I think the issue is that ST is dropping events lately.

Let me know how things turn out.


#31

Yup, I had the toilet roll!

Just added again with the code you posted just now and all is good and working again! Brilliant work Ron, and much appreciated :smile:

Thanks very, very much, this was the last part of my system to get running.


(Ron) #32

No problem. I have learning mode mostly working now. They finally fixed logging so I can debug again…


#33

@Ron

Hi there, thank you for your work on this controller. I have used your code and it’s showing on my app but I’m wondering if you have been successful in being able to learn IR codes? If so, please advise on how I can do that. I’m a newbie just finally learning my way through ide.

Thank you!


(Ron) #34

@MacTigger I actually do have a version with learning mode. It is a work in progress but here is the Beta code for the new version.

Instructions for use.

  1. Set Remote Code to 0. ZXT-120 instructions say 000 but this is passed to the device as a number so I don’t know how you can pass 000 as a number :smile: You can enter 000 in the remote code field but it will change back to 0 and it should work fine.
  2. At the bottom of the device tiles you will see three new tiles A) displays the learning number B) Slider to set the learning number C) The learn action tile

Seen here

Slide the slider to select your learning position based on the positions in the manual. I found this version online and it really documents the learning codes well.
https://github.com/gouldner/SmartThingsPublic/blob/master/devicetypes/gouldner/docs/zxt-120/rm-zxt-Zipato-Ir-Extender-User-Manual-v1.0.pdf

  1. With the learning position set. Tap the learn tile.
    The zxt-120 should flash once. Press the remote button you want to learn with the remote close to the zxt-120 (see instructions)
    The zxt-120 should flash once for success or 6 times for fail.

I have used this learning mode to learn how to control my Dyson Heater and it worked on my first attempt.

Let me know if you have any suggestions to improve the interface. I want to label the learning code tile instead of just a number but since this was Beta didn’t bother yet.


#35

Thank you for that, I did get it to learn my codes but in working with your code I inadvertently figured out that my AC unit does in fact work with a pre programmed code so I’m going back to your previous work (as learning is no longer needed for my application).

Great work BTW, I’m glad that we have more advanced programmers in the community to help out people like me! :smile:


(Jake) #36

Ron - thank you SO much for your work on this. Is your Github link above still the latest version of your device type? I just ordered my zxt-120 and I’m excited to get started!

J.


(Ron) #37

@PassionateLogic This is my latest copy.


(Guilherme Gornati) #38

Hello Ron,

I’ve tried to follow all the steps here I can’t get to work. My version is v.1.7b

Thanks!


(John) #39

Hi there, this seems to be an old thread but was wondering if anyone got there ZXT-120 working? I used the last code from Ron, thanks for all the hard work! I can turn on and of the AC or heat, but that’s about it! No temp settings or other controls. Anyway I just thought I would check, I can’t be the only one that wished this worked! :slight_smile:

Thanks!
John


(Ron) #40

Still working fine for me. I would say it all depends on what type of unit you are trying to control and if you selected the correct code for that unit. Since you don’t say it’s difficult to provide any suggestions. I am using them on Mitsubishi split systems. You could also try using the learning feature to configure your unit if you can’t find a code. It’s pretty tedious but I am using the learning to control a Dyson heater. I only coded one temp since the heater only has heat + and heat - along with on/off. So i just coded 84 = heat on. But it works so I know you can learn codes.