[RELEASE] Remotec ZXT-120 AC IR Controller (2015)

I haven’t looked into it extensively, since I have no interest in using the new app.

But there is a thread that discusses use of custom device handlers in the new app. It might be possible for some handlers, with modifications.

Does anybody could make this work with alexa? so far I had success to turn it on and off, but I am not sure if I am using the right instruction to change the temperature, it looks like in the alexa app it change the temperature but it doesn’t send any signal to the AC, does any have any recommendation for this?

Thanks

Does the temp change in the SmartThings app?
If yes then the device is working as I designed and you can modify to send the signal with the following instructions.

Since this is a thermostat it should work with Alexa however when I implemented the temp setting I didn’t choose to send the temp signal. This is because the older version of the SmartThings slider used to send every change as you moved the slider. This would cause the device to send 5 or more signals as you moved temp from 65 to 70 for example. So I changed the code to only send the temp when you set the mode to “cool” for cool temp and warm temp when you send the “heat” mode.

You can add the temp send back in here for cooling temp.

and here for heat temp

I have not tested the commented out code in a long time since it was in the original DH I modified and I commented it out immediately so you may need to tweak the code a bit if it doesn’t work.

I got my zxt-120 and it is set up and working with my Fujitsu heat pump. In the ST app I can adjust the heat set point with the slider and then hit the Heat mode and it will change and beep just like it does with the remote control when I change the set point. In ST it does enable swing mode but I just hit the off button and that turns off.

My question is in Webcore. I use webcore the change the set point based on either outside temperature or an inside temperature monitor I have down the hall. The script runs correctly and changes the heat set point but it does not transmit to the heat pump. I then have webcore send a “device Set to Heat” command and the logs say the physical command doesn’t get send because it will make no change to the device. Then I have a swing off command that does get sent to the device and I believe it sets the temperature too.

I’m wondering if I should change to “device Set to Heat” to “device Set to Thermostat Mode” and then “Heat” instead? Would this send the code? Or it may mess things up with the other settings I have.

I figured I would ask before I changed it in case someone else has. If not I will let you know.

@cbsmith Technically I don’t support this device anymore because I no longer use SmartThings having switched to HA. However, I will try to help with the following information.

The ZXT-120 should be treated like a stateless device. If the unit is changed using the remote or any other technique the ZXT-120 has no means to know the correct state of the devices. So what I do to get around this issue in ST is I created a Virtual Stateless button DH


as well as a Smart App which maps the SmartThings states to buttons.

This creates a series of stateless buttons. Heat, Cool, Dry (if all are configured in the app).

You can now use these buttons to turn ON or OFF the Heat or the Cool or the Dry without worrying about current state.

I don’t use Webcore so I don’t know if this strategy will work with webcore. Perhaps you can avoid using the DH and APP in webcore but somehow telling webcore that the device is stateless. You would have to contact the webcore developer for that info.

Finally, I chose to code my ZXT-120 DH to NOT send the signal when temp is changed. This was based on the fact that ST sends every temp as you move the slider instead of waiting for you to confirm. This may be no longer true but it was when I write the DH. So I elected to save the temp when you change it but not send the signal. You could modify the DH to send the signal on temp change. This would make it much easier to use with webcore because you would only have to set the temp and you know the unit would get turned on.
To accomplish this you can uncomment out the following two sections.

Hope that helps.

1 Like

Thanks for taking the time to reply even though you don’t support the code any more. I have been playing with webcore and I think the heat set point gets sent automatically via webcore to the zxt-120. I understand how the Fujitsu remote will get out of sync with the actual unit but I think it is working as designed based on thermometers hip have around the house.

No problem. I don’t see how webcore would send data to the zxt-120 without going through the Device Handler. That shouldn’t be the case. Webcore should talk to ST which would talk to the device using the DH. Therefore the DH which just saves the setting and doesn’t transmit the request to the zxt-120 would prevent a temp change from sending the IR signal. If you make the changes I suggested then then the temp change would get sent to the ZXT-120 and it would behave as the remote should and send the signal. Again this was a design decision I made based on my testing so I commented the code out in case ST improved the way the slider worked at some point. Since it seems you are using webcore and not the UI the change would probably work well for you. If not perhaps someone else on the community that uses this device with webcore could better help you.

webcore by default has “optimizations” that if the device is in the state, it won’t send the same state to the device.

This can be disabled in the webcore piston, so it sends the commands regardless of device state.

1 Like

@Ron Yesterday I was able to pair my REMOTEC ZXT-120US with smartthings using your device handler (thanks so much for that), but still I haven’t been able to control my AC, I’m not sure if the codes that shows the manual are not working or if did something wrong.

Device handler is capable of polling actual temperature, but is not able to turn on or off any of the capabilities of my unit, even when the brand (comfortstar) is showed in the manual.

I was trying to use the “Learn” mode from your app but I’m not pretty sure how it works. I will really appreciate any information you can provide me where describe the steps to configure the functions using the Learn option.

Thanks in advance for any help you can provide.

J.Ch

I don’t use SmartThings anymore, moved over to Home Assistant. So I don’t support this device type anymore. Sounds like you have it installed correctly and it is working fine if temp is reading. You just need to find the correct code for the AC which I can’t really help with. It’s trial and error. Just make sure you are correctly sending the code. The new code should update in the UI as documented in the readme. The instruction on how to use learn mode are there and you can read the manual of the device to understand it more. If still having problems reach out to other users with more details such as what you are doing and what results you are getting. Hard to help you if you don’t. Good luck.

Screen shots are outdated but still present the basic idea.

Thanks for your help, I’ve got the device learnt the on (resume) code at least, nothing else can’t be learnt, I don’t know why, maybe because the AC remote won’t go to off state, as display it’s always on.

Just one last favor, could you please post the link of the last version of the apps you developed to automatically control the AC unit?

Thanks again for answering this thread considering you are not supporting this device any more.

Have a great day.

Same repo as I already posted.

Added fan only mode but power off doesn’t work when in fan only mode. Power off works if mode is switched to any other mode before powering off. I can’t figure out how to get power off working again. Any help appreciated. Thank you.

This is the log. Anyone?

8:35:56 PM: debug Parsed zw device: 0B, command: 4003, payload: 00 to command ThermostatModeReport(reserved01: 0, mode: 0) to result [‘value’:‘off’, ‘name’:‘thermostatMode’, ‘isStateChange’:true, ‘displayed’:true, ‘linkText’:‘A/C Controller’, ‘descriptionText’:A/C Controller thermostat mode is off] map=[value:off, name:thermostatMode, isStateChange:true, displayed:true, linkText:A/C Controller, descriptionText:A/C Controller thermostat mode is off]

8:35:56 PM: debug Thermostat Mode reported : off

8:35:56 PM: debug Parsed ThermostatModeReport(reserved01: 0, mode: 0) to null

8:35:56 PM: info Parsing Description=zw device: 0B, command: 4003, payload: 00

8:35:52 PM: debug Dry Mode or Fan Mode or Off no need to send temp

8:35:52 PM: debug setThermostatMode value:off

8:35:52 PM: debug Dry Mode or Fan Mode or Off no need to send temp

8:35:52 PM: debug setThermostatMode value:off

8:35:47 PM: debug Parsed zw device: 0B, command: 4003, payload: 06 to command ThermostatModeReport(reserved01: 0, mode: 6) to result [‘value’:‘fan’, ‘name’:‘thermostatMode’, ‘isStateChange’:true, ‘displayed’:true, ‘linkText’:‘A/C Controller’, ‘descriptionText’:A/C Controller thermostat mode is fan] map=[value:fan, name:thermostatMode, isStateChange:true, displayed:true, linkText:A/C Controller, descriptionText:A/C Controller thermostat mode is fan]

8:35:47 PM: debug Thermostat Mode reported : fan

8:35:47 PM: debug Parsed ThermostatModeReport(reserved01: 0, mode: 6) to null

8:35:47 PM: info Parsing Description=zw device: 0B, command: 4003, payload: 06

8:35:40 PM: debug Dry Mode or Fan Mode or Off no need to send temp

8:35:40 PM: debug setThermostatMode value:fan

8:35:40 PM: debug Dry Mode or Fan Mode or Off no need to send temp

8:35:40 PM: debug setThermostatMode value:fan

Is there any chance you’d be working on a Handler for the ZXT-600? I can’t find one anywhere. Thanks for your help!

Not sure if this DH no longer supported on Smartthings or I set something wrong. I cannot change the temperate sliders. I move the temp sliders but the set temperature always remains the same on the app. I can however turn it on, set to cool, turn it off etc. Seems it could be a problem with the slider type no longer supported.

If anyone else’s temperature sliders work please let me know.

My sliders work (partially). They basically turn the mini-split on or off, depending which way I slide. I have two ZXT-120s, using a ZXT-600 DH. Hub2, new app.

I no longer have SmartThings but if you are using my DH code it doesn’t send the temp when you change the slider, it sends it when you turn the unit on. The ZXT-120 should respond with the current set temp so it should change to your new selection after you turn the unit on using Cool or Heat. That’s why I have the two values displayed, current setting for the next time you send and reported temp which is the last temp reported by the zxt-120.

It’s possible the DH no longer works or has issues since I can’t really maintain it anymore. You would need to get feedback from other users using my DH to be sure. If the unit gets a signal when you slide it’s not my DH. I didn’t like that every temp change turns the unit on. I so as you slide it was sending each change in temp and the unit kept beeping and changing. I wanted the slider to not send so you can set the correct temp and then send with the cool button. That’s how it should be working.

Everything work fine for me but last week some icons disappeared

Propably Samsung make his magic again

Hi all,

I’m just new, so I have only seen the new application, and there doesn’t seem to be a way of rolling back to the older format, but many of the buttons seem to be missing.

Am I the only one who has noticed this?

I only bring this us, as the ‘Configure’ button is missing, so I can’t configure my ZXT-120 for my A/C.

Pax