[RELEASE] Remotec ZXT-120 AC IR Controller (2015)

I have not used this one, check out

There is also thermostat mode director.

Thank you for the quick response! I’ll take a look at these!

Dan

Incorrect remote. Now that you have a correct procedure for configuration, go back and try other codes.

Not sure why you are replying to my post from over 1 year ago and I have no clue what you are suggesting. What was the point of this post?
What makes you think I am using the wrong remote code?

Sorry to have troubled you Ron. I was posting to another member and did not realize I had replied directly to you.

I do have a question for you, though. Have you found a way to get the temperature to update on the ZXT-120? It is very slow on my device and Poll and Refresh don’t make it update.

Also, I would like an app that turns it to Dry at one RH (using external sensor) and Off at another and only runs in Away mode. Have you seen such an app?

Third, can you suggest a way, or add, a button that turns the AC on and Off only, but keeps the last setting? The interface has a rotate through the modes operation, and not a switch.

Thanks for your work and attention.

Cheers,
Mike

No, the zxt-120 requires that you poll for temp and SmartThings Polling has always been broken. Not sure why they can’t fix it but they have tried and it has never worked correctly. So I use a Fibaro Motion Sensor for Temp reading because it posts updates as temps change.

What is an RH?

You must not be using my Device handler. Mine doesn’t cycle through the settings.

Do you have any clue why this doesn’t work with ActionTiles?

I saw on their support forum that device should be visible if it has some capabilities like Sensor, Actuator…

https://support.actiontiles.com/knowledge-bases/8/articles/363-some-devices-are-missing-from-the-authorize-things-add-location-screen

But I can’t see it in ActionTiles SmartApp where I add permissions to devices so I can’t add it to panel and I can’t even see it in ActionTiles UI.

Hi all,

I have had the zxt-120 working good for quite some time. Suddenly it completely disappeared from smartthings and all routines. As if it never existed. That was strange. I now reset the zxt120 fo factory settings and was trying to add it again to smartthings but was never able to. Smartthings never detects it … Any help or hints ? Has anything like that happened before ?

Best,
Fab

@Fab Try excluding it first. But first make sure you configure always listening mode. (explained in manual)

  1. put device in always listening mode
  2. make sure device is plugged in to usb (don’t use batteries since it doesn’t work with always listening mode)
  3. exclude the device first (put hub in exclusion mode and then wake the include/exclude mode on the zxt-120)
  4. try including, it should work now.

thx Ron!! It worked following the process !
Just 1 note: status is not updating. ie I turn the AC on, it turns on but it always gives me Off in the smartapp status. Other ZXT120’s that I have work perfectly using same device handler and they show status correctly.

on a related note Any idea why would the device just disappeared from smartthings ? Have anything like that happened before ?

Best,
Fab

Did you switch the DH to the correct version after including? It might have found another matching device handler and attached to that. If you are changing the status of the AC using the AC remote or the device itself it does NOT report back to the zxt-120. For status to be correct you must change the AC using ONLY the zxt-120 control. Because of this I don’t pay attention to the current state. I simply select the discreet state I want it to be in or I let automation handle it. If I turn the AC on using the AC remote I know it will not be correctly reflected in ST and that has never really bothered me. If you are trying to use state to take other actions this might be tricky. If the AC is a plug in unit I might put it in a smart switch so I can monitor power flow to determine current state, I do that with a heater I use the ZXT-120 for. If it is a split system determining state might be more tricky. You could but a tilt sensor on the vent and see if that lets you know if the vents are open (running) or closed (off). But I never tried that.

No I have never had that happen. If you didn’t have it in always listenting mode perhaps that was an issue but it shouldn’t disappear it should just not be responsive.

Thx Ron !
helpful as always. All working good now

Fab

Hi all,

I have had the zxt-120 working very good with one unit. But I would like to control another AC unit located om another room, using the extender IR Port from the zxt-120.

Any one knows if it is possible?

Best,
Marcelo

Only if they are the same unit and you want them to do the same thing all the time. Whatever signal you issue will go to all IR senders that are active. If they are different units it is not possible since only one programmed code is allow at a time.

I have 5 split AC units and a heater driven by zxt-120’s so I had to purchase 6 of them.

Tks Ron!

They are not the same model but are from the the same manufacture(the same ir controller).
For the moment I will try to use the external IR but I will do the same you did(one zxt for each unit).

I could see them getting out of sync but if the commands are discreet you could just send multiple commands to assure they both catch the commands. Then again it may work well.

I may be selling my zxt-120’s because I am working on switching to a raspberry pi zero build I am working on. So before you buy more ping me. I still have to test my build but I have one working on a simple heater, now I need to see if it will work on more complex split system.

Hi,
I am real noob, I have a Sharp model TU, I did install everything, the codes 524, 318, 426 and 90 seem to work with the AC unit. I can turn it ON, OFF, COOL, HEAT, and dry. I would like to know how to set the temperature, to set the temperature slider into celsius (btw, when I move the slider, it does nothing), to turn on/off the Plasmacluster fonction on the unit.
Thank you.

If you are using my device handler then, you set the temp and then you select “Cool” or “Heat” and the temp is sent.

I you are using iOS classic app then the sliders are junk. You have to move them one degree at a time and wait a little then close the window with X, if you move the slider quickly it tends to only change the value by 1 or 2 not set your selected value. One of many bugs in the UI. Not sure about android and I have never tried the new app.

The temp you changed to should be reflected in the tile you selected when you return from the slider window. The tile to the right will NOT reflect the change. When you send the temp the tile to the right will change when the zxt-120 confirms it sent the temp.

So for example in the diagram below you can see that cool temp is set to 76 but the tile to the right says “75 cool” that is because I didn’t send the new temp 76 yet.
After sending it will change to read “76 cool”

Thanx a lot Ron for the quick reply.
I use your device handler (Android).
However, when I set the Temp with the slider, I press the "x"on the upper left, I come back to diagram you show, but the Temp on the right of the Cool button hasn’t change, it stays on 28, and right next to it, it still display 83.0 cool. Nothing happens. Maybe I don’t have your latest code?
How can I set everything in Celsius?
Thanx

Hi Ron,
I have figured it out how to change the slider temp to celsius (by changing the code lines 333 and 336), the 2 tiles next left the HEAT tile still display in Fahrenheit: “67.0 cool” and “77.0 heat”, do I have to change other line codes?
Another thing, do you think I can have the DTH to learn the fonction PlasmaCluster on the SHARP device? (That’s a unique fonction from SHARP I think)