[RELEASE] Remotec ZRC-90 Scene Master - Button Device Supporting 24 Unique Button Commands (see post 177 for 2021 app version)

Well after some reading ,which I somehow completely missed the first time, I saw how to install the Smart app “Button Controller - Enhanced Lighting”, so that helped a lot to get the ZRC to do things, although the ‘Config’ button in the ZRC page still does nothing when pressed.


Got one of these a few days ago. Works great the the advanced button control smartapp. However. What does the number in the middle bottom mean. I see it changes but can’t figure it out? Also got new batteries in and only says 25%. Will this update?

That is just the z-wave sequence number for the scene report.

The battery value should update eventually.

Also the battery percentage is not calibrated, hence depending on the type of battery you have it may or may not show a useful percentage. For mine it shows 1% but has been working fine for 8 months with that magic 1%!!!

I get this error (and double checked several times to make sure I copy/pasted the whole code). Any ideas?

No signature of method: script_app_metadata_b92ee5f8_8036_4931_ba8f_3ebf74ccdd24.metadata() is applicable for argument types: (script_app_metadata_b92ee5f8_8036_4931_ba8f_3ebf74ccdd24$_run_closure1) values: [script_app_metadata_b92ee5f8_8036_4931_ba8f_3ebf74ccdd24$_run_closure1@392d68b] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

That usually happens because you copied a device type handler but you pasted it in as a smartapp.

1 Like

D’oh - Yes, that’s what it was. Sorry, clearly a new one here. Working now!

1 Like

For me the ZRC-90 is not registering button presses occasionally. It misses hold events very often. Do you have any any idea what might be causing such behaviour?

Installed both the DH and this SmartApp. While setting up, the setup screen for button 5 is not showing up anything, only [remove] and [next] available. Button 6 onwards is fine again. What could be the issue?

@maxtay Which SmartApp?

1 Like

The ZRC-90 Scene Master. I found the root cause. When copying the code, the line for button 5 has been pasted as “卌” rather than ( 5 ). I think it is an add-on on my browser trying to be smart. Thanks.


I tried adding raw code and go this error:

No signature of method: script_app_metadata_da7ddc48_6d3e_4ca7_9a2c_e1bc7cb5e0f4.metadata() is applicable for argument types: (script_app_metadata_da7ddc48_6d3e_4ca7_9a2c_e1bc7cb5e0f4$_run_closure1) values: [script_app_metadata_da7ddc48_6d3e_4ca7_9a2c_e1bc7cb5e0f4$_run_closure1@73e03d86] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Any help is appreciated. I also added the ZRC and have it as a device in my smartthings app but I cant seem to find it to check off on any smartapp. Will this change once I put in the code?

Normally that error occurs when you take code which is a device type handler but you paste it in as a smart app. These are two completely different types of code.

See the FAQ:

FAQ: An Overview of Using Custom Code in SmartThings (SmartThings Classic)

The good news is that yes, once you have the correct code correctly installed then you will be able to use the device in automations. That’s kind of the whole point of using the custom DTH. :sunglasses:

Thanks a bunch!

You wouldn’t happen to be able to guide me to the Remote ZRC smartapp code to copy into the smart app? I thought that was what you provided but I do not see it.

The code in this thread is a device type handler (DTH) which will make the device look like it has 24 different buttons. Those “button presses” will be reported to the smartthings hub.

You don’t need a special smart app. You will be able to detect those button presses with any standard automation, including the official smartlighting feature. So you just use those as a trigger. You should also be able to use it with webcore.

I know that worked great in the classic app. To be honest, I don’t know if this particular DTH works with the new V3 app or not. Hopefully someone else in the thread will know.

Thanks. That is really what I am looking for. the 24 button press and I have only been using the classic app on my android. I added the ZRC as a device so now I should be able to copy the code into the DTH section, correct? From there I can organize on my mobile classic app I suspect?

I’m not sure I understand your question, but if you read the community custom code FAQ, it lists the steps you need to go through to use a custom DTH:

FAQ: An Overview of Using Custom Code in SmartThings (SmartThings Classic)

1 Like

Ok…I was able to add the code and publish to myself on IDE. I found my device and went to edit and add the DTH but I am not sure where to do this. Changed “version” to self-published. Is this the area? The below is where I am stuck

“DT6) Edit the Device so that it uses that device type handler.”

I have installed the custom device handler for my recently purchased ZRC-90, clicked on Save, and clicked on Publish for me. I have then several times clicked Edit after telling the device to use the custom device handler, but every time I click Edit I get a blank screen. When I look at the Device list again I see that it is still showing the standard “Z-wave remote” device handler for the device, not the custom device handler. I have tried removing and reinstalling the ZRC-90. I have tried deleting and reinstalling the custom device handler. I have previously succeeded in configuring other devices to use custom device handlers, so it should not be user error.

Try logging into the IDE from a browser using private mode. Whenever I encounter IDE weirdness, this usually fixes it for me.

Lately I can’t even create a simulated switch in my account without being in private mode.

1 Like