[RELEASE] Qubino Flush 1D Relay, Flush 2 Relays, Flush 1 Relay, & Flush Dimmer

Looking at the response from Qubino in this https://github.com/OpenZWave/open-zwave/issues/976 I’m wondering if the firmware change from S4 to S5 means that the status reporting from i2/i3 requires a multichannel association to group 1 rather than the original associations to group 6 and 9. I have the flush-1-relay DTH working now by copying the association code from your flush-dimmer DTH and then handling the encapsulated multichannel messages.

I cannot get the flush 2 relay paired. Any ideas:

I did an exclude which seems to find something but I can’t include it.


Managed to get it working: Can't pair Qubino Flush Dimmer
in my example the device ID was 1E

I actually spent some time looking at the Flush 1 Relay and the Qubino manual and saw that their associations for the device were different than the 1D Relay. I updated the handler. If you have yours working with MultiChannel though, I wouldn’t switch over to mine since it uses regular associations.

In fact, my dimmer handler wasn’t supposed to be using MultiChannel either, but a “test” version got published accidentally. That was has been fixed as well.

Hey Eric, I have been trying to get your Flush 1D handlers to work, and I’m sure I just don’t know what I am doing. But I got the main handler you published to work fine… but every time I install the Child Device it totally craters my 1D. The phone interface just goes to a pic of a switch, and I2 still does nothing.

Hmm… I’m using the Qbino Flush 1 relay DH with the On/Off Thermostat.

I initially thought these were the same device under the hood but they’re not quite. I’ve got the On/Off thermostat working well enough for my purposes, but the switch doesnt quite work right. It never fully turns on or off, it just says “turning on” or “turning off”. Also it works backwards… “turning on” is off and “turning off” is on, but I can deal with that I suppose.

One thing I needed to do was set Param 11: to 32767 – input I1 doesn’t influence on the Heat/Cool process. This is the default for all other inputs.

Anyway, it seems like an On/Off Thermostat DH could be made from the Flush 1 Relay DH pretty easily.

Eric, a little more info on this …

As well as reset simply not working I believe the energy reported is way off. I have a Flush 2 Relay controlling a light fixture containing 3 LED globe bulbs and a bathroom extractor. it’s in a bathroom that is not used very often and after a few months the handler is reporting 302 and 297 kWh respectively. That’s simply not possible.

EDIT: I’m wondering if the watts are just accumulating in to the kWh without a calculation based on time? I’m not even sure if that makes sense. I’m going to dig around in the code.

I am having an issue getting a Flush 2 relay to include but only if the temp sensor is installed. ST finds it with no issue if the temp sensor is removed. I do have all of the child device handlers installed also. This is what I get in the hub event list.

Without the temp sensor:

With the temp sensor attached:

Any ideas on what may be the issue?

Do you mean when you hit on the gear icon and then hit “save” it crashes the SmartThings app. Any way you can post a video of what is happening or the logs when the error occurs?

@Nezmo Let me know if you find anything. The handler doesn’t do any calculation with the energy readings. It just gets the reports from the switch and creates an event.

@lelynch I don’t see anything in the handler that could cause any issues with the temp sensor installed. Try to remove the handler, install the relay with temperature sensor installed, and then install the handler.

1 Like

Well… I have the Flush 1D main device loaded, and it seems to function properly EXCEPT for the i2 input. i1 works fine, toggles the output the way it’s supposed to, and the temperature sensor works fine after I figured out the reporting interval.

But i2 just stays static, and if I tap the i2 portion of the screen on my iPhone, this appears:

NOW: If I go to the SmartThings Web interface, and install the child device to my Flush 1D in the simulator, everything craters and this appears. And it stays that way until I uninstall the child device, whereupon it goes back to normal.:


Scotty Davis

I bought these from www.thesmartesthouse.com and they were able to duplicate my issue in their lab. They are working with Qubino to see if a firmware update has caused this. I should hear something back from them early next week.

Well, I came up with a big fat nothing on this. I searched around the Web quite a bit too.

I’m really surprised this has not been raised elsewhere. It’s making me think my unit is bad or something.

It just seems the energy value is not calculating correctly - almost like every time the device is turned on whatever the watts are, for example, 14W for my fixture, that 14 gets added to the energy value rather than energy being a true kWh value - but I can’t prove that yet. Either way I’m at over 330kWH for a few months’ usage at maybe a few minutes a day usage.

Tagging @TheSmartestHouse in case they have any ideas on this one and why reset never works.

Hi @wgmcg, the official device handler for the On Off Thermostat is available here.

Feel free to get in touch with our support if you come across any issues using the device.

Yeah that’s the one I’m using now. I can turn the switch on and off as a toggle with the modeSetting() command, but “Set to auto”, “Set to cool”. “Set to heat”,and “Set thermostat mode” do nothing.

The best I’ve been able to get out of it is toggle between off (which is on) and heat (which is off) with the modesetting() command. I can’t set discrete modes.

The thermostat, in it’s default configuration, only supports Off and Heat modes, where Off disables temperature regulation and Heat enables temperature regulation (NOTE: The temperature needs to be under the setpoint in order for the device’s output to turn on and actually start heating).

If your thermostat behaves differently you should return it since it must be faulty.

This is an issue with SmartThing’s Z-Wave engine implementation for which i’ve tried contacting SmartThings support on numerous occasions but only got crickets or a marketing person’s reply whereas i’d really need one of their engineers to take a look at this.

When including Flush 2 Relay with a temperature sensor connected the system doesn’t show the user any mention of the device being included even though on the RF network layer, the device answers all requested commands (verified via Z-Wave Dev Kit provided Zniffer logging to ensure all commands are replied to correctly). It’s as if something in their inclusion process cannot handle certain endpoints.

The same device, in the same configuration, worked normally on the following controllers i had a chance to try: Sigma Designs PC Controller, Fibaro HC Lite, Zipato Zipabox/Zipatile, Z-Way, VeraLite/VeraEdge, Homey and OpenHAB so i REALLY doubt it’s a device problem.

1 Like

If anyone has a Flush 2 Relay can you please try a reset of the kWh and let me know if it works for you. As I’ve reported above the reset does absolutely nothing for me either from the main device or child device.

This is driving me mad and I can’t believe that I can’t find more reports of this.

UPDATE: @erocm1231 I believe I have found the issue with the reset not working on the Flush 2 Relay.

command "reset"

Needs to be added to the metadata section in the parent DTH. I can now reset the energy values - but only from the parent device. The child handler for metering switch does have the reset command but it appears the reset does not work at the child level even with it present. That may just be my lack of understanding how child devices work.

My next mission is to track down why energy reporting values seem so high. First step is to watch for a while now I have the reset working to see if it’s really an issue.

UPDATE: Of the two fixtures I have running on my Flush 2 Relay only an LED light has been used for a total of less than 2 minutes since I reset the kWh yesterday. That is now reading 3 kWh used and the other fixture that was not even turned on is reading 5 kWh. There’s something wrong with this device.

1 Like

Bummer that the reporting isn’t right, but thanks for finding my simple mistake. :slight_smile:

As for the child resets, there needs to be a new method created in the parent to handle the resets. I will try to get that put in.

@Nezmo I fixed the missing reset command declaration and added the child device reset method. I haven’t been able to test it, but it should work. Give it a shot and let me know.

1 Like

Great stuff. I will test a little later tonight after dinner.


Okay @erocm1231, reset from the parent device is now good. However reset from a child is throwing the following:

9:24:18 PM: error groovy.lang.MissingMethodException: No signature of method: script_dth_3ff158c21662a3aba6f2f6856b210615d4612a0a35e81ec290286ce9caf7f764.secure() is applicable for argument types: (physicalgraph.zwave.commands.multichannelv3.MultiChannelCmdEncap) values: [MultiChannelCmdEncap(bitAddress: false, command: 5, commandClass: 50, destinationEndPoint: 2, parameter: [], sourceEndPoint: 0)]
Possible solutions: section(), every(), render(java.util.Map), run(), include([Ljava.lang.String;), remove(java.lang.String) @line 263 (childReset)
9:24:17 PM: debug childReset(5F-ep2)

EDIT: It looks like you put another change out there? I pulled it in and now I have a different error when reseting from a child:

10:27:01 AM: error groovy.lang.GroovyRuntimeException: Could not find matching constructor for: physicalgraph.device.HubAction(physicalgraph.zwave.commands.multichannelv3.MultiChannelCmdEncap) @line 262 (childReset)

Oh man, I’m on a roll. That’s what I get for trying to update code on my phone while lying in bed. I put another version up. Hopefully that is the one. :slight_smile:

1 Like