[RELEASE] Qubino Flush 1D Relay, Flush 2 Relays, Flush 1 Relay, & Flush Dimmer

Any hope of getting the Flush 1 Relay added to your list of compatible devices?

I’m using it on outdoor GFCI outlets and prefer it to the Flush 2 Relay in this case because of the 10A max.

There is an existing integration but it requires polling for power usage.

EDIT: On a whim, I tried the DTH for the 2 Relay module and it works but has a nuisance alert for failure to create child device (which I don’t need for the 1 relay module) and all the Q2 parameters that don’t apply. I’ll either rip that stuff out myself or a parameter to state 1 Relay or 2 Relays in the DTH would work too to limit things.

Truthfully, I hate to have to rip stuff out as it then diverges from the original master branch and I might lose updates :wink:

They do not support that functionality.

@bmmiller I just got the 1 Relay and will be adding support for it in the next couple days.

1 Like

After further review, the 2 relay one doesn’t work quite right on the 1 Relay module as-is.

Seems like on/off status doesn’t report but on/off command works. Energy works but not configure (not surprising) so things can’t be reconfigured either.

I am sure this would all be obvious to you but providing feedback in case it is useful at all.

I have a handler for the 1 Relay module. It does need child devices installed if you plan on using the i2 & i3 inputs. I will probably modify that in the future to default to disabled and only bug the user about the child devices if they have enabled them in preferences.

Awesome!

Just so I understand, what is the device capable of for meter functionality?

I’ve set this in the settings and the orange dot disappeared. I’d expect to see updates very 2 seconds with the Debug Logging Level set to ‘All’ but nothing really happens.

I will say I don’t have anything plugged into it right now, so the power draw is literally just the receptacle being powered up. Things might change if I plug a real device in? Otherwise, things work great. There is the nuisance alert when it can’t find the child DTH it is looking for, but if it’s harmless, no worries.

Great work again @erocm1231

I have the Flush 2 Relays working, the only thing i notice is that when i use the physical switch for the light, the “child” (Q1 or Q2) device doesn’t go on in the app, but the main switch in the app does go on, but then i still don’t know which of the 2 is on when i look into the app.

The settings are default.
Can that be solved or am i doing something wrong.?

I will look into this a little later today.

@Dennis_Tegenbosch I believe there is something going on with the SmartThings platform. There is something in the handler that is not working anymore, and it seems like maybe others are reporting something similar. I’ll keep this thread posted when I figure it out.

1 Like

@Dennis_Tegenbosch just an update. SmartThings does have a platform issue that is causing problems with a lot of device handlers. SmartThings staff have identified the issue but have not mentioned an ETA on a fix.

1 Like

After doing some testing and looking at the logs, it looks like parameter 40 (and maybe 42) aren’t getting set to ‘0’ when requested in the DTH.

Below are logs after setting to 0:

As you can see it states it is trying to update to 5, which isn’t right. If I try and set it to some non-zero value, like say 1:

Since ‘5’ is the default, I’m guessing it isn’t a coincidence. I’m more interested in the time interval parameter 42 myself, but this stuck out as potentially conflicting. I’m not sure how it reacts if you have % AND time as non-zero, but it seems like % might override time and if that’s the case, it’ll never report on time.

I haven’t started looking at the code yet to see if there is an obvious bug where 0 gets reset to the default 5 before send yet.

Just reporting what I’ve noticed.

@bmmiller Alright, so I did find the bug you are referring to and posted a fix. You can now set those parameters. I haven’t tested whether that fixes your initial issue so you will have to let me know.

Edit: I don’t think the device sends reports when it is off other than the initial 0W report. Did you end up connecting anything to it?

@Dennis_Tegenbosch forgot to mention that the platform error was corrected and the problem you were experiencing should be fixed.

1 Like

I’ll test your update tonight. I didn’t mean that the relay was off, but that there was nothing plugged in. It still reports 1W or so even if nothing is plugged into the outlet. The 1W being whatever it takes to run the GFCI outlet.

Interesting enough, I had temporarily changed your code to default the % change to 0, and paired a second unit, and it reports perfectly. Meaning I can get it to update fractions of a W every single second if I wanted. The same DTH change does not work on the first unit, like the first unit won’t let itself reconfigure after it was configured goofy the first time. Not sure. The unpairing process for these seems pretty annoying so unpairing/repairing is a last resort if it bugs me enough.

I’ll take a look at what you did and play with things a bit.

Thanks!

Am I correct to assume that if I open up settings and change nothing, nothing gets sent to the device?

I have my two devices configured exactly the same, but only 1 reports power like I’d expect, while the other requires hitting the refresh button. I have a feeling that something in the configuration isn’t applied the same, even though the DTH shows that they should be the same.

For the most part, yes. Although, if you press the “done” button and there is a lingering configuration that needs to be pushed to the device, it will push it. If you open settings and hit the back button then nothing happens.

I suppose this is possible . . . but not very likely. If you want, you can replace the “refresh()” method in you handler with this one and hit the refresh button. This will make the device report back its settings.

def refresh() {
    def cmds = []
    [1,2,3,10,11,12,15,30,40,42,63,110,120].each {
        cmds << zwave.configurationV1.configurationGet(parameterNumber: it)
    }
    cmds << zwave.switchBinaryV1.switchBinaryGet()
    cmds << zwave.meterV2.meterGet(scale: 0)
    cmds << zwave.meterV2.meterGet(scale: 2)
    cmds << zwave.sensorMultilevelV5.sensorMultilevelGet(sensorType:1, scale:1)
    return commands(cmds)
}

Thanks for the snippet of code. It took several calls, and slowly pulling out the variables I confirmed that were the same, but both are indeed configured identically.

I’m at a loss as to why one reports on the 10sec intervals I have it set to and the other only reports on refresh. I’ll try “rebooting” the one by killing/restoring power from the breaker.

If that doesn’t work, I’d probably have to try unpair/repair but that won’t be happening anytime soon as it involves taking everything apart again.

That is really strange. I’m not sure what is going on. If I get time I will look at my Qubino devices to make sure they aren’t doing something similar.

As for the reset, you can try flipping the switch attached to i1 after switch power up as defined in the manual:

@erocm1231 they are working perfectly now, thanks for letting me know and for making the device handler :+1:

1 Like

Does anyone have a good installation video for the 2 relay switch for US installation?
Specifically I want to install this to control a bathroom light and fan (no dimmer needed). Can I just plugin the existing wires in the box or do I need to do splicing to smaller wires like the Aotec models? I was hoping to avoid splicing as I have very little space in the gang box.

As for wiring, my understanding is that I1/Q1 and I2/Q2 would be the wires on the current light swtiches and I need an additional neutral and line for the relay itself.

Hi,
I just installed this device and im getting the error “child device creation failed, please make sure that the “metering switch child device” is installed and published”, any idea whats this?
Also, how can i control both switches independently? Right now both turn on and off together

Thanks!!

You need line (120v AC from circuit breaker) going to 1) relay module 2) physical switch1 3) physical switch2. Load from physical switch1 & 2 will go to I1 & I2 respectively. Q1 will deliver load to the bathroom light and Q2 will deliver load to the fan. As mentioned, neutral will go to the relay module as well. So, when physical switch1 is closed it will deliver 120v to input1. When physical switch2 is closed it will deliver 120v to input2. Does that make sense?

@mcaldas SmartThings recently implemented a “proper” solution for handling devices with multiple endpoints of the same capability called “composite devices”. This requires a parent and a child device handler to be installed. Scroll to the 1st post, find the link to “Metering Switch” child device and install/publish it. Then go back to the device in the SmartThings app, hit the gear icon, and hit done. That should complete the setup and install two relay endpoints that can be configured individually.

Are you able to connect the line cable directly to this relay? I know in Aotec ones the thicker wire caused issues so you needed a connector in between