[RELEASE] Qubino Flush 1D Relay, Flush 2 Relays, Flush 1 Relay, & Flush Dimmer

It seems like the second one did not get its child devices deleted and recreated. That would be the cause of that error . . . Or an association issue. Go into preferences and change a preference to resubmit the config.

This part I most certainly did…

I have not played with associations either, but will try to save from the app as I haven’t as yet - only from the IDE…

Will your handlers also work for a Flush 1 Relay ON/OFF Thermostat (ZMNHID3)?

I do not believe that it will.

Did you get it to be ONLINE? I just purchased/added a 1D, but Smartthings shows it only as OFFLINE. I added it right beside the hub… that didn’t work. Very frustrating.

It’s not just you. It’s a platform wide issue. This has now been posted to the status page as well.

1 Like

Well I’m at a loss with my new Flush 1D Relay (in the new app).
I just can’t seem to get the temperature probe to show up.

The probe is one I’ve used on a Qubino Flush Relay ON/OFF Thermostat and it worked fine.
I’ve made sure it was plugged in BEFORE I powered up the device. I’ve included/excluded/hard reset about 30 times. It comes up either as a z-wave switch or a Qubino Flush 2 Relay.

When it comes up as the Flush 2, I change over to the custom Flush 1D handler. It creates 1 contact sensor child device (i2) that just continues to say “Checking…”

I’ve spent about 4-5 hours on this and am coming to an end.

Can anyone please lend some advice?

In the new app there needs to be a “template” that the device can use to determine what information is displayed in the device page of the app. Last I checked a template did not exist for a “switch” that includes “temperature” because it is a unique device. The current template is “generic-switch-power-energy”. As far as I know there is no “generic-switch-power-energy-temperature”.

1 Like

But I’m trying to use your handlers for this device. Does your handlers not handle TEMPERATURE as well? I don’t seem to see any child device handlers in your list pertaining to temperature… even though others seems to be able to see temps. Perhaps I’m going at it the wrong way?

When I finally get the device to come up as only “Qubino Flush 2 Relay”, I switch it to your Flush 1D handler. What else am I supposed to do? No child device comes up except for CONTACT… and that just sits there with “Checking”. The main device comes up and ON/OFF works, just no indication for TEMPS.

The device handler doesn’t support temperature in the new app. Only in the old app.

I Have Qubino Fulsh 2 relays, Qubino Fulsh 1 relay and Qubino flush 1D relay, using these device handlers, and the temperature works without any problems. The only problem i have is with qubino flush 1 relay contact I3 always checking an not working!
Indeed i have added them to my network and reset them several times until they worked, but the temperature has to appear when you add them to the network, the device child with the temperature is created automatically.

Qubino 1|638x500

1 Like

@The_Black

I’ve tried so many times (maybe 30-40) and just can’t get the Flush 1D to recognize the temp probe. What probe are you using? The probe I have plugs into that little port and is the one I used on my Qubino Flush Relay ON/OFF Thermostat (which the Flush 1D is replacing). I’m assuming that same probe is the one that all the Qubino relays use. As I stated before, I need BOTH temperature AND one contact switch on this unit.
Screenshot 2021-04-07 105312

The probe which i use is the one from qubino plugged in same as your picture. What i was checking indeed for the qubino relays that i have the temp probe connected i am using the device handler from the Qubino Flush 2 Relay.

1 Like