[RELEASE] Qubino Flush 1D Relay, Flush 2 Relays, Flush 1 Relay, & Flush Dimmer

I don’t have one of these devices, but you can reference some of my code where I created tiles for preset values to set a level for a vent (same process as a dimmer). In each tile there’s an action to perform the dimmer value (set value). Search the code below for the words “ventFifty”. You’ll see the code for the tile and the code to set the dimmer level.

https://raw.githubusercontent.com/jsconstantelos/SmartThings/master/devicetypes/jsconstantelos/my-keen-home-smart-vent-v2.src/my-keen-home-smart-vent-v2.groovy

You should see 6 tiles for preset values - up 5%, down 5%, 25%, 50%, 75%, and 100%

Hopefully this will help you tweak your code to do what you want. Please note that the new app (v3) will not have these new tiles, just the Classic app will have them.

Alright thank you I will have a look into that. Of course for the classic app :slight_smile:

1 Like

OK I had this command for a tile to appear as an example:

valueTile(“ventSeventyFive”, “device.switch”, inactiveLabel: false, decoration: “flat”, width: 2, height: 2) {
state “ventSeventyFive”, label:‘75’, action:“ventSeventyFive”

But I have a tile with Unknow on it
I added the command line as well:
command “ventSeventyFive”

What I am missing? Sorry for this question…

No problem at all! Even though I don’t have one of these, I took a shot at modifying the code for you. If you’re using the dimmer code above as-is, then give this a try:

https://raw.githubusercontent.com/jsconstantelos/SmartThings/master/devicetypes/erocm123/qubino-flush-dimmer.src/qubino-flush-dimmer.groovy

Here’s what I did

  • Added new 1x1 tiles - preset 1 through 4, and 5% up/down
  • Added new commands
  • Added new sections of code starting at line 361

And it’s nice and working. Thank you again really appreciate your help.

One more question how can I put my own icon?
Edit nevermind I found it :slight_smile:

1 Like

You’re welcome!

just bought Z-Wave Qubino Flush Dimmer Plus, once you have it configured can you use a generic z-wave dimmer?

@erocm1231 thanks so much for these DH - I’m a github noob in the UK . Pretty sure I’ve the github integration working but I can only find your custom DHs in the generic smarthingspublic repo - and some of the child devices dont show up at all in the Update from Repo section - is the only way to get these to copy paste the RAW file, I’m sure there’s an easier route?

Much obliged and thanks again.

You just need to add my repository to your settings in the ide and update from there.

image

thanks for the reply, got it working. Not sure what the issue was. All working perfectly and intend to double down on Qubino thanks to your great work on these DHs.

1 Like

Hi @erocm1231, thanks for your amazing DTH’s, I’ve been using them for over a year and they’ve been rock solid, except for today when I tried a few Flush 2 Relays and got this weird behavior.

The main relay switch is stuck on off, when pressed it shows turning on, and turns on the lights but reverts back to off. Same for the energy readings, they remain 0, until I hit refresh, they show the right readings but still shows off. When hit off (while it’s stuck on turning on), the lights turn off normally.

Both Q1 & Q2 buttons work just fine, and report on and off on time whether controlled from app, switch or Alexa.

I tried and faced the same issued on 7 different relays and 2 Sat hubs.

Hoping you can help me. Thank you!

I’m using the Qubino 2 Relay with the device handler and child device. Both Q1 and Q2 are showing and responding properly however no inputs are showing up. I wanted to use limit switch of a garage door with the inputs and open the door with an output. My question is can the Qubino 2 Relay inputs be use for monitoring.

Hello Eric,

First of all thanks for the DTH for the qubino Flush 1D Relay. I hooked up everything and all is good for a garage opener (momentary switch). The only strange thing is that once I press the switch on the ST app (new and old) it remains on despite the fact that the relay turns off after 1 second. Even refreshing the app it still shows the state as “ON”. Any clue what might be happening?

parameters are as follows (images):

Hi… I’m facing the same problem… did you manage to get it fixed?

erocm1231 - I have the Qubino Flush Dimmer (have been using it for 3 years now and it is working fine). The only problem is that I am not able to turn of the spamming with energy reporting.
I have tried runing it of by setting parameter 40 = 0 and 42 = 0 but when the dimmer is turned on, it reports energy consuption around 30 times every minute.
HowIs there any workaround?

Hi all… could someone please help me? I keep getting “device not responding” when trying to control from Alexa but the device actually works… this is an error I’m getting in the IDE.
Any idea what’s wrong?

Hello Hiato, nope, still the same.

If you aren’t using the temperature probe then try commenting out the temperature capability at the top of the code:

//capability "Temperature Measurement"

Might have to remove and readd to Alexa, but I’m not sure.

Hi @Obbi13,
I was having some issues with the app not reporting the correct state of my Flush 1D Relay after I pressed the physical switch. I made a small tweak on the DTH that fixed my issue, and I think this could be related to your issue. Would you like to give a try?
I’ve sent to @erocm1231 as a PR: https://github.com/erocm123/SmartThingsPublic/pull/19

Hello Tyron,

This is good, now, how do I apply it to the DTH that I got saved on my IDE instance?

Regards,

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.