[RELEASE] Qubino Flush 1D Relay, Flush 2 Relays, Flush 1 Relay, & Flush Dimmer

Excellent thank you. I’ve updated handlers for both relay 1d and dimmer, and added child device. All devices now showing i2 or i2+i3 as appropriate. Have added a few new Smart Lighting routines against the extra open/close contacts.
Can’t connect wiring to extra terminals to test until the weekend- looking forward to closing off a few items from my wish list.!

Can I ask if you intend uploading the handlers to.SmartThings to try to start the process of getting them added? Particularly in the U.K. where we don’t get GitHub integration this would be the icing on the cake.

If SmartThings had such a thing as an App Store I’d be more than happy to pay for them- until then I’d be happy to offer a donation either directly or to a charity of your choice…

Thank you again- wonderful piece of work for these fantastic modules

I have honestly never tried to publish my work through SmartThings. Have heard bad things about the experience, but maybe that is a thing of the past. I’ll give it a shot and see how it goes. I’ll let this version of the handler settle in for a bit before submittal to make sure there aren’t any bugs.

Gentlemen, did you manage to get the Flush Dimmer included while both I2 and I3 are enabled via this handler?

I’m writing a common device handler for these that would support all features but am having trouble with SmartThings detecting the device during inclusion at all when both inputs are enabled.

Which features are you looking to add that aren’t already supported with this handler?

I have found that the dimmer is kind of finicky with inclusion and usually have to try several times.

I’m mainly trying to add a full multichannel context to the device that would support the full configuration range for the device’s capabilities in a single handler, so both configurable inputs and the optional temperature sensor along with single and multi channel associations.

It’s most likely not an issue on the device itself since on the z-wave network level all commands are answered correctly, but for some reason i can’t get it to recognize the device with both inputs enabled (with just 1 it’s paired normally).

So the only thing mentioned there that my handler doesn’t support is the direct associations, but I do recommend people use the Z-Wave Tweaker smartapp for associations as it is a great tool with feedback for confirmation etc.

Last update to these handlers added support for the i2 & i3 inputs. It also switched the Qubino 2 Relay device over to SmartThings new composite device method of handling multichannel devices. This is something I have been waiting for for a long time! (but it does require child device handlers to be installed)

I have just commited a new update that allows you to dynamically change the inputs of i2 & i3 to several different types of sensors (smoke, carbon monoxide, motion, contact, water, carbon dioxide). Here is a video of it in action:

This functionality will be in the Flush 1D Relay as well as the Flush Dimmer.

Is there a way to have a smart app pick up the temp from this unit? I’d assume it would be by setting parameters for the digital temp sensor reporting, but I am not clear on what those parameters do.
I am trying to run a ventilation fan when the temp reaches a certain point and was using the samsung multi sensor, which I think are awful, but it worked…replacing the batteries every week just got old.
Any help greatly appreciated.

Yes, the handlers all support temperature sensors. To have them automatically report temperature, they have to be included while the temperature sensor is connected. Any app that lets you select a device with the “Temperature Measurement” capability should be able to use the temperature sensor on these.

Does input i2 and i3 support double and triple click?

Any hope of getting the Flush 1 Relay added to your list of compatible devices?

I’m using it on outdoor GFCI outlets and prefer it to the Flush 2 Relay in this case because of the 10A max.

There is an existing integration but it requires polling for power usage.

EDIT: On a whim, I tried the DTH for the 2 Relay module and it works but has a nuisance alert for failure to create child device (which I don’t need for the 1 relay module) and all the Q2 parameters that don’t apply. I’ll either rip that stuff out myself or a parameter to state 1 Relay or 2 Relays in the DTH would work too to limit things.

Truthfully, I hate to have to rip stuff out as it then diverges from the original master branch and I might lose updates :wink:

They do not support that functionality.

@bmmiller I just got the 1 Relay and will be adding support for it in the next couple days.

1 Like

After further review, the 2 relay one doesn’t work quite right on the 1 Relay module as-is.

Seems like on/off status doesn’t report but on/off command works. Energy works but not configure (not surprising) so things can’t be reconfigured either.

I am sure this would all be obvious to you but providing feedback in case it is useful at all.

I have a handler for the 1 Relay module. It does need child devices installed if you plan on using the i2 & i3 inputs. I will probably modify that in the future to default to disabled and only bug the user about the child devices if they have enabled them in preferences.

Awesome!

Just so I understand, what is the device capable of for meter functionality?

I’ve set this in the settings and the orange dot disappeared. I’d expect to see updates very 2 seconds with the Debug Logging Level set to ‘All’ but nothing really happens.

I will say I don’t have anything plugged into it right now, so the power draw is literally just the receptacle being powered up. Things might change if I plug a real device in? Otherwise, things work great. There is the nuisance alert when it can’t find the child DTH it is looking for, but if it’s harmless, no worries.

Great work again @erocm1231

I have the Flush 2 Relays working, the only thing i notice is that when i use the physical switch for the light, the “child” (Q1 or Q2) device doesn’t go on in the app, but the main switch in the app does go on, but then i still don’t know which of the 2 is on when i look into the app.

The settings are default.
Can that be solved or am i doing something wrong.?

I will look into this a little later today.

@Dennis_Tegenbosch I believe there is something going on with the SmartThings platform. There is something in the handler that is not working anymore, and it seems like maybe others are reporting something similar. I’ll keep this thread posted when I figure it out.

1 Like

@Dennis_Tegenbosch just an update. SmartThings does have a platform issue that is causing problems with a lot of device handlers. SmartThings staff have identified the issue but have not mentioned an ETA on a fix.

1 Like

After doing some testing and looking at the logs, it looks like parameter 40 (and maybe 42) aren’t getting set to ‘0’ when requested in the DTH.

Below are logs after setting to 0:

As you can see it states it is trying to update to 5, which isn’t right. If I try and set it to some non-zero value, like say 1:

Since ‘5’ is the default, I’m guessing it isn’t a coincidence. I’m more interested in the time interval parameter 42 myself, but this stuck out as potentially conflicting. I’m not sure how it reacts if you have % AND time as non-zero, but it seems like % might override time and if that’s the case, it’ll never report on time.

I haven’t started looking at the code yet to see if there is an obvious bug where 0 gets reset to the default 5 before send yet.

Just reporting what I’ve noticed.

@bmmiller Alright, so I did find the bug you are referring to and posted a fix. You can now set those parameters. I haven’t tested whether that fixes your initial issue so you will have to let me know.

Edit: I don’t think the device sends reports when it is off other than the initial 0W report. Did you end up connecting anything to it?

@Dennis_Tegenbosch forgot to mention that the platform error was corrected and the problem you were experiencing should be fixed.

1 Like