RELEASE: OSRAM Lightify Smart Dimming Switch(Ultra-fast Zigbee Handler, No Smart App)

You can sign up for email notifications re: the platform status too. No guarantee that issues you at be experiencing can be attributed solely to a platform outage when one is occurring, but no use searching for an underlying cause unless you continue to have problems after the outage is resolved.

Perhaps I’m barking up the wrong tree here, but I’m having a hell of a time doing something that seems like it should be simple to do.

Problem to solve:
I have a room in my house with no traditional light switch or proper wiring to get a SmartSwitch. I do have an Echo Dot and a smart plug (Zwave GE) which will control a plugged in lamp. Works just find with Alexa. I tell it to turn on or off the lamp and it activates the smartplug to turn it on or off.

The problem I have is this is in my daughter’s room and she isn’t that great with voice commands as she is still young. I’d like some kind of switch to be able to turn the lights on and off the old dumb way.

As I can’t use a smart switch due to wiring, I can’t use IFTTT to turn on the smart plug. So I thought this Sylvania lightify+ Dimmer switch that just mounts on a wall was perfect. My thought process was that button press 1 would tell IFTTT to turn the Zwave plug on and then button press 2 would turn off the Zwave plug. However, I can’t get this to work using IFTTT.

Here’s what I’ve tried:
I have tried just the default SmartThings discovery and it found it, but of course didn’t really do much. It wouldn’t pull into either Alexa or IFTTT. I used this handler, which I did seem to install correctly, but still wouldn’t recognize as a switch to pull into Alexa or IFTTT. I then modified to the code by adding capability “Switch” which then DID seem to allow me to pull it into IFTTT and Alexa via Smartthings. However, it didn’t seem to work. In Alexa, if hit the on button on the switch, it would switch on in Alexa, but then immediately off. Did want to stay on, which I think is because it’s a button. But, more importantly, while it did pull into IFTTT it did not work. I’ve created a bunch of applets in IFTTT, so I know what I’m doing there. I tried doing it with my GEZWave switch with the smart plug and it worked fine, but that switch is in a different room controlling something else, but it was a good test to make sure it wasn’t the plug having the issues. It was def this lightify smart dimming switch.

Can anybody help solve my problem? I simply want to put a switch in a room with no traditional light that will turn a Z-wave smart plug on and off.

I don’t have a Sylvania lightify+ Dimmer, but I am thinking Smartthings is seeing as a button not a switch. You may able to use the smartlighing app. I use it with my minimote.

Not entirely sure why you’re having such difficulty, but what you’re looking to do should be simple.

Pair the lightify dimming switch with ST, then use smart lighting to turn your z-wave plug on and off, using the lightify dimmer as the trigger.

Edit: A smartlighting automation like @Jason_Brown’s screenshot would work fine. The lightify dimmer is indeed treated as a button by ST. Since it has two buttons, you could create two automations, one for on and one for off.

Also you might want to what before trying this until Smartthings heals.
https://status.smartthings.com/

Use the device handler from this post:

Then set up a smart lighting automation to turn the lights on when the up button on the dimmer is pressed (no toggle) and another for when down is pressed to turn the lights off (again, no toggle).

You can also set up another to turn the remote on/off when the light is switched on/off from other sources like Alexa so the remote status stays in sync if you really care about that. It doesn’t matter though.

No need for IFTTT or anything else.

This worked. I missed the button options inside of the automation in SmartThings. Didn’t even realize that was there. Thanks so much!!!

2 Likes

Hello everybody, i am a newbie to smart things so please take it easy on me. I have setup the device handler but the switch has a HUGE delay, 10-20 seconds sometimes. I tried a few other handlers/smart app combos around and still seeing the same thing. Where it gets weird is when i turn the switch on and off in the smartthings app its almost instant, so now im concerned maybe my new switch isnt working properly

It’s possibly related to the ST network issues going on right now. My switch wasn’t working at all yesterday. Today it’s back to normal though.

Thanks, today my switch is functioning perfect. I didn’t realize there was network trouble until about 4 hours in trying to setup my new switch. Like I said I’m new here sorry! Carry on

Does this DTH work only with Zigbee HA devices? I got it to work with my sylvania bulbs but can’t make it work for my Hue bulbs, which are Zigbee LL. For Hue I have to use the ST default “zigbee button” DTH.

So it looks like I’ve found something that doesn’t work… This handler doesn’t seem to be able to turn on my Sengled Element Classic bulbs. It working fine with a Cree bulb. The button will turn off the Sengled bulb, but not turn it on.

2a4e5713-3ada-4435-b0ab-960f3198c153  9:06:17 AM: trace Sending current state to device [st cmd 0x3305 0x01 8 4 {FE 0000}, st cmd 0xDD09 0x0A 8 4 {FE 0000}]
2a4e5713-3ada-4435-b0ab-960f3198c153  9:06:17 AM: info hallway South button 1 was pushed
2a4e5713-3ada-4435-b0ab-960f3198c153  9:06:17 AM: debug message pushed button 1. brightness 200
2a4e5713-3ada-4435-b0ab-960f3198c153  9:06:17 AM: debug parse description: catchall: 0104 0006 01 01 0140 00 2F8F 01 00 0000 01 00

0x3305 0x01 8 4 {FE 0000} is the Sengled bulb which didn’t turn on.
0xDD09 0x0A 8 4 {FE 0000} is the Cree bulb that did turn on.

I get logging for the Cree bulb:

73dee47d-ea9d-404a-93cd-925a6370c85e  9:06:17 AM: debug [raw:0104 0008 0A 01 0140 00 DD09 00 00 0000 0B 01 0400, profileId:0104, clusterId:0008, sourceEndpoint:0A, destinationEndpoint:01, options:0140, messageType:00, dni:DD09, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:0B, direction:01, data:[04, 00], clusterInt:8, commandInt:11]
73dee47d-ea9d-404a-93cd-925a6370c85e  9:06:17 AM: debug DID NOT PARSE MESSAGE for description : catchall: 0104 0008 0A 01 0140 00 DD09 00 00 0000 0B 01 0400
73dee47d-ea9d-404a-93cd-925a6370c85e  9:06:17 AM: debug level updated successfully

But nothing for the Senglend bulb.

I’m lost as to what it might be doing…

This only really works with the lightify bulbs. Any other use case is not expected to work

Gotcha. I have one of those in the house too. Looks like it’s time to swap some bulb positions. Thanks.

Are your endpoints correct? 01 vs 0A?

Yeah, I was using the endpoints that the IDE had. I have it working with both Cree and Lightify bulbs, so I’m good for now.

1 Like

And that is why I don’t use custom device handlers if there is a native ST one already? Only native ST device handlers and rules support local processing. When I lose internet, my OSRAM switch continues to control my lights.

Would be nice if ST would implement some real support for dimmers. It is annoying that the only dimming is load controlling dimmers – remote dimmers are not supported, because they do not read dimming level as events from these types of devices, and they don’t know how to deal with press and hold events for controlling dimming. I am still hoping for a native ST solution soon. I never migrated off of CORE, and since I only use it for a couple automations that I do not need offline processing for, I have no need to migrate to the rules engine system.

That simply is not true. I use this switch to control GE+Link bulbs (Zigbee), Z-Wave wall switches, and anything else I want to control on/off state on. The device handler is only about receive the events from the switch. The control of the bulbs has only to do with the device handler for the bulb, and the SmartApp controlling the target device. The switch is not paired to the light in anyway, it is paid to the hub, and hub is responsible for everything else.

My suggestion to @xdreamwalker is to control the bulb directly from the ST app. If you can manually turn the bulb on/off and if dimmable–dim it, then the issue is your SmartApp that is controlling the bulb.

The Device Handler for the switch has only one purpose, to translate button pushes into button press events. Just take a look at the stock DH from ST to see how they implemented the logic. It becomes more clear what it happening when you look at this way. If you are using WebCore, it is likely your rules are not written correctly for the bulb.

So, it turns out ALL my lighting controls have failed to work in the past few days. I have opened up an issue with Samsung. This is a SmartThings hub issue. Nothing changed except for the recent firmware update, and I just learned all the smart apps that control lighting in any way (DimWithMe, SmartLighting, etc) all fail to execute on published events. I can use the SmartThings app to force the lights on/off, and can use Alexa, etc. But all my devices that are not load controlling no longer work. The on/off, Level Up/Down, and other events are picked up by the Device Handlers, but the Smart Apps are not being executed. To that point, even through the app, if I turn the switch/dimmers on/off, no rules are triggered. So, if you are having issues with this device handler, or the SmartThings generic Button Controller handler, it’s not your device, or your device handler, it’s the SmartThings update that broke the smart apps.

@adamoutler, have you considered removing the direct device control of bulbs and submitting this to Samsung for integration as an official device handler? I think the direct device control is the only thing that would be an issue, and your handler is a great device handler for this two button controller. Much nicer than the generic button controller preferred by the current SmartThings system.