SmartThings Community

RELEASE: OSRAM Lightify Smart Dimmer Switch (button controller device handler and smart app)

osram
dth_remotes
dth_lighting

#73

The ramp up/ramp down is most likely a parameter in the switch settings. If it is possible to change that, you would do it by reconfiguring the device if you have a device handler capable of changing those Settings.

So first you need to figure out what those parameters are, and then the device handler would have to be updated to allow the changes.

If you’re controlling smart bulbs, it might be a separate parameter in the bulb settings as well. So then you have to look at the device handler for the bulb.


(Kent Marshall) #74

ok did a bunch more testing. I must be doing something really wrong.

Existing and brand new switches pair. They are automatically assigned your device profile.

Still,only one switch is working. The rest of them were setup the exact same way.

When I press buttons nothing happens, nor does it show in recently or the live log. If I refresh from the app. the switches respond in live log.

How I am seting up

I am adding the switch
going to my smartapps on the web picking your app
selecting home
the switch
lights
button 1& 2 levels
then install

It appears on the mobile app under the selected switch

but nothing happens. Hopefully I am doing something stupid.

The 1 switch continues to work fine. I even deleted your app from it, and readded it. Still works

Am I missing a step?

Any ideas?


(Oscar Calvo) #75

I am seeing the same. The old switch reports states and data. But the new switch is not reporting any state or any data. I am checking this in the Ali graph web site


#76

If you are using a smartapp for it you will have to install one copy of the smartapp for each switch. That’s just how SmartThings works. So three switches, three copies of the smartapp.


(Oscar Calvo) #77

What app? I am talking about the device state in the http://api.graph.smartphones.com

I see different things for my 2 switches, one have states and events and the new one does not have any state or any event.


#78

You said you were using his smart app. Did you mean device handler or smart app? Or both?

.

If you are using a device handler, you only have to install it once, then each switch will find it and use it when they pair.

If you are also using a smart app, you have to install that once for each switch.


(Oscar Calvo) #79

Here is what I am seeing:
Old switch:

New switch:

Notice how the new switch says: “No states”
And it does not report any battery level, or any event.


(Oscar Calvo) #80

I am seeing this in the debugger:

7c82608c-3fde-4706-859d-7de7d6488ba2 ‎9‎:‎43‎:‎26‎ ‎PM: error groovy.lang.MissingMethodException: No signature of method: script14596586065851101692207.reverseArray() is applicable for argument types: (java.lang.Byte, java.lang.Byte, java.lang.Byte, java.lang.Byte, java.lang.Byte, java.lang.Byte, java.lang.Byte, java.lang.Byte) values: [-48, 82, -88, 22, -10, -41, 0, 1] @ line 74


(Oscar Calvo) #81

Also, I cannot see the new switch at all in my live logging https://graph.api.smartthings.com/ide/logs


(Michael) #82

Sorry all but it has been a busy day, give me some time to try and replicate the issue and I will let you know what I find. I have not hooked up my second switch yet as I am finishing some remodeling but I will get a second switch setup soon and see if there is some issue when there is more than 1 switch or something.

Just to confirm, you do have the smartapp installed a second time and setup to control a set of lights right? Without that you may not see any events. I don’t see anything in your “In Use By” field so it doesn’t seem you have a smartapp associated with the new switch but not sure if that is the issue.


(Oscar Calvo) #83

I still don’t have any apps on the second switch on purpose. Just wanted to test.

Another issue, is that for the first switch I am seeing the events for button pressed, but my automation does not execute. I tried rule machine and lighting automation, neither of those works.


(Michael) #84

I added my second switch and I can see in the live logging that the commands for the second switch are not being accepted and the button presses for the initial switch I setup is showing in the logs for both switches. I will do some research on that and I am sure I will be able to come up with a fix, likely just not using an unique device number or something somewhere in the code. My guess is this is what is tripping up automation rules as well.


(Kent Marshall) #85

Sorry for the late reply

I installed 1 copy of the device handler and when I add the switches they properly pick that up

I then went to the smartapp through the web interface and installed it for each switch with the appropriate lights and switch selected and clicked the install button each time. That is how you do it right?

I also tried the smartthings button controller on the working one and the non working ones. Nothing from that either.

Just wanted to give my feedback as well.

Thanks again so much for all the hard work!


(Michael) #86

I have updated the device type with a fix for the multiple switch issue, please give it a try and let me know if you see any issues. I was able to get multiple switches hooked up and they now report properly in the IDE logs. I was also able to setup my smart app to assign each switch to a separate group of bulbs and all 4 functions work.


(Oscar Calvo) #87

I am testing it…

Will keep you posted.


(Oscar Calvo) #88

I am basically seeing the same thing.
The new switch is still not defining any states and it does not show anything in the live logging window.


(Michael) #89

Did you reset and re-pair your devices? And just to confirm you have updated and published the new device type code right? I am seeing no issues and I did find the issue that was causing the problem.


(Oscar Calvo) #90

No, how do I re-pair the devices?


(Oscar Calvo) #91

Do I need to delete both devices? The old and the new?


(Michael) #92

I would go into the IDE and delete the devices and then on the switch hold both buttons down at the same tim until you see the light flash blue, then you can set your hub to pairing mode and it will re-pair those switches. I would remove all of them but then add them back 1 at a time, the code was not assigning a proper device ID previously which is why it got confused with multiple devices.