[RELEASE] Nuki smart lock device handler

what support are you looking for?

I had some questions regarding the new ST App and adding the LockNgo option.
Currently their is no option to build a local app on the new smartthings developer site - this option is available only to “organization” - already applied - but still was not approved.
The second method I have tried, but still no success is the cloud to cloud connection.
basically connecting the nuki cloud to the st cloud so actions will be preformed from cloud.
the first problem that i cant export project to the community, it is limited by smartthings only for internal testing.
hopefully in the near future samsung will allow community developers to publish apps and build local device handler.

Hello, is this integration still supported?

Yes.
Have you tried it?

I cant find where i Need to Input the NukiId and where to Input the NUKI WEP API token?

Its dead. Close this thread…

didnt get notification on your comment here
have you followed the guide: https://github.com/volski/Smartthing-nuki

after creating the dth in the smartthings console -> you need to create new device from the dth.
after you have the new device, you need to edit preferences of the new device. you have to fill the nukiid and nuki token

But i dont have the edit preferences after i created the Device???
Thats why i dont find it.

Okay so in the Picture you see my Problem…
In the Installation Guide you said on
11. In the “Type” select “Simulated Lock” (this is the device we have created in the steps before)
But in “Type” you need to input “nuki web api handler” NOT “Simulated Lock”…
Then the edit preferences button is showing up :slight_smile:

Its working fine on 29.01.2020 :slight_smile:

You need to use this handler: https://github.com/volski/smartthing-nuki/blob/master/devicetypes/smartthings/nuki-web-api-handler.src/nuki-web-api-handler.groovy

You are correct, fixed the readme file.
Thanks

2 Likes

I’m currently using this integration… but I have to wonder… what are the differences between this one and @RBoy 's integration? :slight_smile: Just a thought… (don’t kill me too much… lol!)

Haven’t tried their handler.

But mine is totally free.

2 Likes

And that’s why I jumped straight into it! Lol! Apart from the fact that it works perfectly and it was way too easy to install (provided one reads the instructions carefully)! :yum:

This approved one is developed in conjunction with Nuki and uses automatic device discovery, real time notifications and will support additional Nuki devices in future. We can continue the conversation about the other integration on this topic here.

I have both handlers and for one thing, yours tells me the door is unlocked when it is manually unlocked. The Rboy integration does not seem to do this which is a massive issue.

One question for you, I cannot lock / unlock the app without clicking into the device itself, is there any way to change this to give me the functionality from the main screen?

Thanks for your work on this.

The device handler is working perfectly on Android smartthings app, but its not on my Samsung Smart TV smartthings. It just shows the status of the lock but can’t control in opening or closing it. Any solution to this issue? :slight_smile: As I would like when I have a notification
on my ring doorbell on the TV to be able to unlock the door lock as well from the TV. Hope its feasible. Thanks a lot.

Hallo Volksi,

Thank you for your great work here, I followed your instrucion and get a problem, the current status on mthe device is permanently write: “waiting”!!!

I have already run a simulation and receive the following message, please help me:

dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:15:11: debug Error groovyx.net.http.HttpResponseException: Unauthorized
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:15:11: trace refreshing !!
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:14:11: debug Error groovyx.net.http.HttpResponseException: Unauthorized
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:14:11: trace refreshing !!
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:13:11: debug Error groovyx.net.http.HttpResponseException: Unauthorized
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:13:11: trace refreshing !!
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:12:29: info called shade updated ()
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:12:29: error groovy.lang.MissingMethodException: No signature of method: script_dth_152fc2428fe51cc1fb3ff16b32eaa455c2ad8f4a3c49a0fceadb9fy: for
Possible solutions: setBatteryLevelLock (java.lang.Number) @line 57 (initialize)
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:12:29: trace initialize ()
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:12:29: trace installed ()
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:12:29: trace installed ()
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:11:35: debug Error groovyx.net.http.HttpResponseException: Unauthorized
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:11:35: trace refreshing !!
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:11:34: error groovyx.net.http.HttpResponseException: Unauthorized @line 131 (lock)
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:11:34: trace — LOCK COMMAND —
dd7182b3-3c5a-4137-b33d-ba4a81521c41 14:10:55: info called shade updated ()

please help…
many thanks

You should check you api key.
It seems you get Unauthorized error on calls to the nuki lock.