SmartThings Community

[RELEASE] NST Manager v5.0

I just updated to the second push of 5.0.0, and all my Nest devices now have the red “unavailable” flag.

I have updated with no issues. I am not seeing “unavailable” on my 4 protects.

Just upgraded, my protects and thermostats are offline and I lost the nest away/home watch dog feature? Should I just wait???

Is it possible to mirror just some settings through automations?

for example I have two thermostats with dampers, I want independent temperature control for each thermostat but if I manually turn on the fan it would be nice if the other thermostat mirrored that to open dampers to the entire house.

I just upgraded from version 4.5 to 5.0. I have a couple of issues to report.

FYI: I did the upgrade using the manual way and in this order:
1) Updated all 5 existing Device Handlers to 5.0 code - Saved / Published
2) Created new Smart App for the New Automations using 5.0 code - Saved / Published
3) Updated existing NST Manager Smart App to 5.0 code - Saved / Published (Already Oauth Enabled)

Prior to upgrade - I had NO issues to report on any of the devices.

Devices with NO Issues:

  1. Nest Thermostat - Working fine
  2. Nest Presence - Working fine

Devices with Issues:

Nest Protect

  1. When you first open the Protect Device, you get the embedded safety / warning message about SmartThings. No problem.

  2. When you hit Refresh, you get the following error:

  1. If you go back to devices and go back into the Protect device, the screen defaults to the following screenshot

  1. I then have to scroll up to the top to see that it is Clear, but the rest of the Content doesn’t load

  2. Go back to Devices and go back into Protect - The original error message does not come back, but the Content doesn’t refresh under the Green Box. (The Initial Loading showed the entire contents of the Protect, but once you go back to ST Devices and go back into the Protect Device it doesn’t load the content (See notes on Force Stopping SmartThings App below).

  3. I can get it to load all content successfully once and if I go back to the Main Device List and go back into Protect, it won’t update/refresh (screenshot above)

Nest Cams (Indoor and Outdoor)

  1. The following issues arise when opening each (have 3 indoor and 2 outdoor) of the devices.

  2. You get the initial message for version 5.0 and then when you hit refresh, you get the following error:

  1. If I hit refresh, then I get this additional error:

  1. If I simply go back to the Main Device List and then select the Camera Device again, all appears normal without the Error Message you see above.

  2. The camera functionality looks fine (I do not have public streaming turned on, so not testing that). I was able to take a snapshot and have that show at the bottom as it did in 4.5.

Nest Weather

  1. When I initially opened up Weather from my Devices, the Weather screen loaded correctly and I got the friendly 5.0 message about the UI… As soon as I hit Refresh, I got the following error:

  1. When I go back to the Device List and try and view Weather again, like the Protect, it doesn’t reload the content. It’s just clocking and the spinning circle continues. I attempted more than 6 times. (However, if I Force Stop the SmartThings App -See NOTE section below, the Weather will appear again the next time I open the Weather device, but as soon as I hit Refresh, I get that XML File / Authentication is required message again.

NOTE:

So after going through each device and seeing the error messages for both Protect and all 5 Nest Cams, it appears that the errors do not reappear no matter how many times I open them, with the exception of the Protect not reloading Content after initial opening / error message.

So here is where it gets really interesting and I did this 3 times to see if it was repeatable and indeed it is. If I goto Apps on my phone (Motorola z Force) and Force Stop Smarthings and then go back into SmartThings, when I open each camera, the error message process starts over again for each device, and once I exit the device and open it again, the error message goes away, and the same process takes place with the Protect and the authentication error message.

Additional Items performed

  1. I went into IDE and even though I already had OAuth enabled, I refreshed my Client Secret (didn’t know if this may have had an impact from previous version).

  2. In the SmartThings Smart App I reset my Nest Token

  3. Whether either step above would have any impact or not, I did it just to make sure that everything within my SmartThings was synchronized correctly.

I want to downgrade back to version 4.5.2, but I will stay at version 5.0 in the meantime so if you want me to perform any troubleshooting or logging on this end, I will gladly perform anything you want me to on this end.

Sorry for the lengthy post, but I wanted to include as much content on all of these issues before too many people install / upgrade to this version and experience the same type of problems.

Thanks,
WB

Not sure it is your use case…

In the built-in automations, many have the ability to mirror the automation operation to another thermostat.

In your ask, it sounds like you don’t exactly want that. You want to mirror some items and not others. You may need to write a CoRE piston or other smartapp to mirror some, but not all.

Since upgrading to v5.0 earlier today, I’ve been getting intermittent notifications that my thermostat is offline (it’s the only Nest device we have) though it seems to be working fine. And when I go into the ST app, it doesn’t show that it’s offline.

1 Like

7dc41e29-0572-4e08-b6c6-8b8264f7b6fc 11:36:28: error groovy.lang.MissingMethodException: No signature of method: script14911290710701400510663.getAutomationsInstalled() is applicable for argument types: () values: [] @ line 2203

after upgrade
getting the above error in IDE when i try to click the nest manager app
the apps doesnt open now :frowning:

any ideas?
Thanks
Lawrence

I’ve got the same issue as @Luigidon:

groovy.lang.MissingMethodException: No signature of method: script1491134616996466157603.getAutomationsInstalled() is applicable for argument types: () values: [] @ line 2203

I have also noticed that the old automations are still out there when I look at the individual devices. I did follow the upgrade instructions as listed.

FWIW, 5.0 Is working great for me, but I started fresh and ripped out my old automatons and devices since I had previous issues.

I am brand new to smarthings. I started with Wemo and Nest and decided I wanted a bit more, so here I am. I am a bit surprised that nest isn’t “officially” supported, but this looks to be an even better option. With that, I have a question that, because I am new to all of this, I just want to verify that if I install this, it will in no way cause any disruption with the Nest app or servers. That this Nest Manager will not alter or stop notifications from Nest itself. I realize I would probably get two notifications (Nest Protect), but I just want to make sure that by installing this it will not stop any notifications from the Official Nest App. I just want to be sure that my thermostats and protects will still function as they do today, but with another way to control them. I just want to be sure that if my nest protect goes off, we all get the alert from nest and that this doesn’t somehow block that notification. I know I repeated myself, but I just wanted to make sure I asked the question correctly.

Thank you.

The issues we have see have been folks that:

a) upgraded from V3 to V5 (not supported…)

b) had upgraded in past from V3 to V4, but in this upgrade they did not recreate their automations (per instructions to do so); so net effect was a V3 to V5 upgrade (not supported)

http://thingsthataresmart.wiki/index.php?title=NST_Manager#Applying_Updates_to_Existing_Code

If you fall into one of these situations:

Best thing would be to delete the existing automations and re-create them.

if they can delete from the ST mobile app, that would be easiest. This means go into ST mobile app, go into Nest manager, -> automations -> select an automation -> scroll to bottom and hit “remove this automation”, then done your way out.

If the world is not going easy for you, then you have to go into the IDE to delete them

If you want you can leave another window open in the IDE in “Live logging” so if you have trouble we can see what happened.

IDE -> My Locations -> select location -> List SmartApps

scroll down to Nest manager, and you will see the automations below it (indented just below it)

  • back at the top of this page, hit Edit
  • go back down and hit uninstall next to each child automations under nest manager (don’t delete other things!)

back to top and hit done

go into ST mobile app - select nest manager, and hit “done”. Wait a min or two, then
you can start creating the automations again.

In V4/V5, there is 1 automation per thermostat, and within this automation you can enable whichever of the
automation features you need.

3 Likes

We do not change the operation of nest protect devices. They still operate as usual

with this integration, you can control thermostats from ST and from the nest mobile app. Nothing has changed there. You do want to be aware of automations you enable (either Nest or ST), so you understand “who is on first” or “who made a change to thermostat settings”

http://thingsthataresmart.wiki/index.php?title=NST_Manager

http://thingsthataresmart.wiki/index.php?title=NST_Manager#NST_Automations
http://thingsthataresmart.wiki/index.php?title=NST_Manager#Nest_API_Rate_Limits

1 Like

I have upgraded every time I got a txt notification and with the latest I was able to open the app one time and see the updates when I clicked to go in again it will not open

Thank you. I was concerned because of the bold section that states not to rely on ST for safety alerts, so I wasn’t sure if it disabled the nest alerts from Nest. I am going to attempt this soon and it will be my first try at adding something that is not just right in the smartthings app. Hopefully it all goes well.

I would like for this to control my home and away better than Nest does. Sometimes it takes hours for it to go into Eco mode. By using our phones as proximity sensors, hopefully we can do that. I realize I would need to change nest to not do that and only have this app do that.

The nest mode built-in automation will help you with eco setting based on ST modes.

A note to folks, most of you on v5, are running V5.0.2. If you are on 5.0.1 or 5.0.0, do update to 5.0.2. It fixes an issue that shows as tokenize in the IDE logs.

Any idea of how to correct this error? :confused:

c8a63e97-def3-4ff3-8831-f1169639eaf2 10:41:36 AM: error | NST Manager | nestResponse error - (Status: 400 - Cannot set fan_timer_active on/off due to incompatible mode) - [ErrorLink: https://developer.nest.com/documentation/cloud/error-messages#incompatible-fan-mode]

NST Automation question:

To have the fan come on only at low speed, when the heat comes on, regardless of whether is is in heat mode or auto mode, I have the following settings:

Run External Fan while HVAC is operating…
Select Living Room fan
Control Switches when: Heating
Thermostat Mode Triggers: Any Mode
Enable Fan Speed Control: On
Low: 80 (assume that this means when target is less 80 degrees away it will be on low)
Med: 90 (assume that this means when target is between 81-90 degrees away it will be on med)
High: 100 (assume that this means when target is between 91 - 100 degrees away it will be on high)

I realized that the numbers are off the realistic scale of the thermostat but that is my goal, so that the medium and high speeds are not used and the fan is always turned on at low speed when the heat is on.

Is there a better or preferred method of doing this? I had this working but when I upgraded to v.5.0.0 I got some errors (operator induced) and removed and reinstalled the entire NST Manager system from scratch to eliminate any errors.

The fan speed is determined as a temp diff from desired.

The further away from the desired temperature, the higher the fan runs.

So your settings

if tempdiff < mediumsetting, set fan to low

if tempdiff >=mediumsetting and tempdiff < high setting, use medium

if tempdiff >= high - use high setting

So your settings should work. You likely could choose 20 degrees for mediumsetting, and 25 for highsetting and get the same effect. All 3 settings (low, medium, high) should be set non-zero