SmartThings Community

[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(Guy) #3648

Part of my piston (2 posts up) is to use the ‘temperature’ . Is there a set time period that this device maintains?

I tried testing it set to ‘at least 2 minutes’ and it seems to fire…
When I change it to 5 days, it doesn’t. Both IF statements fail.


(Steve) #3649

Guy - I don’t think this evaluates based on history (though, that is what I thought the first time I used it too). The way I have seen it work would be: when the temp changes, EVALUATE, if temp greater than or equal to 65, wait for “5 days” or “the temperature to go under 65”, if you make it through 5 days, then fire the action(s), OTHERWISE (the else if), if less than or equal 60 …

you could test by doing an hour and see when it happens or even enable trace and see if it is sitting in a wait more there with a timer. Or you could use https://wiki.webcore.co/Weather and use something like $weather.almanac.almanac.temp_high.normal.F


(Guy) #3650

Thanks for the reply.

It is counting down right now.

I’ll have to give your idea a shot.

I think it should look at the forecast for the next 3 days anyway…


(Steve) #3651

How about this:

(thats the first time I have tried to paste a copy of a piston, lets see how it looks)


#3652

This has always worked great for me, then as of this morning, it just stopped. I’ve updated the device drivers and smart apps. Within SmartThings, it seems like it’s connected, but the information it shows when I click on the device is incorrect. For example, the Nest is set to 70, but it says 66. I’ve tried deleting the login info and re-entering, but still nothing. Anyone else having this issue?


#3653

I am having the same problem, stopped working this morning for me as well.


#3654

Same here. If it helps, I’m getting this repeated warning in the log: Manager: NST Manager (v5.5.8) | workQueue: busy processing command


(Eric) #3655

Go into the NST manager and hit done.

You may want to have a window open in “live logs” in the IDE to see if there are other messages.


#3656

Thanks but no go. It seemed to force one update and then nothing. Commands sent through smartthings don’t make it to the thermostat (which is presumably what the queue warning message was about). Will continue to poke through the logs but nothing jumped out at me. Any others seeing issues?


(Eric) #3657

The platform seems to again be having a bad weekend…

Two things

a) Go into your Nest mobile application, and see if any permissions are being requested (would show up as Messages). I don’t expect this to be the issue especially if you are using your own token).

b)

You can ask NST manager to reset all its state. In the ST classic mobile app:

NST Manager -> Application Preferences -> Logging -> “Reset Application Data”

Done /save/ next your way out, and wait about 1 min before doing anything else.

You can have a separate window on in the IDE live logging if you want to see the logs.

If this does not work (and you don’t see a clear error), Then the platform is in a world of hurt…

  • you could try re-authenticating your Nest login in the NST manager ( I don’t expect this to help)
  • you may end up having to re-install. We have over 10,000 installs, and we do see about 1 a week needing to re-install (they otherwise kept the software up to date) because of the platform getting stuck in some no-obvious way (I’m guessing losing some parent/child relationship).

Sorry for the troubles - we understand how frustrating it can be.


#3658

I tried doing the application preferences login reset. The device information did indeed get updated to the “real” values that are on the nest. However, if i try to change anything, i still get the same behavior: SmartThings thinks everything is fine, but none of the changes are reflected on the thermostat


#3659

I should also mention: Nest manager is not the only app having trouble this weekend. I have a device handler for my Kevo Plus written by kennelbound, and since yesterday morning, the lock shows up as “checking” in Smartthings. Like with nest, it works fine through Alexa. Don’t know if the two things might be related to a common server-side problem…


(Anthony S.) #3660

To those having issues

The cause is that ASYNC http requests are failing at the platform level.

It’s being dispatched to the appropriate engineer at ST and will hopefully be addressed soon.
I will post an update with I know more.


(Anthony S.) #3661

Issue Resolved:

The issues we are seeing should slowing start resolving themselves.
I want to say thanks to @vlad for investigating the cause and contacting @rappleg who fixed the issue in like 10 seconds


#3662

Mine is working again, thanks to everybody for getting this worked out


#3663

Same here. Both Nest and Kevo are working properly again. Thank you for your help.


(Guy) #3664

This is great! I really appreciate it.

I made a few tweaks to the time and added some notifications, but your solutions works like a charm!


#3665

Thanks all, working great!


(Christian Long) #3666

I just started getting these errors. I’m reading up and trying the suggestions but I’m just wondering if anyone else is having a problem since it reads like it should be resolved already and I am just now having the issues that others had a couple days ago.


#3667

I had problems again earlier today for a bit, but things are back working again. Might have been another hiccup.