SmartThings Community

[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

#3628

Is there anyway in WebCoRE you can see when the last connection from the nest server was? I’m hoping to notify when it hasn’t connected in XX days and/or send a refresh to try to jumpstart it. I just found that I hadn’t gotten an update on 2 weeks.


(Jason) #3629

Yes, the date and time it last connected is “lastConnection”. You can create a dynamic variable tied to this and then calculate the time since the last connection.

Edit:
Here’s a simple piston that should do what you’re looking for.


(Benji) #3630

What domain name are you using to get to the IDE…


(Jim Horlacher) #3631

I installed NST Manager for two locations and all is working fine however, just a few days ago I had to replace a Nest camera that failed. The replacement camera works fine in Nest however I am unable to see it via SmartThings. How do I get SmartThings to recognize/discover the new camera?


(Eric) #3632

Should be able to go into nest manager

Select “Manage / View Devices”

Nest Cameras

Select what you want, and done/save your way out.


(Jim Horlacher) #3633

That worked thank you. I tried it when I first replaced the camera with no luck. It was still picking up the old camera ID and date and time just before I replaced the camera. I checked the SmartThings IDE just now and noticed an updated connection date and time. I deselected the camera saved on my way out and then selected it and saved on my way out. Things are as they should be again. Thank you.


#3634

Hi,

Is there any variables/events for detecting if the temperature of a Nest thermostat is changed manually not programatically? if so, how can it be used?


(I Am Root) #3635

So I was able to make this work. I have just one Nest Device, its the Nest Thermostat.
How do i enable Nest Presence and Nest Weather? Is it a feature that comes wtih Nest thermostat? When i click on both the buttons, it says “cannot connect to device, check device and try again”. BTW the nest thermostat is perfectly working.


(Eric) #3636

The NST Manager app can create these, but it is important that you have already installed the device handlers (so it can do it).

After the DTH’s have been installed in the IDE, go into NST manager and enable them, and done/save/next your way out.

If you are still have problems, IDE logs are where to look. Mostly likely it is an installation issues that the device handlers were not installed/saved/published correctly.


(I Am Root) #3637

@E_Sch, thanks for your replies mate.
I wanted to report back, that I can view the Nest Presence and Nest Weather in “Smartthings Classic” app. Its showing fine in there. Just that the error pops up for these two virtual devices in the new Smartthings app. Is it normal? Or it shud work in both? If thats the case, why would it work on one and not on other if the settings are incorrect?


(Tony Fleisher) #3638

It is normal. Many custom device tiles don’t work in the new ST app.


New Smarthings App and NST Manager?
#3639

@MinerJason this is perfect, thanks! I was looking for last Connection but somehow missed it. I imported your sample and modified it for my needs and it’s working great, thanks!


(I Am Root) #3640

@TonyFleisher Thank you!!


(Scott Chapman) #3641

I have checked virtual devices for weather and humidity. But I do not see those devices in my device list?


(Keaton Hoskins) #3642

Can you expand upon what you configured with this and the lastEventStart trigger? Do you have screen shot of the condition you set for the motion trigger?


(Guy Renard) #3643

I am having trouble with NST manager connection to my thermostat. I have two thermostats: one upstairs and one downstairs. The downstairs responds fine every time but the upstairs will not. How do I reset the connection or the thermostat or is there something else I need to do/check to get this working? thanks.


#3644

I have a flaky installation of the latest configuration.

I have two location with a Nest Thermostat in each. Both locations have been online since the early versions of the Nest thermostat incorporation into ST.

My device handlers show what appear to be duplicate handlers.

I get update notices which do not disappear after updating. I get missed custom schedules, setpoints and HVAC changes. It seems like I have the old stuff still connected to my automations?

The Live logging shows several errors, including
NST Manager (v5.5.6) | NST THERMOSTAT DEVICE UPDATE REQUIRED: Thermostat 9DGwRhzuF9VifYHM8p3ScuDROURHfn0B (v5.3.1) | REQUIRED: (v5.4.3) | Update the Device code to the latest software in the IDE

My concern is that one of the thermostats is 500 miles away and I will not be there until March. I don’t want to bring the hub or other automations down.

Here’s my Device Handlers

How do I go about removing the duplicates to get the automations to be stable? Do I remove all Nest and NST and start over?


(Guy Renard) #3645

I removed the problem thermostat and re-added it into both nest and ST and it now seems to work.


(Guy) #3646

Hi, I was hoping to get some clarification on something.

See image to get an idea of what I’m doing.

I’m in the north east, so in the summer, I turn off my thermostats (they do not cool). In the late fall I turn the thermostats back on.

I have my daily eco/heat based on presence, which is working great. Now I want to do it for the season.

What is the difference between the custom ‘offbtn’ and the device ‘turn off’?

I’m not sure which to use.
Thanks!


(Eric) #3647

off() is the standard thermostat capability to turn things off, so I suggest you use standard capabilities when they do what you want.

Depending the the UI, some devices have custom commands, mainly for tile use / display.