SmartThings Community

[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(jkp) #3608

#3609

Harlan,

Once you see NST manager in ST. You will probably not able to get any of your devices added. It looks like there are not enough auth tokens available and will you get an error message "“Oops! We’cw encountered an error. Please try again.” after typing in your credentials… Let me know if you are able to… I am still waiting for an answer on this issue.


(Jason) #3610

Did you create a nest developer account and create your own auth token as described in the instructions jkp posted just above?


#3611

Hi Jason,

Was the reply for me?


#3612

Hi Everyone. I was able to make it work. I had to redo the and update my token. Happy Holidays!


(Harlan Lau) #3613

Once I followed jkp’s detailed instructions creating the Nest token and updated my token’s URL and permissions, I was able to login to my Nest account.

A few suggestions regarding jkp’s instructions (not complaining, just pointing out what caused me problems):

  1. the link the Nest Developer Portal should be updated to https://console.developers.nest.com
    I had to google to find portal and wasn’t sure I was in the right place, especially when the portal said
    they were not issuing tokens.
  2. change the Support URL and Default OAuth redirect URL so they are not links and can be easily copied.
    I could not figure out how to copy them from PDF. So I clicked on each link, then when page opened,
    I copied the URL from the address bar. Unfortunately, for the redirect URL, this is different from
    https://graph.api.smartthings.com/oauth/callback in the PDF.
    Consequently, I got the oauth redirect URL failure.
    I handcopied the redirect URL into the nest token and I was able to login to my Nest account.

Thank you to everyone who responded with helpful advice!


(Scott Chapman) #3614

Yes your Nest account credentials to log in.

Look in the smart app you’ll see a spot to inset your client ID & secret.


#3615

For some reason motion wont trigger on device handler, it says no motion no matter what.
Is it because my camera is private? Or is it something else I need todo to make motion work?


(Eric) #3616

Motion relies on the stream service. Do you have that enabled?


(Stefano Landi) #3617

Hello, i just tried to add NEST integration. I followed all the steps but when I went in the marketplace/MyApps, I get 2 errors respectively for NEST Manager and NST Automations

; Did I miss a step? thanks for any help.


(jkp) #3618

Look in the Automation tab for NST Manager :slight_smile:


(Stefano Landi) #3619

I went in the Automation tab of the Classic App and under MyApps, I get the same error as if I go to Marketplace. In the new App, if I go under Automations, I dont see NST Manager. Sorry but what am I doing wrong?


(jkp) #3620

Did you save and publish all 3 Smartapps and 5 device handlers you installed in IDE. And enabled OAuth for the NST Manager smartapp in IDE?


(Anthony S.) #3621

Maybe this will make the install process easier for you.

http://thingsthataresmart.wiki/index.php?title=Community_Installer_(Free_Marketplace)


(James Runde) #3622

I get the below message when I tried to create a Nest developer account. Is there a way to use NST Manager without a developer account?

“Thank you for your interest in the Works with Nest program. We’re currently restructuring our developer program and are no longer accepting new developers to the program or performing client integration reviews for existing developers until the new program is implemented. Stay tuned for further details and announcements.”

Jay


(jkp) #3623

(Stefano Landi) #3624

Thanks for the help. I installed the FreeMarketplace and I saw all the available apps. I installed (successfully) the NST mgr

When I then go to MyApps I can see NST Automations and NEST mgr (as well as ST Community installer).

but when I launch Nest Manager, it gives me the same original error.

Any idea? thanks


(Stefano Landi) #3625

I was able to figure out the problem … I had not created the Nest Client ID. So I was able to launch NST mgr as well as login to my home NEST account. All looked fine however it say “No devices found”. I have 2 working NEST Thermostat which I can see/use/control from my Nest iphone app as well as from online. Any reasons why they would not show up in NST mgr? thanks


(Eric) #3626

ensure you use the primary nest account for initial access.


(Chip) #3627

Having some trouble getting this installed.

I installed through the community installer, then went through Nest Developer steps, only to get to the IDE step and can’t find the app listed there. Any ideas?