SmartThings Community

[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(Anthony S.) #3586

Are you receiving any errors in the logs?


(Roger) #3587

Seems to work for me, but is there a way to make the Nest thermostat respond faster? It’s like 3-5 minutes from when I change the temperature in ST until the thermostat updates.


(Anthony S.) #3588

sounds like nest or St issues. The delay should be at most 5-6 seconds


(Patrick Mjoen) #3589

Sent in message to you


#3590

My nest thermostats started acting strange in ST, the temperature updates correctly but the humidity is not, and if i try to change the target temperature in smartthings it doesnt update on nest web client/app. I checked oauth, nest dev account permissions, resetted nest token and relogin… nothing… any ideas?


(Eric) #3591

IDE logs, and enable remote diagnostics.

If you still need us to look, send the URL as private message.


(Patrick Mjoen) #3592

@Scott_Chapman I ended up deleting all smart apps and DTH for this and used the community installer for it now is all working.


(JB) #3593

I have a question about the weather alerts. I am trying to find out how NST Manager gets the information that it provides in the notifications whenever there is a weather alert in my area.

Warn: WEATHER ALERT: …Significant weather advisory for patchy freezing fog across {location}. Patchy freezing fog still exists across {location}. However, temperatures across the area are starting to warm back above freezing. A few slick spots on roads across the area are possible through 10 am. Stay tuned to NOAA weather radio or a favorite local media outlet, for further statements or updates…

It appears to grab the information from the National Weather Service, but I’m trying to learn how. I would like to have this information read aloud via webCoRE and LANnouncer, but I’m having trouble getting the data into webCoRE.


(Scott Chapman) #3594

Wait, which one?


(Patrick Mjoen) #3595

There is a community installer app that allows you to install 3rd party apps without messing in the IDE


(Scott Chapman) #3596

Sorry, do’t think I’ve seen that… Where can I find info on it?


#3599

Hi Anthony,

So i’ve recently updated my nest credentials to a different email and password. When I am trying to access the NST manager to add my nest smoke alarm, it is giving me an error of “Oops! We’cw encountered an error. Please try again.”. I’ve been trying to log in and still no luck. Do i need to update any of the configs on the Nest Portal or ST IDE?


(Scott Chapman) #3600

So just to update what I did.

  1. Uninstall existing devices, device handlers, apps
  2. install community installer
  3. install nst manager
  4. get my client ID & Secret from nest portal
  5. run NST manager
  6. enter credentials

All works!


#3601

I still cannot add any of my Nest devices to my ST AP. Ive deleted and re-installed back NST manager and installed the community installer. The NST manager is still not taking in my Nest credentials… a screen shot of the error message is attached.


#3602

@tonesto7…so after reading up more on this issue i did find out that issue is with no auth tokens. Is there an update on getting more? appreciate the help in advance!


(jkp) #3603

Did you set up your nest developer account?


#3604

Yes, i did. i was able to get my client id and client secret codes


(Harlan Lau) #3605

I just installed NST Manager from scratch, following the detailed instructions on the wiki page.
I used github integration to install Nest manager and NST Automations, the community installer and all the nest device handlers.

I did OAuth for the Nest manager and community installer, but not NST Automations.

Everything looks okay from IDE side, but in the ST Classic app, nothing shows up in Marketplace > My Apps

I followed the link to make sure I’m in the right shard. Plus all my other SmartApps showed up under My Apps.
I even installed another SmartApp and it showed up in My Apps so correct shard.

I went through the Troubleshooting section.
I just updated from Repo so I have all the latest code.

I don’t think I need a Nest Token since I can’t load the Nest Manager smartapp.

But I followed the instructions and created an OAuth at the Nest Developers Portal.

Any suggestions as to why nest manager doesn’t show up under My Apps when it shows up on the IDE under my SmartApps? (I’m sure I’m in the correct shard)


(Harlan Lau) #3606

I downloaded from GitHub. I didn’t realize you had to open each app and handler and publish them one by one. Once I published, the nest manager appeared under My Apps.

I’m trying to install nest manager and I can’t login to my nest account.

I authorized OAuth for the nest manager.

I entered my nest token under settings in the nest manager

The error is:
redirect_uri mismatch
The URI in the request does not match the ones authorized for the OAuth client. Visit the Developers Console to update the redirect URI.

When I was requesting the nest token I had no idea what redirect URI should be. I either left blank or entered garbage. What should it be?


(Harlan Lau) #3607

Scott,

When you set up NST manager, what credentials did you use to login to Nest? Your personal login?

Where did you use the Nest token’s client ID and secret?

Where did you use the NST manager’s OAuth client ID and secret?