SmartThings Community

[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(Anthony S.) #3525

And it generally works extremely well… The only issue is occasionally after iOS updates i need to open the WebCoRE app on my phone and it’s fine again.


(Jason) #3526

Just an FYI- found a potential bug in the automation smartapp. I have an automation that uses remote sensors for temperature. When I switched the remote sensor from cool only to auto it crashed (stopped loading the automation in smartthings). Error in logs was: groovy.lang.MissingMethodException: No signature of method: script_app_fe48ee0a8b7b7202ba4c032a7054929af449e840713139abd0304dbeb3626abd.fixTempSetting() is applicable for argument types: (java.lang.String) values: [67.0]

I went through the code and added toDouble() to all the calls to fixTempSetting() for heat temp and that fixed it. Not sure which one was the culprit.


#3527

Does this NST manager support Nest Hello doorbell? Or any other way to add it to SmartThings?


(James Casteel) #3528

I’ve managed to get my Nest Hello added to SmartThings, however, whenever I try to stream the video ST crashes. I can remove the device, re-add it and it appears online but soon as I try streaming again it crashes and continues to crash every time I look at the device until I remove / re-add it.

I did go and set up the video URL in the device handler, I also validated my permissions in NEST to ensure I have read/write on my camera. Any suggestions?


(Chad Buckyman) #3529

FWIW, I noticed that my graphing for my Nest integration (thermostat, and virtual weather device) started having issues on Nov 4 at 6:00 am. I’ve been going in saving, and closing in the Nest Manager SmartApp, and things will work again for awhile. Prior to that is was rock solid since I set everything up in February 2018.


(Brent Haag) #3530

@clensert, what are you using for your graphing presentation (sorry if it’s been asked to you before)?


(Chad Buckyman) #3531

I use Grafana, with InfluxDB. There’s a great write up on it here.

https://community.smartthings.com/t/smartthings-data-visualisation-using-influxdb-and-grafana/44946


(Jason Nielsen) #3532

I apologize if this has been answered but I couldn’t find the specific answer in the message board. I am behind on updating the new updates. I updated and got the client id and secret and updated in the smartthings IDE. However when I go to the NST manager automations in smartthings it mentions I need to login with my nest credentials. When I try to login it says Oops! We’ve encountered an error. Please try again. Login and password are correct.

Any help would be appreciated. As a sidenote I don’t believe I have the most recent version. I am currently using 5.2.3 and not sure if that is why.


(Jason Nielsen) #3533

I am still running into this issue, as of right now I have.
-Uninstalled NST Manager and re-installed it on IDE (all things show as published for me).
-Verified client id and client secret are correct in settings in IDE.
-Verified I have the 9 permissions labeled correctly (per the written procedure) in nest developer portal.
-Unistalled smartthings app and re-installed.

I assume I am missing something dumb, but I have followed procedures and don’t see anything that jumps out at me as something I missed. Sorry for double post, but I woke up today and tried a few more steps and thought I would try to elaborate more on what I have tried to do to remedy. I have read through the prior messages on this issue and have tried several of those suggestions as well, but had no luck.

last thing I was thinking about redoing was to just create a new OAuth (remove one I created) in developer portal for nest. Any thoughts or advice would be appreciated.

Thank You
jason


(Kostas Petropoulos) #3534

i install nest Manager from first time
I install all device handlers and smart apps and I enable the Oauth on smartapp Nest manager
even if take the id and secret on api smarthings page on the app / smart app nest manager does not take it automatically so I go and I add manually the id and secret on smart app oauth page

then works on app…
now ask for nest account but after that says the same msg as you
Oops! we have encountered an error. Please try again later
version 5.5.6

I create developer nest account the same as the normal one
no luck…

anyone can tell me what is going wrong? I using UK version smartthings v2

EDIT
I read that developer says that because have create more than 7500 tokens is better to create my own token on developer account (OAuth)

but right now the nest does not allow for some weeks to do that because they updating the site or something like that…


(Eric) #3535

Nest will allow you to create new account and token. They are not accepting reviews (which you are not doing). So if you login, you should be able to “Create new OAuth client”.

You should only need 1.

As to folks with other errors, logs from the SmartThings IDE is best place to start. Typically oauth was not enabled on the NST Manager app, or some permission or callback is not set correctly in the nest developer site.


(Kostas Petropoulos) #3536

Sorry, you are right the review does not work so when I create OAuth client and use the new id and secret finally everything work

But I have UK thermostat that have heat and hot water but no hot water on SmartThings


#3537

Did you ever uncover a root cause / identify a solution? I’ve been having similar problems where the SmartApp just stalls on making mode updates or logging data (I have a similar Influx setup).


(Chad Buckyman) #3538

I uninstalled and reinstalled the smart app, and it seems to have helped for me.
The installation process has been updated since I did it initially, so I figured it didn’t hurt to try that first. It’s been updating regularly since.


#3539

So does NST manager allow you to add Nest hello doorbell to Smartthings?


(Eric) #3540

I thought folks have said here that the doorbell shows up as a camera in the nest API (I don’t have a doorbell so I cannot confirm).

That is where I would look once you add it.


(Anthony S.) #3541

You are correct it does show up as a camera


(Adi Thorny) #3542

Apologies if answer is obvious but had no luck finding it.

I got the error:
Client ID and Secret are both missing. I clicked on the web-link in the app but got a message “error saving page”.

I understood this to be the problem that I needed a Nest Developer Account. I created an account but see they are closed for new products, only available to create an OAuth client.

I presume there is a way through this but can’t find an answer. Would appreciate any direction. Many thanks.


(Tony Fleisher) #3544

If the problem is updating the settings in ide, try it using an incognito/private browsing window.


(jkp) #3545

I believe he is saying he can’t get the ID and secret from the nest developer account