SmartThings Community

[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(jkp) #3422

(Ron Warris) #3423

My NST setup stopped working this morning. When I tried to reset the token in the app, I am seeing this message:

Nest Developer Data Missing. Client ID and secret are both missing!

I went through the setup procedure to create a new Nest Product in my Nest Developer Account, however, it looks like things have changed somewhat since the instructions were created.

I was able to sort out the changed setup and complete the creation of a New Product, and updated the clientID and clientSecret values in the IDE, but the phone app is not seeing these changes. Tried a couple more times with no luck.

I wonder if Nest has changed something?


(Ron Warris) #3424

After trying several more times, I was finally able to reconnect my developer account to the NST SmartApp.

Very odd.


(Tony B.) #3425

This is odd. Temperature changing by routines and webCoRE works but, I can’t change the temp on the tile.

Any idea why this would be?


(Tony B.) #3426

A little more on this;

If you touch the slider that is below the lower set temp (the one with the up and down arrows), that allows you to set the temp. This is probably a small goof somewhere in the code for the tile.

I could probably fix it myself :wink:


(jkp) #3427

Android or iOS?


(Tony B.) #3428

Android

It’s definitely adjustable with the slider, I tested it and was looking at the logs when testing :slight_smile:


(Felix Pau) #3429

Has nest manager up and running for a while, just tried to add a 3rd nest protect, went to nest manager and couldnt get the authorization page to load and been poking around all the instructions for the last hour.

Any hints why I cant get to the authorization page?


(jkp) #3430

to add additional nest devices, you need only to go to Manage/View Devices in NST Manager :slight_smile:


(Felix Pau) #3431

Thats true but the first screen wouldnt even load when you click through the app.

Update: So I got stuck at the uninstall stage for the app. Dug through the entries here and finally used the hub location > smartapps > edit > uninstall > done method

Reinstalled from scratch, all up and running again

Thanks!


(Dejovas) #3432

Looks like Nest secret codes etc. aren’t available for the time being… Installed with community manager and went pretty flawlessly, ran into an unrelated issue because my github account needed an updated password. Other than that pretty smooth so far…


#3433

Does anyone know how I can turn off most of the log entries shown in my activity feed from NST Manager? I’ve tried turning off most of the ones I can find in the various options of NST Manager but my feed is filled all day with this stuff. I don’t need to see the “Last Connection” ones and as you can see some of the events like the heating at 2:59PM are listed twice, one with a green circle and one blank. Other unwanted logged events include “Device is idle” and “Ambient Temperature is X degrees”.


(Eric) #3434

A general public service announcement:

  • we see most folks updating successfully and correctly NST Manager and associated components.

In a few cases, we see folks only updating NST Manager (but not the DTH’s or Automations).

It is important when updating, to update all components for the release.

  • This is most easily done using the community installer
  • It is pretty straightforward if you use github directly, just need to ensure to update the smartapps AND the DTHs
  • doing this manually works, but requires one to carefully update each / all components - so this can be error prone in that you may forget / skip some step or component.

It is important to be running the current release - in the notes above ST made platform upgrades (including to groovy compiler) that require running latest code to avoid errors, failures, etc. These platform upgrades were “pushed out”, so many different apps (including NST manager) were caught by some of the language / compiler changes.


(Johnny2678) #3435

This won’t be helpful at all, but wanted to give an update.

Around 5.4.x release, there was a bug that inadvertently deleted virtual thermostat devices. They weren’t re-added until you went into each automation and re-saved. This was problematic because the devices were also removed from any apps that may have used the vThermostats (webcore, actiontiles, influxlogger, etc), so you also had to go into each of those apps and re-add the devices.

@tonesto7 and @E_Sch acknowledged the issue here [RELEASE] NST Manager v5.0 and then the issue was fixed around Aug 20th. I took at least 2 releases post-fix with no issue. vThermostats were not deleted and I didn’t have to go into other apps to re-add devices.

Today, I took the latest update (5.5.2), installed via community installer. After installation, 1 of my 2 vThermostats were deleted, forcing me to add it back to all other apps, the other persisted. Of course, this makes no sense - why would only one of the two get deleted? I thought we were past the bug so I didn’t capture any logging, sorry about that. Just wanted to report what I was seeing.


(phil) #3436

Just looked at mine and one of the three are no longer there…Crap this is going to be a pain

What is interesting when you go the the Tstat that it is associated with all the automation is still there.

Just figured out how to get it back. Go back to the original Tstat. Go into like you are going to creat a new tstat and Mine was still there. I made a change, saved it and it was back on the list. Went back and change it back and save it again and now it should show back up


(Johnny2678) #3437

I got it back that way too but still had to re-add it to all of my other apps (ActionTiles - which is the biggest pain because you have to remove the old, dead vThermostat and replace with the newly created one, InfluxDBlogger, and WebCore.)


(Tony Fleisher) #3438

I just realized that the thermostat integration hasn’t been working for a few weeks. I went to login to nest developer console and had to accept new t&c, and after accepting, it started working again.


(Yash Gupta) #3439

Hi Mark,
I’m getting a similar notification as well on my iPhone using smartthings classic app.

Nest Manager Update(s) are Available:
Presence: V5.4.2
Thermostat: v5.4.2
Weather App: v5.4.2

Please visit the IDE to Update code.

from my desktop, I have gone and updated the code from repo.
On mobile, in the smart things app>Automation>NST Manager I see Nest Manager version 5.5.2 Updated: 09-19-2018

The notifications still keep on coming. How do I rectify this?


(Kirk Hilzinger) #3440

Did you click on the checkbox to publish those updates? That has skunked me a few times.


(Eric) #3442

Those notices are asking to update the dth’s for nest manager (so you you did the app, also update the device handlers)