[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(Ed) #3179

I have the same issue. Where do you add the storage app? Thanks.


(Erik) #3180

@impee once I added and published the storage smartapp everything worked fine.


(David Currie) #3181

Thanks to tonesto7 for this great code! I am new to Nest Manager and am installing the latest release for the first time. I am having a few basic problems installing the code into Smartthings IDE.

  1. I used my current github integration to do the installation.
  2. I clicked the publish checkbox and installed all three modules (Manager, Automations, Storage).
  3. I went to enable OAuth and I got a 505 error message “You do not have permission to view this page”
  4. I tried to delete them and either got the above of a 500 Internal Server error.

So, I’m stuck before I’ve started unfortunately. Has anyone else encountered these issues?

  • David

(jkp) #3182
  1. make sure to login to https://account.smartthings.com to access IDE.
  2. try using an incognito/private tab when logging in,

(David Currie) #3183

jkp, Incognito window did it! Thanks! No idea why, but it worked.


#3184

Thanks all, after installing the Storage App, it started to work again :slight_smile: Phew, after 2 days of trying this that the other :slight_smile:


(Anthony S.) #3185

I’m very sorry for all of the trouble caused by this…
I made a bad choice in deploying the storage app the way it did.

This will soon be resolved in an upcoming release


(jkp) #3186

@tonesto7 Just got the message that there is an update for NST Manager (v, 5.3.8). I updated and now when I attempt to open a cam device, the ST app crashes. Nest Protect and Thermostat devices open fine. I have live logging open but no error messages show.


NST Manager Camera crashes
(Anthony S.) #3187

Android or iOS client?


(jkp) #3188

iOS plus more text to get 10 characters


(Graham) #3189

Tried uninstalling completely and reinstalling and I still get the Client ID and Secret are missing but the “settings tab is greyed out still”

Settings
Add setting definitions in the source code and then set the values here


(Anthony S.) #3190

Did you use the community Installer? I swear i fixed that


(Graham) #3191

I read up and someone had a similar issue, I had to save and publish (the NST manager smart app) 3 times, on the 3rd time it allowed me to put the settings in. (Just now!)


(Anthony S.) #3192

That is very weird!
So you did use the installer?


(Graham) #3193

Sorry, yes I did use the installer,

no idea why that worked, first two times the settings tab was above, on the 3rd publish for me the input boxes appeared.

If it helps I haven’t finished I can delete an try again to help debug.


(David Currie) #3195

Hi there! I am new to the NST-Manager. Here is my problem and how I got there:

  1. Had installed version prior to current one 5.3.8 and added two thermostats successfully and configured the Nest developer API stuff and the NST-Manager app. No problems
  2. For some reason, my Android app was not able to access my Thermostats. Kept getting the error message, “Cannot connect to device. Check device and try again.”
  3. I then noticed that I had enabled O-Auth for the NST-Automations app, which the instructions clearly say not to do!
  4. I then proceeded to try to delete the app, was able to delete NST-STorage and Automations, but not manager (tried IDE via locations, via SmartApps, and the Android App, all to no avail. I was planning to reinstall everything.
  5. I gave up on the idea and updated the apps and reinstalled the lastest NST-Automations child app. I also updated all the device handlers as well.

Now I have a problem in that the app opens and I see the “New in this version” page, but I get a long wait (whirling circle animation) followed by “Network or server error occurred. Try again later.” It’s been doing this for a while, so not sure how to resolve it. Ideally, I can delete everything and start over, but the system prevents me! Feeling very stuck here.


(David Currie) #3196

Update: I was able to completely uninstall and used the community manager to reinstall. I did not see the app in my automations page, so I added it in the old Smarthings app and got the error that the Client ID and Secret were missing. I went to the app in the IDE and tried to find where to enter it, but those Settings aren’t there! Help!


(David Currie) #3197

Further Update: I did a fake update and publish on the NST-Manager app in the IDE, and then I was able to see the setting and enter the info. Things seem to be working well in the Classic app, but I can’t get the new app to allow me to access any of the devices (Thermostat’s, Weather App, or Presence app). They show up, but it says they are disconnected. “Cannot connect to the device. Check the device and try again.”


(jkp) #3198

No custom code works in the new app at this point


(David Currie) #3199

@jkp I haven’t had any trouble with other custom smart apps as long as I instantiate them through the classic app. Once I instatiate, everything else works great. It’s just NST-Manager I am having trouble with.