[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(Mr.T) #3139

Hmm, I tap through to this location. I have the option for NST Manager to update device names, but I can’t tap the devices. They show, but are not selectable.


(jkp) #3140

Did you enable assign custom names at the top of that screen?


(Mr.T) #3141

Well of course not. That would require some degree of intelligence on my part :confused:

Works now :wink:

Thanks


#3142

Nothing on my problem :frowning:
I fallow this guide exactly but no lock is error on smart app about Client ID: and Client Secret

“Using Git Integration
Enabling the GitHub Integration in the IDE is by far the easiest way to install and get the latest updates for NST Manager, Automations, Presence, Protect, Thermostat, and Weather devices.
To enable Git integration (one time configuration) under the IDE please visit here for instructions: IDE GitHub Integration Instructions”


(jkp) #3143

Did you set up your Nest Developer Account?


#3144

No
Do I need that to make it work?


(jkp) #3145

Yes, it is required


#3146

Is asking me about company name and company url I do not have that
Maybe I’m on wrong webside


(Borristhecat) #3147

Just make it up


#3148

ok thx will try :slight_smile:


#3149

Thank you guys very much is all working now :grinning:


(Eric Sims) #3150

@tonesto7 Really enjoying this app integration, especially with my action tiles. Have you been able to find a way to add the Nest remote sensors?

Thanks!


(Eric) #3151

Nest has not added their remote sensors to the API yet. So we are not aware if they are there (or not), and we cannot report anything about them at this time


(Scutzi128) #3152

Does this also work with the Nest Hello doorbell? Specifically I’d like to be able to trigger other actions when the doorbell is pushed.


(Anthony S.) #3153

The simple answer is no… Nest seems to really drag their feet when it comes to API changes. They didn’t even add any access to the temperature sensors yet


(Kevin) #3154

I keep getting notifications that there is a new version: v5.3.7 but when I go into my IDE and check for update it shows no updates. I’ve used github integration with WebCore/core and it has always worked for me. Any ideas what would cause this?


(jkp) #3155

After updating in IDE, did you open NST Manager in the ST app and click Save at the top?


(Graham) #3156

I recently decided to try to re-install NST manager (had it previously but had various issues)

I followed the instructions, its published, Oauth is enabled, I have a Nest developer account with it setup.

I can’t open the app on market place as I get
“ClientID and Secret are both missing”

So reading the thread here I go in the in IDE, edit the app but under settings I can’t add the clientID etc as it says

“Settings
Add setting definitions in the source code and then set the values here”

So can’t input anything at all. Any ideas?


(Anthony S.) #3157

Did you use the community installer to install it?


(Graham) #3158

This time I did yes

I also tried removing everything and adding from from code and got the same result.