[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(jkp) #3099

Just checking… you entered your client ID and secret in the right column? The field names are in the left column. Just asking because many users have attempted to enter the data in the left column over the field names.


(Nick) #3100

Thanks for the reply, and yes they are in the “Value” column, to the right of the “Name” column.

In the Oauth section I tried to refresh the ID and secret to see if that would jog anything and got the same error page. It’s like I’m not allowed to make any edits to the Smartapp in the IDE.


(jkp) #3101

Try logging into IDE @ https://account.smartthings.com using a incognito/private tab in your browser.


(Nick) #3102

Sweet, I think that worked! Thanks for the tip.


#3103

FYI the community installer did not auto install the NST storage with the latest release.


#3104

After installing today’s updates to the SmartApp and DTHs I can no longer open the SmartApp in the ST mobile app. No errors - it just does nothing when clicked.


(jkp) #3105

did you install the new Storage smartapp? :slight_smile:


#3106

That was it, thanks. I guess I missed that memo.


(Mr.T) #3107

Does storage app need to be published?


(jkp) #3108

Yes, I believe so. I published mine


(Michael Stroh) #3109

FYI, updated today via IDE without any problems. I did notice that the update information when opening the device in the ST app shows a release date of “January 31st, 2018”


(jkp) #3110

V5.3.7 was released May 31, 2018. Are you on the beta channel by chance? I was and needed to switch back to the master channel to get the update. :slight_smile:


(Michael Stroh) #3111

tonesto7/nest-manager/master is the repo I used this morning to update. The update in the repo included all the device handlers, the two smart apps, as well as a new storage smart app.

Line 16 of the thermostat device handler code is “def devVer() { return “5.3.5” }”

The nest manager smart app code indicates version 5.3.7 with a May 31, 2018 date.


(Megan) #3112

did the update today via IDE/GitHub. It did not install the storage app, I had to do that manually and when I open the thermostat I get

3:13:23 PM: error groovy.lang.MissingMethodException: No signature of method: physicalgraph.device.DeviceTypeExecutorBase$_closure5.doCall() is applicable for argument types: (java.lang.String, java.lang.ClassCastException) values: [graphHTML Exception:, java.lang.ClassCastException]


(jkp) #3113

Can you open the NST Manager smartapp and click save?


(Megan) #3114

Yeap tried that


(jkp) #3115

you updated the device handlers?


(Megan) #3116

yeap i did


(Eric) #3117

would be good to see logs as a private message (or if you can enable web diagnostics).


(Megan) #3118

that was the log from the IDE I posted