[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

(Eric) #3079

I suggest you go into nest manager in the ST mobile app, and hit done.

Nest had a couple of outages this week…


(Tom Johnson) #3080

Just figured it out. My NST Manager update, wasn’t published in the IDE…doh! User error. This s#$t is complicated!


(Daven Maharaj) #3081

Works great for me…Took a little time and attention to setup but the wiki and instructions were great.

Thanks for creating such a much needed solution to the Nest thermostat!


#3082

My notifications have not been working so when i checked my mobile app, it says “Click to enter Nest Credentials” so i do and this is what i get …
{“error”:true, “type”: “AccessDenied”, “message”: “You are not authorized to perform the requested operation.”}

I’ve updated to 5.3.5 (i couldn’t find 5.3.6)

Any help would be greatly appreciated!!


(Bartlomiej ) #3083

Hello friends,

I run into some problems. I follow the wiki to the teeth but for some reason, I am getting an error.
“Error: redirect_uri mismatch The redirect URI in the request, https://graph.api.smartthings.com/oauth/callback, does not match the ones authorized for the OAuth client.
Visit the Developer Console to update the authorized redirect URIs.”

I created my developer Nest account and copied Id and secret in settings under Smart Things APP.
Enabled Oauth

What should i put under Redirect URI: (optional)

Hopefully its something small. Appreciate your help.


(jkp) #3084

Make sure there are no empty spaces before/after the URL when you copied in your nest developer account.


(Bartlomiej ) #3085

Yea, i checked that before. Is the Authorization URL provided in Nest Developer Overview is what I put under Oauth Setting Redirect URI: (optional)?


(jkp) #3086

You are entering the data into the wrong section. You are trying to enter it into the Oauth section but the client ID and secret should be entered into the settings section.


(Bartlomiej ) #3087

Oh no, I put id and secret into settings section. That part in Oauth section is greyed out. What I am trying to put in Oauth section is Redirect URI: (optional). But I don’t know which link goes there. I am just trying to follow the error that its showing me after i log in to Nest account in the phone app.


(jkp) #3088

Nothing goes in the Oauth section.


(Bartlomiej ) #3089

I see, But when i put nothing there I get this error in the app after Nest login attempt.

redirect_uri mismatch The redirect URI in the request, https://graph.api.smartthings.com/oauth/callback, does not match the ones authorized for the OAuth client.
Visit the Developer Console to update the authorized redirect URIs.”

That is why I was trying to fill in Redirect URI: (optional) under Oauth section.


(jkp) #3090

I would suggest checking everything in your nest developer account again.


(Bartlomiej ) #3091

Thank you. I appreciate your input. I will try to set up new OAuth Client and see if that works.


(Bartlomiej ) #3092

That was it. I appreciate your time. Thank you very much. have a great day.


#3093

Ran into an odd one today. I’m on the Gulf Coast of FL being hit by Alberto. Shortly after the 2PM update, NST manager started going crazy. Every 30 seconds, ST was throwing errors “Cannot remove device as it is in use …”. When I started chasing the logs, I found NST manager appears to be choking on the alerts issued associated with the Nest Weather device. Error in the log is:

2b2f96b5-1f9d-45d8-b081-8b7cab712543 3:18:05 PM: error getWeatherConditions Exception: physicalgraph.exception.StateCharacterLimitExceededException: State cannot be greater than 100000.0 characters @line 5629 (getWeatherConditions)

I would be fine with the weather/alerts not updating, but this has a trickle down effect & causes streaming to go offline and the struct data to NULL out. This cause NST manager to attempt to remove all Nest devices it believes are no longer associated.

I’ve worked around it temporarily by removing the Nest weather device, but thought I would pass the info along.


(Tom Johnson) #3094

Same thing happened to me. I’m in Tampa FL and my NST manager started flipping out on me sending my wife and me multiple notifications every minute. I got the “cannot remove device…” message as well. Thank you for the fix!


#3095

The same thing happened to me in Tampa. Every minute it was alerting.

Also, for the last 3-4 days, it’s not coming out of Eco mode when WebCoRE tells it to. Where would I begin to troubleshoot that?


(Eric) #3096

I have an updated code into Tony that trims alert messages that are long. Once Tony pushes it this should make things better.


#3097

Thank you very much!


(Nick) #3098

Hoping someone smarter than me can help me get the private token working.

I created the Nest Developer Account and followed all the steps on the Wiki. After entering the the Product ID and Product Secret in the appropriate Settings fields in the IDE, I get the following error page after clicking update:

Any idea what to do?

This isn’t a new NST Manager installation… I had it before, it stopped working to the token issue, and I’m trying to get it working again. I have the Oauth section in the IDE completed but not sure how that relates to this new ID and Secret in the Settings section. My NST Manager and Device Handlers have been updated to the latest.

Thanks in advance, and I apologize if this has already been asked before in this lengthy thread.