[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

#3059

I made a couple updates to my post above from 6 days ago. Please scroll up and read that. You can also goto the link and then also look thru the community out there to see updates for the same questions others have posted directly to Nest. :slight_smile:


(Matt Dunning) #3060

Thanks for the response. I saw your post but was hoping someone may have found something. I did do some additional searching over on the nest developer forum and found this thread. Looks like api updates are in the works but no word on when they will be made available.


(stephen) #3061

hey guys i need help! i changed nest accounts to a new email set everything up perfectly except for smartthings! it won’t let me log in im so confused i keep getting this error message, anything?


(jkp) #3062

Are you using a nest developer account?


(stephen) #3063

I think so, how do I find out? I did change emails so I could have forgotten to change my nest account.

-Stephen Parrish


(jkp) #3064

https://console.developers.nest.com/


(stephen) #3065

So I got it to login but none of my devices are responding

-Stephen Parrish


#3066

Have you figured out your notification issue? I’m having the same problem.


(Ophir Bamani) #3067

no, I don’t get any motions events…


#3068

I was wondering if someone could help me. I’ve got version 5.3.5 installed but when I look in the app it says that I’m on 5.3.4. Any idea why?


(Benji) #3069

I know this isn’t exactly the right place to ask but, out of curiosity, is anyone in here a “Nest Pro”?


(Jacob W) #3070

Can anyone help me with this issue posted over here?

I can’t access my SmartApp because it just gives me this message:

Update: Problem solved with new update released.


Adding Nest to SmartThings
(Chris) #3071

Hello, I used to have this working fine but one day I received errors and created my own nest developer account. When I follow the steps to goto settings for the Nest Manager Smart app (I used the community installer to reinstall) I get this error:

“Add setting definitions in the source code and then set the values here”

There is no place to set my nest developer account information that I created. Any ideas what I missed? I completely removed all Nest manager pieces from my account before I reinstalled.

Thanks,
Chris


#3072

Last time I ask, I’ll give up after this, I promise.

I’m using Real Time Events and MotionPerson never goes active, only inactive. Bug?


(Chris) #3073

Not sure what happened, I believe there was an update to nest manager and then my settings appeared. I was able to enter my nest developer account details and it is working again.


(Johnny2678) #3074

For Automation schedules, the first one to meet the criteria gets applied, correct?

Is there a way to insert a schedule? I need to make a new #1 priority schedule but I already have 4 schedules in place - hoping I don’t have to delete and recreate to get them in the right order.

TIA!


(hjro) #3075

Hi. I just got a notification saying the was an update to NST Manager 5.3.6

How do I go about updating to this?


(Jeremy) #3076

Hello all, I just went through and setup NST Manager, following all of the directions from start to finish, but I’m unable to add the app from the market place and I’m getting the following errors in the IDE Live log and similar errors on the mobile client:

|| Nest Manager | getTimeZone: Hub or Nest TimeZone not found
|| Nest Manager | SmartThings TimeZone is not set; Please open your ST location and Press Save
|| Nest Manager | SmartThings Location not returning (TimeZone: null) or (ZipCode: null) Please edit these settings under the IDE
|| Nest Manager | Status Message: SmartThings Location is not returning (TimeZone: null) or (ZipCode: null) Please edit these settings under the ST IDE or Mobile App

I’ve checked and I have location and timezone configured on both my nest account and my smartthings account.

I’ve done a lot of searching and it seems this issue is either related to improper client_id or secret in the NST SmartApp settings, oauth not being enabled, or from publishing on the wrong shard.

I have triple checked my client ID and secret are entered correctly, oauth is enabled, and I’ve been using the shard that I get re-directed to after logging into account.smartthings.com.

As part of my testing I went through and entered a bogus client_id and secret and I get them same error message as when I have it entered correctly. This leads me to believe that I have some issue connecting into the nest api from NST Manager.

Has anyone else run into this and found a fix for it?

Cheers.

UPDATE: Resolved the issue by setting location in SmartThings Mobile app. Went into Hub settings, clicked the map, updated the location and clicked save, then clicked save again on the hub settings and I was able to register the app.


#3077

Hi, Is there some way to share this so it will show up in my wife’s account too? Both of our accounts are connected to the same hub but her account is not showing NST Manager. Thanks in advance.


(Tom Johnson) #3078

All of my Nest Thermostat Automations stopped working within the last two days. I have not been able to update from 5.3.5 to 5.3.6, there is nothing that i find in the Github repo. I keep on getting these text error messages. I’m completely lost…

Nest Manager API CMD Failed:
The (nestCmdResponse 1 (structures{away:home})) CMD sent to the API has failed.
Status Code: 429
ErrorMsg: blocked
DT: Sun May 20 14:24:23 EDT 2018

Everything had been working great for months! Please help.